Question about RTO PasLode 900420 Impulse Framing Nailer

1 Answer

Paslode 350 tell no light

I have a charged battery in my Paslode im350 but the warning light in the handle is out and there is no operation

Posted by Anonymous on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 206 Answers

If you have no light at all in the handle and you're sure you have a charged battery, then I would look at the battery contacts - that tool has the contacts molded into a circuit board assembly so if it is not obvious I would take it to a repair center to be diagnosed.

Posted on Jun 11, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 497 Answers

SOURCE: My paslode IM350 fires about once every 20

by service im assuming you mean replacing the o-ring and seals/gaskets. If not do that. But if you have it may be more of an internal problem with the air valve leaking around the piston.

Posted on Aug 10, 2009

  • 121 Answers

SOURCE: paslode 350 wont fire

Hi,
Probably needs cleaning. You`ll need two new o`rings.

Posted on Aug 26, 2009

  • 55 Answers

SOURCE: My paslode IM350 fires about once every 20

Check to make sure that the chamber is free of debris because the piston can get stuck if it is dirty it probably just needs to be cleaned and then lubricated really well and the problem should stop. Other outcome is the worse it could also be that the piston is bent and it gets hung up on itself then it would have to either be sent in for repair or to take it to a repair shop.

Hope this works

Posted on Dec 01, 2009

  • 165 Answers

SOURCE: paslode im350 will only now wrk properly when on a flat surface

Make sure the nails are inserted so that the follower maintains pressure on the strip of nails. Also, your pressure on the whole gun at an angle is probably not as great as on the flat---could lead to misfiring

Posted on Mar 02, 2010

rowdy45176
  • 2176 Answers

SOURCE: impulse gun wont fire and fan doesnt run

could be a bent probe not allowing full travel of the safety , fan motor, loose wire, or circuit assembly. If you are handy with tools, remove the battery and fuel cell. remove the 4 screws holding the cover on top of the cylinder assembly and down where the saety is remove the 2 screws there also. gently pull the cylinder off the tool. when you have apart check toe condition of the Oring on the top plate where the fan motor is. Now reinsert the battery and you will see a rocker switch towards the top, depress it and the fan motor should come on. if not try and depress the trigger switch and again the fan motor should come on. If neither start looking for loose or broken wires, if you find none then I would guess the terminal board would be bad. you can also remove the handle halves and look for a loose connection at the board itself, they sometimes wiggled loose where it plugs in. Good luck and let me know.

Posted on Apr 25, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Changed the circuit board on a Paslode IM350 and now the fan wont work any Ideas welcome


fan motor could have gone bad, spark unit(little black box in handle) could be bad. one of the three top conections could be loose, or hooked up wrong, battery contacts on end of circuit board assembly could be placed a little off( battery not making contact with circuit mold assembly) pinched one of the wires going to the trigger area, or fan area

Sep 26, 2012 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

Paslode im350 fires every time,but nails dont come out


Unless you have the wrong nails or a problem with the feeder and/or feeder spring it is probably dirty and the driver is hanging up on the cylinder. These tools need to be cleaned and lubed after using them for some time. If you look on Paslode's website there is a manual that explains how to do it. There are also videos on YouTube that show this. It is somewhat complicated and the tool has to be disassembled quite a bit. If you don't feel comfortable doing this work then you may want to want a servicing dealer that repairs these tools. There is a rubber o-ring on the head and a filter on the top that should be replaced too. Here is a link to the cleaning guide.

Paslode IMCT cleaning guide

Aug 26, 2012 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

When the trigger is pressed the light on the handle flashes green and red intermittently and nothing else happens. any ideas?


Hi,I believe that is a battery issue...either it is run down or not charging properly...

Here is a tip that I wrote about the Paslodenailers and the problems that can come up with them.

I also have a link to the Paslodemanuals which contain Paslodecleaning and troubleshooting guides.

If you need parts for your Paslode,there also is a link for a site that sells the Paslode nailer parts.

PaslodeCordless Nailer Problemsheatman101

Sep 18, 2011 | RTO Paslode 902000 IM250 Ii Cordless 16...

1 Answer

Paslode IM350 90CT Nail Gun gun light green gas full battery charged fan works gun wont fire


Try a different gas cartridge and make sure the top of the cartridge is snapped tightly onto the cartridge body.

Jun 23, 2011 | Air Tools & Compressors

1 Answer

IM350 when battery inserted flashes green then goes to red. Tried battery in other gun and works ok. Tried full charged battery (green in other gun) and led goes red in this one. Measured voltage at 6.74v....


Hi,

Check the battery contacts in the gun...

Here is a tip that I wrote about the Paslode nailers and the problems that can come up with them.

I also have a link to the Paslode manuals which contain Paslode cleaning and troubleshooting guides.

If you need parts for your Paslode, there also is a link for a site that sells the Paslode nailer parts.

Paslode Cordless Nailer Problems



heatman101


Feb 05, 2011 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

Hi .my im350 nail gun isnt working gas and battery ok and gun is cleaned.light on green .but when depresssed makes strange noise and lights on fire from fan end?


Hi,

Here is a tip that I wrote about the Paslode nailers and the problems that can come up with them.

I also have a link to the Paslode manuals which contain Paslode cleaning and troubleshooting guides.

If you need parts for your Paslode, there also is a link for a site that sells the Paslode nailer parts.

Paslode Cordless Nailer Problems



heatman101



././

Oct 24, 2010 | RTO PasLode 900420 Impulse Framing Nailer

2 Answers

Problem with battery connection


if you remove the battery and look into where the battery goes at the bottom you will see the two prongs that make contact with the battery pack gently pry away from the side not to far but just a bit if you can not insert battery when done you pried to, far just bend them back until all works properly

Nov 11, 2009 | RTO PasLode 900420 Impulse Framing Nailer

1 Answer

My paslode IM350 fires about once every 20


by service im assuming you mean replacing the o-ring and seals/gaskets. If not do that. But if you have it may be more of an internal problem with the air valve leaking around the piston.

Aug 03, 2009 | RTO PasLode 900420 Impulse Framing Nailer

2 Answers

Paslode im350 has indicator light flashing red/green


The nailer’s electrical system has gone into overload protection. There may be something wrong with the fan motor or the wires going to the fan motor. Remove the cap and grill to inspect the red and black fan motor wires. If the wires are pinched or broken, that may be the problem. It may also help to disconnect the small white connector on the wire assembly that goes to the motor and then reconnect it.

Jun 22, 2009 | Tools & Hardware - Others

Not finding what you are looking for?
RTO PasLode 900420 Impulse Framing Nailer  Logo

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top RTO Air Tools & Compressors Experts

John Trevino

Level 3 Expert

1383 Answers

Brad Brown

Level 3 Expert

15557 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Are you a RTO Air Tool and Compressor Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...