Question about Ovens

1 Answer

Took 30 min to heat up to 320???? - Ovens

Posted by on

  • kwt31113 Jun 22, 2009

    Is that the bottom element that is not getting red except for one little part of it. Can i buy one and put it on myself?



    Thanks,

    Kim

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 212 Answers

Need to replace oven temp probe

Posted on Jun 22, 2009

  • kenrick driscoll Jun 22, 2009

    sorry misunderstood your question. yes if only part of the element is getting red then you need to replace it. take your model number to a local parts dealer and buy the element. unplug it before you do anything. element should be held in place with screw at back of oven. pull towards you and you will see where you connect the wires.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My whirlpool oven (AXP206/IX) is not reaching the temperature I want, 200c. It will only go to about 175c. Any ideas please?


are all the elements heating (glowing ) when on , ifnot then the ones that are not possibly need replaced .

Oct 28, 2015 | Whirlpool Ovens

1 Answer

Gas oven takes 30 mins or more to to preheat


Open the bottom and have a look at the burner while its heating. The flame should be strong blue/white and both sides the same, if they are not you have some blocked holes in the burner. Remove the burner and clean out the holes (carefully, don\'t ream them out, use a small paperclip to clean them, be gentle.). Above all do NOT use any kind of oven cleaner on them, if they are aluminum, and most are the oven cleaner will destry it.

Jul 29, 2014 | Kenmore Ovens

1 Answer

Belling XOU69MF Tripping breaker after on for 30-40 mins after steam cleaning


That's why you use easy off. LOL
If you have run it twice then any moisture should be gone, besides if it was moisture it should trip quick, sounds like a bad element causing the trip. I have never seen a breaker go bad, but they can.

Mar 30, 2013 | Ovens

1 Answer

Oven is taking to long to heat


look for the temperature sensor inside the oven cavity in the upper left or top center of the upper oven cavity,its will be a silver or copper colored rod about 1/4" by 2" to 6" long this rod senses the oven temp and cycles the heat to the oven

Jun 03, 2012 | Kenmore 30464 / 30465 / 30469 Gas Single...

1 Answer

My oven is taking 30 min to heat up to 350 degrees. the light sensor is turning orange what might the problem be??????


Hi,
If your electric2_bing.gif oven is not heating then you probably have a bad heating lelement in your oven. This is not that hard to fix yourself...
Check out this tip that I wrote about the Oven not heating problem..

Oven Problems Electric2_bing.gif Oven is Heating Slowly or Poorly
http://www.fixya.com/support/r4511800-oven_problems_electric_oven_heating

heatman101

May 07, 2010 | Maytag CWG3100A Gas Single Oven

1 Answer

Oven heating really slow


yes it sounds as if there is a "HOT-SPOT" on the element which will look like a dis colored spot and will be either bubbled up or have pock marks where its burning thru and can no longer pass sufficient current to heat the element fully

Apr 04, 2010 | Maytag 30 in. Electric Single Wall Oven...

1 Answer

SLOW HEATING OVEN


you may want to check your broil element
turn the unit on and wait a few minutes
see if you can feel the heat from the upper broiler elemnet
some model use both elements to preheat
i dont have your productiuon number so i cannot be sure with your model
anyway
14-20 mins is the industry standard for a 350 preheat...

Oct 25, 2009 | GE 30" Built-In Single Electric Wall Oven...

1 Answer

Oven cuts out


Most of the time it is a temp sensor in the oven. We bought a service manual at houseneeds.com and fixed ours.

Nov 30, 2008 | Ovens

3 Answers

Oven won't stay on and give an F error message


Disconnect the power. Disconnect the sensor harness from the control. Measure the sensor resistance (white leads). The resistance should be 1080 ohms at room temp. If the sensor is open the resistance is usually over 2900 and you get an F3 message. If the sensor is shorted the resistance is usually less than 950 ohms and you get an F4 error message. Also look for damaged harness terminals if not a bad sensor.

Aug 31, 2007 | Ovens

Not finding what you are looking for?
Ovens Logo

Related Topics:

54 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ovens Experts

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

ashburton

Level 3 Expert

417 Answers

yadayada
yadayada

Level 3 Expert

76132 Answers

Are you an Oven Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...