Question about ECHO, Inc. PB-251C Handheld Blower

1 Answer

Same problem here also..

Was running great than I noticed last time it would not run all the way up .Now it wont run past half throttle..But it will rev up if you cover the blower nozzle with your hand..Need help bad..I run very clean fuel.Air cleaner is clean..Please help

Posted by on

  • 2 more comments 
  • aboutime_2 Jun 22, 2009

    Cant see a adjustment screw.Cable good and I run very clean fuel

  • aboutime_2 Jun 24, 2009

    UPDATE to this delema..I got no help from Ecko but they have heard of this problem before.No help from the common fixs..I was so mad..The thing was running fine One Month ago.I took all the things apart that needed to be inspected.Then I took Off the starter cord assm.I flip flopped the blower everyway possible looking for anything funny looking ..All of a sudden I see this black tube coming out of the tank going to some small white can looking thing hidding in the case..It was all so small I got my needle nose plyers out and carefully sneaked the tube and canister out from its hidding place..It was a big ball of dirt.I sprayed it off with carb cleaner and it looked like new ,White..Put it back carefully and replaced the starter coil cover ***.Then I went into the house found the blower break down on Echo's site for the blower parts breakdown .Looked to see what the hay the part was,,part number 10 on the PDF breakdown and lo and behold it was a tiny vent..I also see it is on My Echo weed wacker..Well I went back outside and Fired that puppy up.Keep my fingers crossed and squized the trigger for full throttle and WaLA.She reved all the way up like New.So Now ME happpy.I hope this helps out some of you Blower Dudes out there..Peace Out.

  • aboutime_2 Jun 24, 2009

    O by the Way thanks for all the help from the the helpers here..Much appreciated..

  • aboutime_2 Jul 09, 2009

    My update -update.....Echo carbs have a little black plastic plug covering the High speed adj screw..CA air pulotion control bs..So get that little black blug out and give the screw a little turn open and u should be good to go..It worked for me..on a PBL 251 blower..My Echo weed wacker has the carb also..Go to Echos site and download the parts break down for your unit and look at the carb page..You will see the plug and HS,screw..happing wacking and blowing

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

The carb may need to be adjusted or taken apart and cleaned. Also check the throttle cable to make sure it hasn't been streched out.

Posted on Jun 22, 2009

  • Nate Stansfield
    Nate Stansfield Jun 22, 2009

    Some do not have the adjustment screw. Is there a fuel filter on this model? If it does, I would change that first. If not, carb will need to be pulled off, pulled apart, and placed in solvent for cleaning.

  • Nate Stansfield
    Nate Stansfield Jun 24, 2009

    Sometimes you have to feather the the throttle for a minute, and then give her a good squeeze. sometimes they are tempermental when first starting to run

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My troy built riding mower won't run full throttle it only run at about half throttle


if it runs good at half throttle, it just wont throttle up it sounds like the throttle cable has slipped. you might try to adjust it to get full throttle back .but if when you turn it up to full throttle and it dies then you have a choke, carburetor, fuel line, fuel filter or fuel tank problem. hope this gives you an idea.

Mar 29, 2016 | Troy Garden

2 Answers

Leaf blower runs on half choke


My craftsman leaf blower ran great for 4 years.. It stop running on me one day while using it.. I replace the carb, muffler and fuel filter with a new one.. it still will only run when the choke is half closed and don't run good doing that.. I have also noticed oil around the plug and muffler. I have to use either to get it started and I noticed when I pour a little oil in the spark plug hole before cranking it seems to run loner but not at full throttle think it might be piston rings shot.

Nov 11, 2013 | Craftsman 25cc Gas Blower

1 Answer

My briggs and stratton engine throttle cable and throttle body wont engage,always wide open


Are you sure it's not a new style Briggs that uses the 'throttle cable' just as a shut off? Many new mowers on;y start and run at High Speed

Jul 05, 2013 | Briggs & Stratton Garden

1 Answer

Got a yamaha bruin 350 runs great wont take throttle when in gear.


Will the bike rev in neutral? If so, but not when in gear it sounds like the crotch might be slipping. GOOD LUKE.

Jan 20, 2013 | Motorcycles

2 Answers

Chugging issue....


the fuel pump is going bad

Dec 01, 2012 | 2002 Ford Taurus

1 Answer

9.9 evinrude, yr 1990..runs like a new motor but wont throttle up past about half speed..once or twice it kicked in and took off but only for a few minutes then went back to half speed..sometimes it will...


Check the fuel tank for water.Squeeze the fuel line bulb and see if that gives a boost,and if it does you may have a blockage in the tank or in the carbs.If the bulb contracts when the engine is running,you have a blocked pickup in the tank.Check the vent on the tank is not blocked.The symptoms you give all lead to a fuel problem.Also.Check to plugs after you have run the motor.If one looks darker than the other.Change them both.Hope some of this may help you

Sep 02, 2010 | Light Outboard Motor Boat Bass Fishing...

1 Answer

Leaf blower that wont run at high rpm


You need to replace your fuel lines.

Nov 09, 2009 | Garden

1 Answer

My 420 with an onan runs great at half throttle, then bogs down.


Are you sure you did not get the jets in the wrong places when you cleaned that carburetor.

Aug 23, 2009 | John Deere Garden

1 Answer

2000 Chevy Blazer Cranks but wont start...


What about the fuel filter????? Have you changed it out??? If you can spary something like a started fluid, that means it is a fuel problem. My last check, it has to be above 50-psi on the fuel pressure to make it run right. I had 35psi, but whould not get over 30mph or down hill maybe 45mph. Check both filter & pressure, but check pressure with a New fule filter!!!!

Jan 18, 2009 | 2000 Chevrolet Blazer

Not finding what you are looking for?
ECHO, Inc. PB-251C Handheld Blower Logo

471 people viewed this question

Ask a Question

Usually answered in minutes!

Top Echo Garden Experts

Jim London
Jim London

Level 2 Expert

257 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

colesmowers

Level 2 Expert

38 Answers

Are you an Echo Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...