Question about MTX Audio Tna251

Open Question

Mtx tna251 amp no sound tried two different subs

I have tried two subs and still no sound? the three lights flash then stay on?

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 631 Answers

SOURCE: mtx 1501d no sound

There are a number of things that can cause it to act as you described. Have you pulled the covers off of it yet to see if you can see any problems?

If you do, disconnect power from it and don't touch ANYTHING on the board when ANY of the 3 LEDs (2 are not visible from the outside) are lit.

Posted on Aug 19, 2008

  • 5 Answers

SOURCE: Mtx TC-6001 Amps Problem

I had same problem with a TC6001 and get solution from MTX, not send to MTX instead MTX kindly sent a quotation for parts to be replaced, I can tell you what parts need to be replaced if you still need a solution.

Posted on Dec 29, 2008

  • 36 Answers

SOURCE: mtx 1000xd led light is flashing and the subs will not work

The light flashing usually means there is a short somewhere. Check your wires to make sure there are no slices and are touching. Also check to make sure you have your remote wire hooked up.

Posted on Sep 21, 2009

thepot
  • 188 Answers

SOURCE: Sub not working and red light on amp stays on?

the amp is under to much pressure get a bigger 1

Posted on Nov 18, 2009

  • 1 Answer

SOURCE: MTX Thunder 81001 wont push subs

first of all you should check the minimal impedance your amp handles , if is class d it should handle between 1-2 ohms total impedance in a mono conection , meaning whatever quantity of subs you have hooked to your amplifier,their total impedance should the minimum the amp handles that way all the power from your amplifier will be used.

Posted on Jan 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mtx tna251 amp has bass remote that has a light glowing but turn knob up and down and no difference like simply not working no difference in bass? Posible causes,


It is actually in the controller, if you turn the remote all the way down and press on the controller until the bass goes off, you will be able to turn the bass up and down with the remote, mine worked but stopped after a month, I tried adjusting the amp but then I noticed that if I wiggled the knob on the remote that it would work, I mashed mine until it worked again and velcroed it to my console sonibcan get it on and off easily.

Mar 03, 2015 | MTX Car Audio & Video

1 Answer

I bought a mtx terminator amp model no TNA251 600 watt and two subs installed. It works good for few days but now its not cranking up proper bass and sound. It always has three solid red lights everytime....


does it do this all the time when you turn it on? any sound at all?
provide more information, but my guess its that the amp is blown. replace it or sell it for parts.

Nov 11, 2013 | Car Audio & Video

2 Answers

MTX tna251


I have the same sub combo. The problem is the amp is underpowered for the 2 MTX 12s, get a bigger amp and you should be fine.

Nov 13, 2011 | MTX Car Audio & Video

1 Answer

I have 4 mtx 9500 12in subs 2 of them is on a mtx 92001 and the other is on a mtx 4001d . would it be better to run all four on the mtx 4001d. for more power and a better sound or how should i run this set...


NEVER mix different power amps. Depending on the ohms of your subs, sell one of the amps, up to you. The 4001 has more power, but either amp will do the job, the amp needs to see a 1 ohm load, so your subs have to be dual 2 ohms, or single 4 ohms to do this. If your subs are dual 4 ohms then you will have to run your amp at 2 ohms which would be have the power, or a half an ohm, (Not Recomended) and be at double the power. You may be able to do a competion sound off and just "Burp" the subs, but at a half an ohm, dont expect to listen to it to long before it goes into protect and shuts down.

Sep 06, 2011 | MTX Thunder Elite TE4001D Car Amp

1 Answer

What is the HLI port on the MTX tna251 amplifier?


What is the HLI port on the MTX tna251 amplifier?

Jul 15, 2011 | Car Audio & Video

1 Answer

Sub not working and red light on amp stays on?


the amp is under to much pressure get a bigger 1

Nov 18, 2009 | MTX Thunder 421D Car Audio Amplifier

1 Answer

Not working


disconnect the subs from the amp and check to see if the amp will turn on and stay on-check the subs to see if they are blown with a different source try a pair or a single sub that you know works fine on the amp and see if it plays-this should tell you whether your amp is fried or your subs are roasted

May 19, 2009 | MTX 4002 Car Audio Amplifier

2 Answers

Just got this amp, and was wondering what subs I should get with this amp


Did some research and it sounds like a wicked lil amp with clean clean sound-its hard to say what subs to tell you to run because everyone has different taste- and without knowing what your setup is going to be theres no real way to actually say-the amp is made to run 3 channels -so focusing on the sub channel only i personally say get a pair of 10s or a good 12-your not throwing a ton of power so you dont have to go balls out on the subs- i personally like MTX subs and xtant is made by MTX so that wouldnt be far from home -good luck with that

May 19, 2009 | Xtant 403A Car Audio Amplifier

1 Answer

Car audio


hi, your amp seems to be getting power but the cables might be wrong so it's not getting enough power. the light on the amp should be green if everything is going well. are you sure the cables are suitable for your amp?

Sep 11, 2007 | MTX RT202 Car Audio Amplifier

Not finding what you are looking for?
MTX Audio Tna251 Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...