Question about Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

Dub4001 overheated now protect light comes on

I have had a dub4001 mono amp layhing around for a long time, i have since given up on fixing it and went onto bigger and better amps. but none the less i would still like to get it working. here goes. it was driving a 2 ohm load for about 3 months before it died on me. in the process i had over heated it. looking in the case nothing is melted or burnt. so where to start looking? do i look for the thermal protect circuit? what parts normally go bad when overheated/ burnt up? any help would be great

Posted by on

  • eboucher Jul 06, 2009

    i appreciate the info but, if its stable at 1 ohm its stable at 2 ohms, and this amp is only stable at a 4ohm load. so by dropping it to 2 ohms like i did i doubled the output. if it was at a 1 ohm load it would be quadrupled( excuse spelling), but i will have to check the caps

  • steve woodley May 11, 2010

    resistors capacitors and mosfets are ussually the first circuits to go. The mosfets are screwed onto casing providing heat distribution check those they cannot have any cracks or dents or divits look closely

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers

Look around the power input on the amp on the inside and wiggle the capacitors around to see if any of the legs burned up because sometimes the tops don't pop up instead they burn the leg off and just so that u know that amp is not stable at 2 ohms only 1 ohm

Posted on Jul 06, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Protect Light On Amp Being Weird


Could try switching right and left subs. If the problem moves to the other side pull the wiring and redo.
Then if the wiring is ok check the sub.

May 15, 2013 | Jensen JPA600D - 600 Watts Digital Mono...

1 Answer

NAD M3 power light turns red immediately and PROTECT message displays. Amp keeps functioning but volume control doesn't work up or down.


Hello
Check the connection to speaker with this amp, for any short or any other fault. disconnect the outputs, ie, speakers from the amp, and switch it On, and see the protect display comes or not. If it comes, the fault is internal and the set need service.
Your M3 dual Mono integrated amp, is of high output power and its outputs are protected against any overload or short circuit. If the system detect any among this condition specified above, it will show protect mode display.
Never load this amp, as protection display is there, as it may damage the speaker or its internal power amplifier section circuits, may cause more money to get it repaired. OK.

Jan 23, 2012 | NAD M3 Master Series Integrated...

1 Answer

I have a Sony Xplod 800w Amp running a 10' Sony Xplod Amp....i unhooked the amp to do some moving and i tried to put it back in today and it didnt have any sound coming from it! I did notice the power...


it sounds like it could be a blown channel in the amp. if the sub was blown it would still work just sound horrible. i have blown many subs and amps. you can bring it to an audio shop near you and they can fix it. i just got one of my channels fixed for 35$

May 11, 2011 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

1 Answer

I melted the input for my 12 volt connection well just the plastic around it. Is there anyways i can fix this, or does someone know where i would be able to send it in to be fixed? My amp still gets power,...


The high current drain due to a possible short in the sub output drivers must have pushed the connectors to melt off and fail.
Your amplifier driver MOSFETS might have shorted to bring about the protection on. Make sure that the wiring to the sub woofer is not touching a ground or shorting.
You can ask any audio tech. to have a look within and test for shorted driver outputs.

Sep 17, 2010 | Digital Audio 1500 WATTS CLASS D MONO...

1 Answer

I have a JL total mobile audio T500.1 mono amp and it was playing then all the sudden it stopped and the power light which is usually green is now red and stays red and no sound comes from the subs any...


This happens when the amp goes into protection mode. 90% of the time, it means there is a short or has another issue inside the unit and has to be fixed or replaced. Hope this helps and good luck!

Jul 09, 2010 | Jl Audio Car Audio & Video

1 Answer

What does it mean when the red protection light illuminates


Hi the protection light comes on when there is a problem within the amps. circuitry. Generally speaking the protection light normally comes on when powered up while the amp checks all of its voltage rails so that they all lie within a specific tolerance, when all have been verified to be in spec. then the protect light goes out & the power light comes on. If the protect light stays on then a fault exists within it's circuitry. Cheers, acbva.

Nov 14, 2009 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

1 Answer

I have a TN250/1 MTX class D, mono-block amp, protection light comes on and thats it. Whats the problem?


Two things, a problem with the speakers, or the amp is toast. If there is a short is the speaker, wire touching, bad voice coil, the amp will go into protect. I have also seen many, many MTX amps that go bad, and just stay in protect. the easiest way to check, is to unhook the speaker wire from the amp, then power it up, if it still goes into protect without a speaker hooked to it, you have a bad amp. Hope this helps.

Aug 17, 2009 | Car Audio & Video

1 Answer

Protection Function flashing with error code E-2


I do believe that error is a short between the positive and negative terminals. Check your wiring and measure with with a ohm meter, it should be more that 1, if not 2 ohms. With the wires from the speaker termanils removed and the amp off check the condinuity between the two terminals, there should be none...if you have some that thats where the short is occuring and work needs to be done on the amp to fix the problem

Dec 15, 2006 | Kenwood XXV-03A Mono 25th Anniversary...

Not finding what you are looking for?
Ultra Linear UL-2200D Car Audio Amplifier Logo

Related Topics:

93 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ultra Linear Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

FastHarley
FastHarley

Level 3 Expert

637 Answers

matthew nulph

Level 1 Expert

46 Answers

Are you an Ultra Linear Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...