Question about Amplifiers & Preamps

1 Answer

KR-v 6050 amp

When i turn it on ,it shows protect on the screen and won't start properly

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 54 Answers
Re: KR-v 6050 amp

Possible internal short on Sterero power amp ics. Check for low winding resistance on main power transformer.

Posted on Nov 03, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

How to troubleshoot a kenwood kr 5600

These older tuner/amps have protection relays that when latching, are distinctly audible. Does the relay engage after approx. 10 seconds after turn-on? If not, check your speaker wires and/or speakers for issues. With all speakers (and wires) disconnected, the relay should still latch after turn-on. If not then you have an internal problem...likely a older pre-drive transistor that's bias is incorrect, which in turn causes bigger problems downstream.

Jun 01, 2014 | Kenwood Amplifiers & Preamps

1 Answer

Crowm micro-tech 2400 goes straight to protect upon start


Lets get this straight, you are saying that a CROWN MICRO-TECH2400 power amplifier show the two front red lights when you turn it on? Because it supposed to do that if everything is fine, when you turn your amp on and one of the lights or both don't turn on then you have a serious issue with this great amp, keep me informed in case you need further help.

Nov 07, 2013 | Crown Amplifiers & Preamps

1 Answer

When I try to turn the amp on, all I get is a flashing red light flashing beside stand by. Nothing comes up on the screen and nothing seems to work. It's always worked fine before, today it shut off on...

It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Mar 14, 2012 | Onkyo Amplifiers & Preamps

1 Answer

NAD M3 power light turns red immediately and PROTECT message displays. Amp keeps functioning but volume control doesn't work up or down.

Check the connection to speaker with this amp, for any short or any other fault. disconnect the outputs, ie, speakers from the amp, and switch it On, and see the protect display comes or not. If it comes, the fault is internal and the set need service.
Your M3 dual Mono integrated amp, is of high output power and its outputs are protected against any overload or short circuit. If the system detect any among this condition specified above, it will show protect mode display.
Never load this amp, as protection display is there, as it may damage the speaker or its internal power amplifier section circuits, may cause more money to get it repaired. OK.

Jan 23, 2012 | NAD M3 Master Series Integrated...

1 Answer


The manual would suggest you have a problem.

Register and download the manual for free at

Try unplugging all of the speakers and see if that amp is still distressed. If it looks clean and happy start adding speakers until it returns (or not).

Jul 03, 2011 | NAD M25 Amplifier

1 Answer

After playing for a while my Sony Surround Amp cuts off and shows a PROTECT Reading in the window.

Sounds like the amp is protecting itself from an over-current situation.
This happens when the machine has to try too hard to get sound out to the speakers.
There are several possible reasons.
You may be using the wrong impedance speakers for the amp.
-some amps only work with 8ohm speakers
-some only work with 4ohm speakers
If you have a short circuit in the speakers or in the speaker wiring, that could cause the amp to overwork and go into protection.
If you connect up multiple speakers to the same single output of the amp you effectively short out the amp and cause it to overwork also.
Before troubleshooting, blow out the amp, dust inside can cause lots of problems with the electrical systems. Use canned air and do it outside with fresh air.
To troubleshoot :
1. check to see that the amp and the speaker have the same impedance number, either 4 or 8ohm. This is usually printed on the back of both. If they do match go to step two.

2-unplug all the speakers, add one speaker(left one) and test it for awhile to see if it goes into a protection mode. Next move that same speaker to the right side output and run it for awhile to see if it goes into protection mode. Repeat the test with your other speaker, moving it to both outputs(L&R) to check if it works. If the amp fails with either speaker on either output, you may have a mismatch of speaker and amp or a bad amp. If you have only one speaker that causes a protection, then you have a bad speaker or it's wire. If both speakers go into protection, get different speakers and test again. if it works for all of these tests, go to step three.

3.hook up both the left and the right speakers to the amp. be sure that the wires are stripped cleanly and twisted tightly, if you have screw on outputs that is. Test for proper operation. At this point you should know if there is a single speaker causing the protection or if it is a amp malfunction.

Jan 28, 2010 | Sony Amplifiers & Preamps

1 Answer

The power protection kicks in when I turn up my radio volume

ground wire connection or possibly amp is turned up to high when an amp is turned up all the way it starts pushin dc voltage also it could burn out the internal battery check all connections and settings after that make sure subs arent begining to blow a sub that starts to blow kicks of the amp hope this helps

May 21, 2009 | Sony Xplod 500W Bridgeable Multichannel...

6 Answers

Technics SU-G75

I had the same problem. The solution to me was presoldering transistor Q708.

Feb 05, 2009 | Technics SUV500 2-Channel Amplifier

2 Answers

Ppower on then standby problem Kenwood KR-V8060

This fault may be similar to a Harmon Kardon AVR1550 fault I recently encountered. I did all the usual checks e.g. testing for presence of DC on speaker outputs etc. but all seemed fine, then the fault cleared! Next day it re-appeared and attention was (falsely) given to the protection circuits as the amplifier circuits themselves were considered to be in order. The HK uses both voltage and current protection circuits and it was discovered that the current protection circuit was operating. Eventually the fault was found to be one of the 0.39 Ohm 3W metal oxide resistors that had gone high in value on the left hand channel. Of course your amplifiers fault may not be due to this but the reason for going into standby would probably be the same i.e. due to amplifier protection circuits operating. You need to check out all the output devices and those resistors on every channel, even surround ones you may not be using. Hope this helps.

Nov 01, 2007 | Amplifiers & Preamps

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts


Level 3 Expert

4518 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

66552 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides