Question about Electrolux Central Vacuum

1 Answer

Electrolux Central Vac- One hose works well, one does not

We have 2 hoses, upstairs and down. The downstairs one has minimal suction, the second one works well in the same outlet.
I used a plumbing snake in both ends and found approx 90% of the hose clear. Is the blockage in the middle 10% or can there be another problem?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 58 Answers

If its an older hose it might be crunching up when the vacuum is running that couses a loss is airflor due to high resistance. if this is the case the hose should be replaced.

Posted on Jul 26, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an older model Electrolux central vac. When I put the hose into the wall outlet, the cannister comes on but there is no suction ? What is needed to correct this?


Three things are the most likely.
1. Since it's an older model, the hose is likely well worn and probably has leaks at each end where it attaches to the handle and connector at the other end. If this is the case, a new hose is needed.
2. A blockage in the hose. To check the hose for blockages, detach both ends and drop a coin down one end. Lift the hose a little at a time so coin drops out the other end. If it doesn't, there's a clog. It will probably need to unclogged at an authorized Aerus Electrolux store.
3. A dirty filter. This is probably the first thing to check for, since it's so easy. If it's dirty, it needs to be thoroughly rinsed under warm water. Then allowed to thoroughly air dry prior to use. For this reason, it's highly recommended that an ECV owner have an extra filter on hand.

Is there suction at the end of the hose, or is it just at the power nozzle there's none. If the hose has good suction, check the power nozzle airway. If it's blocked it can easily be cleared by pushing the clog back toward the brush with the handle of a wooden spoon, or other similar object.

Jan 15, 2011 | Electrolux Central Vacuum

1 Answer

What do I do when there is no suction. My central vac just stopped picking up and though I emptied the machine and replaced the filter there continues to be no suction.


1. If it's an older model, the hose is likely well worn and probably has leaks at each end where it attaches to the handle and connector at the other end. If this is the case, a new hose is needed.
2. A blockage in the hose. To check the hose for blockages, detach both ends and drop a coin down one end. Lift the hose a little at a time so coin drops out the other end. If it doesn't, there's a clog. Please don't try to take it apart to remove the clog. If you can't get it out, take it to a reputable vacuum repair shop and let them.
best way to clear an obstruction is to blow it out by attaching the wall end to the exhaust of a shop vacuum, or using an air compressor.
You can try holding the wand end of the hose directly to the CV in port and turning the machine on. This provides essentially the same action as the previous method.
If neither of these work, try a combination of the two. Or using a shop vac, hold the wall end to the exhaust of the vacuum and the wand end to the in port of the shop vac. Turn shop vac on and the obstruction should come out.
Borrow a good strong shop vacuum if you need to.
If these methods fail, take it to an authorized Aerus Electrolux store and have the service tech try to clear it. Care must always be taken when trying to clear an obstuction with a long object, especially if it's pointed. I've seen many hoses that have shorted out and even caught fire due to the wiring accidentally being "nicked

3. Is there suction at the end of the hose, or is it just at the power nozzle there's none. If the hose has good suction, check the power nozzle airway. If it's blocked it can easily be cleared by pushing the clog back toward the brush with the handle of a wooden spoon, or other similar object.

Jan 15, 2011 | Electrolux Pu3650 Central System Vacuum

1 Answer

Poor suction in system - I have used shop vac to suction all three receptacles. Have checked bag and cleaned everything. Still poor suction. I have one receptacle in garage that works perfectly. Must...


Have you checked the hose for clogs or leaks. Clogged and leaky hoses are an area of concern with any central vac. Unless you hose has a hose sock, then wear and tear from constant rubbing on floors and other surfaces will result in holes and cracks. Pulling the hose can also result in leaks where the hose attaches to the handle and intake connector.
Mix some dish soap with water.
Use shop vac to blow air through hose, with other end capped or "clogged".
Apply soap solution to each end of hose.
If bubbles form, this indicates leakage. Hose will need to be replaced.

Oct 25, 2010 | Broan-NuTone CV450 Central Bagged Central...

1 Answer

Have an electrolux 2100 canister vac, it has lost suction power thru the years. no clogs in newer hose or in sweeper. even with new bag, filter and belt only increases power minimally.


Have you ever over the years replaced your brushroll ? Have you tried dropping a coin thru the hose from one end to see if it comes out the other end ? Have you taken the wand loose from the elbow ( the swivel part of your carpet sweeper) to see if there was a blockage ? Does the motor make a strange noise ? Have you ever had a tune-up on your vac.
You might think about taking your vac to your Aerus/Electrolux shop.
Joe

Nov 19, 2009 | Electrolux Vacuums

2 Answers

My electrolux central vac outlets work on the main


You might have a plug or clog in the upstairs lines. for information on how to remove a clog in a central vacuum system see this article:

http://centralvacproducts.blogspot.com/2009/01/how-to-unclog-central-vacuum-system.html

Oct 24, 2009 | Electrolux Central Vacuum

1 Answer

Low suction


1) Have you checked the filter? If it is clogged your suction will be low. Also, you could have a pipe loose where you can't see. Make sure that you can get a coin to go all the way through the hose. make sure the suction motor ( the unit ) is coming on.

2) Call the repair man.

Aug 10, 2009 | Electrolux Central Vacuum

3 Answers

I need a new hose for my Electrolux central vac


Do you need a new powerhead too or only the hose? If you need a new powerhead than I would recommend looking at the Imperium Pro Elite Attachment set. It is an excellent quality powerhead and hose. If you only need a new hose than you will need to contact the Aerus because they will be probably be the only company who can sell you a hose that wil be compatible with your powerhead. Their website is http://www.aerusonline.com/products/

Jan 21, 2009 | Electrolux Central Vacuum

2 Answers

Electrolux central vac problems


I work on many types of units. If you electric floor brush runs but you have no suction then there is possibly a problem with the relay board that allows you to turn on the suction from the hose handle. This is a low voltage (24 V) switching loop circuit that will cause the 120 V motor in the unit to run.

Inside the wall valve are two brass pins. NOTE: there are 120V valves installed on some systems known as a Super Valve. A shock hazared exists if you work on that type of valve. That being said. In the round portion of the valve you can use a garage hose that has a 360 deg. chrome ring to test the valve. The ring completes the circuit causing the unit to power up and suction at the end of the hose. If the suction is weak, there is a colg in the pipe. If you hear no airflow, the relay inside the unit did not energize or the motor is bad.

To test: go to the unit and turn the switch on the side to "manual" if the unit turns on the motor should be ok. DO NOT RUN THE UNIT without and open valve. In some brands dammage to your motor will occure.

If the unit did not run, look for a small button near the switch. This is a circuit breaker for the motor. If it is poped out and you hear a "click" when you press it in there is most likely motor problems and someone should be contacted for repair.

Hope this helps!!

VR

Mar 07, 2008 | Electrolux Central Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...