Question about Lincoln Electric LINK2400-+2 CV-305 MIG Welder with Options Input Power: 23

2 Answers

Lincoln Pro-mig 175 w/ no wire feed but relay clicks fan runs

Machine code 11009

*no voltage at wire feed motor
*relay clicks when trigger is pulled
*fan runs
It worked fine when I put it in storage for about 18 months. I finally got into a new shop and went to use the welder. Everything seemed fine untill I went to pull the triger and no wire feed...

I traced the wires from the feed motor to the circuit board and nothing looked suspicious. I'm guessing it's something with the integrated curcuit board. But it worked fine when I put it in storage...

Posted by on

  • Ned C Cook
    Ned C Cook May 11, 2010

    Are the drive spools turning?

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Normal 0 false false false MicrosoftInternetExplorer4 /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} The problem with my MIG 175 Pro is the "voltage selector switch" (part # M15750-1). I took it apart and saw all of the contact points where corroded. I can hold the knob between two settings and the machine will work.

I have the same issue only after about a year of very light use. I am not sure how to prevent this from happening again.

Posted on Sep 04, 2009

  • NeonDion Apr 13, 2011

    My mig SP-135T had the similar problem with the Voltage Selector Switch. One of the contact points was totally gone. I recall it sticking and being hard - also after sitting in storage for several months.
    I ended up needing my welder BAD, so I jerry-rigged it. I took regular 110 house electrical wire (12 gauge), wrapped it around the contact point, (twice) and it left an even height on the Voltage Selector Switch. I did some testing at low voltages using .035 Flux wire and slowly worked my way up to max voltage. It worked fine and never even sparked once.
    So I closed up the cover and it awaits it's next welding project. I hope to replace the Voltage Selector Switch - if I can find the part. I did find a parts breakdown at searspartsdirect.com, search for model SP135T. Thanks and God Bless!

×

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 225 Answers

Is the unit set for the right input voltage.

Posted on Jul 02, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Our Lincoln Pro Mig 175 won't feed the wire. The trigger clicks and the motor works but will not feed the wire. There's a burnt resister or capacitor on the pc board and the only numbers that we...


Hi:
If your wire feed motor turns, then your problem is one of the two:
The gun's liner is kinked and no longer is allowing the wire to pass freely, or Your outlet wire guide/drive rolls are all worn out.
Easy fix will be to star with changing the liner and new contact tip. But if all that is working is your fan motor, then check your gun's trigger, if gun's trigger is OK, then change the pc board. Good luck!

Aug 29, 2011 | Lincoln Welding Tools

1 Answer

Wire feed speed was surging & now the motor just clicks & turns about 1 degree on the rollers. I suspect it may be the relay for the drive motors. Any help with this problem is...


To test your theory you'd need to check the voltage going to wirefeed motor with a multimeter set to DC voltage. This is dangerous as you'd need to have the covers off the machine. If the motor was getting voltage the whole time you pressed the trigger the fault would lie in your wire feed motor gear box. If it is a small mig welder, i would think from the sounds of your fault that it is the gear box that you're having trouble with. To find a replacement you'd need to write down the model number of the mig welder and order a replacement part through a repair shop.

Jun 07, 2011 | Pro Line Welding Tools

3 Answers

I have a brand new Lincoln pro mig 140. Took it out of the box and set it up yesterday. After approximately two hours of mild steel welding today the wire drive roller quit working. I've tested the...


I'm having a problem with the wire feed on my Lincoln Pro Mig 140. The wire feed speed is not consistant. It seems to be slipping even though the tension is tight. Any solutions?

Oct 18, 2009 | Lincoln Electric LINK2400-+2 CV-305 MIG...

2 Answers

Wire doesn't feed


Either the trigger mechanism in the gun is bad, the servo that turns the feed wheel is bad, or you have too much tension on the adjustable tensioner knob. Take the wire out of the feed wheel, plug unit in and see if you can get the wheel to turn. If not, it is the trigger or the servo. If it turns, the tensioner was too tight.

Jul 10, 2009 | Lincoln Electric LINK2400-+2 CV-305 MIG...

1 Answer

I have a sp 100 lincon pull the trigger it clicks, no wire fd


not diode problem,check enternal wiring and relay for feed motor.

Jun 25, 2009 | Lincoln Welding Tools

1 Answer

No wire feed


If the power to the unit/fan is on and the relay clicks the fuse is not the problem. Check your motor connections. Either you have a bad motor/wiring to motor or motor speed control board.

May 22, 2009 | Lincoln Electric LINK2400-+2 CV-305 MIG...

2 Answers

Northern tool mig welder,120 volt with gas.The wire feed is not working.When i pull the trigger the wheel that feeds the wire to the gun does not spin,even with no tension on it.The fan works and the...


you are going to need to remove the wires going to the wire feed motor, then take a volt meter and check the wires when you pull the trigger. this will tell you if the motor is bad or another problem

Apr 14, 2009 | Welding Tools

Not finding what you are looking for?
Lincoln Electric LINK2400-+2 CV-305 MIG Welder with Options Input Power: 23 Logo

2,127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lincoln Welding Tools Experts

Steve

Level 3 Expert

3287 Answers

Brad Brown

Level 3 Expert

15729 Answers

joe2639

Level 1 Expert

10 Answers

Are you a Lincoln Welding Tool Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...