Question about Bose Acoustimass 15 System

1 Answer

My Bose Acousticmass 15 sub has stopped working. I have tried unplugging it but that has no effect. When I turn the switch "on" I get nothing (but the sub still passes sound to the cubes). Any ideas? Can I open the shell (and if so, how?) and simply change a fuse?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Vice President:

    An expert whose answer gotĀ voted for 100 times.

    Sniper:

    An expert who has posted more than 50 answers, of which 90% or more were rated as helpful.

  • Expert
  • 71 Answers

If you know the sub has no power (tried new outlet or tested the current) the fuze may have been blown. The problem is that it could be more than the fuze in this case. Also the fuze is not easily replaceable in these bass modules. I'd call Bose tech/repair support to see what they offer for repair options. (they're actually pretty reasonable considering the cost of their products)

Posted on Jun 21, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Just unwrapped my bose solo 15 and the universal remote worked up until I tried to set up the tv.. Now it does nothing, can't even turn on the Solo 15. I removed the batteries for about 30minutes, also I...


Try removing batteries from the remote, pressing all buttons to unstick a stuck buttton, reinstalling batteries, and testing operation. Also, something may have gone wrong when you were setting the remote to control your TV. If no corrective action works, the remote may have failed prematurely.

Dec 16, 2014 | Bose Solo 15 TV sound platform

5 Answers

Bose Acoustimass Subwoofer not working; front/center are working


Ok, have you tryed to unplug all of the wires from the sub, including the power wire from the wall. Install of the speaker wires to the sub, and plug back in the sub. Also what are the numbers on the speakers and the sub.

Jun 10, 2007 | Onkyo TX-SV525 Receiver

1 Answer

How to turn on bose acoustimass 15 sub unit


there is a switch located next to where the speaker wire is connected to the module. flip it.

Aug 02, 2014 | Bose Acoustimass 15 System

1 Answer

I aquired Bose Acoustimass 15 surround sound through home purchase. Hooked wires up to reciever and hdmi to tv and i got nothing. my question is, how do you turn on the sub? just plug it in?


Hey Any chance you have the Acoustimass 15 II or III? The first Acoustimass 15 has a switch. The II and II models turn off and on when it receives a signal from the source you are using. Amplifier, ect. All you need to do is make sure everything hooked up correctly and plug it in.

Aug 02, 2014 | Bose Acoustimass 15 System

1 Answer

My bose cinemate wont turn on


It is most likely a problem with the acousticmass. There has been a lot of issues with the Bose cinemate. Most of these issues require you to contact Bose. Make sure you have proof of purchase. They will charge a flat fee to fix it or if they can't they will offer you a discounted one as long as it's covered under warranty. 10_21_2013_5_59_43_am.png

Oct 05, 2013 | Furniture

1 Answer

I have Bose lifestyle 28 series III. Suddenly it stop working and now showing an error 10. Could u pl. help me solve the problem.


hi ,
the main problem you have is that the head unit does not recognise the sub .
unplug everthing and let it unplug for minimum 10 mns .
turn the sub on first
than turn the module on
this should get rid of your problem

Jul 14, 2010 | Bose Lifestyle 28 System

1 Answer

The subwoofer sound is very low with the bose acousticmass 5 III


chewi5,

There is a saying in the audio industry I've come accustomed to hearing -
"No high's, no lows, it must be Bose" Anyway that is just a reference to the flat sounding nature of Bose in general and some people like the accuracy Bose is trying to deliver. I believe your problem is not related to this heavily opinionated statement. The fact that you have a very low sound coming from the sub is an indication that the RCA cables may be hooked up to an input rather than an output. I know this from my own experience and, if this is your problem you are in luck. Just find the proper output and the problem is fixed. The test tones and message also reinforce my main theory. However if this is not solved by my first suggestion you may have to start checking your audio cables for continuity. A bad ground (or even out of phase preamp signals) on an RCA cable can also produce similar symptoms. Let me know if none of this helped and I will try suggesting something more in depth & technical.
-Dynami

Apr 08, 2009 | Audio Players & Recorders

1 Answer

Bose Acoustimass 15 System no power


same problem, i found the transformer looks like the wax or glue melted down on the cir board . . . not sure if that the problem but has anybody seeing the same ?

Sep 20, 2008 | Bose Acoustimass 15 System

4 Answers

Bose - Custom EQ Error: 10


Hi, I have just had the same problem and the advice from BOSE was to turn everything off and disconnect the sub from the main unit, wait 10 mins and turn everything back on, making sure to turn the sub on first.

As it happens i then noticed I had connected the sub via the BOSE link speakers plug to the main unit rather than the correct "MAIN" socket. - so if you are reading this you know I am a fool! But the sound now works.

Basically BOSE confirmed the reason for error 10 is that the main unit is not detecting the sub and speakers.

Anyway, I hope my foolish mistake, helps save time and blushes for anyone reading this link.

J.

Sep 01, 2008 | Bose Lifestyle 28 System

1 Answer

Bose acousticmass 15 sub-woofer making a noise


The sub contains the amp for the other speakers. But it sounds like the amp has a seriously damaged section and will probably have to be serviced by Bose.

Jun 24, 2008 | Bose Acoustimass 15 System

Not finding what you are looking for?
Bose Acoustimass 15 System Logo

2,027 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bose Audio Players & Recorders Experts

The Knight
The Knight

Level 3 Expert

74245 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Ben Armstrong

Level 2 Expert

334 Answers

Are you a Bose Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...