Question about Philips GoGear HDD6330 MP3 Player

2 Answers

Can't connect to PC - also sound on one channel only

I bought two of these on One works fine - the other has two problems, both seem related to the connections to other devices.
1. the sound only comes through one earphone. (the same earphones work fine on the other player). Is this a problem with the earphone jack ?
2. when connected via usb to PC, the PC does not see the player (message 'not connected'). The same Pc connects to the other player fine.Is this a problem with the connection out to the USB cable ?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Can't connect to PC - also sound on one channel only

I have done all the steps above. Still have a problem with one channel. Any more ideas

Posted on Feb 21, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 20 achievements.


    An expert that got 10 achievements.


    An expert that got 5 achievements.

  • Master
  • 8,596 Answers
Re: Can't connect to PC - also sound on one channel only

Install a clean version of the software from the Philips website first.

Make sure you back up all songs on the GoGear before attempting this solution.

1) Back up all files on the GoGear
2) Open up Philips Device Manager (Start --> All Programs --> Philips)
3) Click on the Repair Tab, and look for a msg that says connect the player while holding the volume + button
4) Disconnect the GoGear from the computer and turn the GoGear off - hold in the volume + button and continue to hold it as you reconnect the GoGear to the computer; after holding the volume + button for up to 20 or 30 seconds, a window will open up saying that your device is being repaired (now you can let go of the volume + button); after the repair is successfully complete, your GoGear will be good as new

Now you can do the firmware upgrade that will prevent this problem from occuring in the future. Open up Philips Device Manager and click the Update tab. This problem was caused because most GoGear's were designed for Windows XP with Media Player 10 (which is no longer the latest standard).

-Tha Mp3 Doctor

Posted on Feb 11, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Philips hf3461 - radio works but sounds don't

Please reset the player and see if this will start back. Also connect to PC and scan the PC for error files, delete and format the memory and load the safe files.

Jan 09, 2012 | MP3 & Digital Media Players

1 Answer

Sound problems

Have you tried using a differant set of Headphones? If you still have the same problem with using other headphones, then it seems like there's a poor connection on the sound card from the headphone in input to the board. If your sound card works fine through normal speakers, then that's more then likely your problem.
The cheapest solution would be to replace the sound card rather then have it repaired, as it would probably cost you more to have it repaired then what it would be to buy one depending on what quality of sound your happy to listen to.

Dec 01, 2008 | Samsung Yepp YP-P2 Digital Media Player

1 Answer

2GB Sansa e250 won't connect to my PC


Try connecting it to different USB!!

Nov 02, 2008 | SanDisk Sansa Clip MP3 Player

1 Answer

Insignia NS-8V24 Rhapsody problem

burn the music you PAID for to a cd then rip it back to the system and use Windows Media Player 11 to sync the files to the device (only works if you have a burn feature in rhapsody)

Windows Media Player will see it all the time and is more compatible then Rhapsody with the device

Aug 20, 2008 | Insignia NS-DV2G MP3 Player

1 Answer

My iriver X20 works fine all the features work as they should however there is a problem with the headphone jack. for some reason it does not seem to get a 'clean' connection and the sound does not come...

i am getting the exact same problem, the worst part about it is that ive had mine for just over 13 months and my warranty just ran out!!! plese tell me how long uve had urs for, i would be interested to know

Apr 13, 2008 | MP3 & Digital Media Players

1 Answer

Internal Connection

Just buy new headphones!

Mar 16, 2008 | SanDisk Sansa e260 MP3 Player

1 Answer

Pb for my sandisk m230 mp3 player

Same thing happened to me... try this...
1) disconnect all cables
2) turn power on (hold menu button until screen lights up)
3) Press "menu"
4) scroll down to "settings"
5) scroll down to "USB"
6) select "MSC" (default is probably auto detect - which I think there's a conflict with)
7) turn power off (holding the menu button down)
8) connect USB to computer and hopefully start loading files

I bought 2 of the 512 models, one didn't work... so I took it back and had to buy a 2gig model... got home and it didn't work! I tried the above for the new one and at least the computer recognizes it! Everything seems to work fine...for now...

Dec 03, 2007 | SanDisk Sansa m230 MP3 Player

1 Answer

Help: My Creative Zen Micro 8 GB died

Make sure you have media player 11
If you can, the best test is to try your player with another PC, to see if you still have the problem. This localises whether the problem is with the PC (most likely the USB) or the player. See the link below (search on "connection problems") for a lot more troubleshooting on this.
Download recovery tool off creative's website.
go to my computer > click on hardware tab >
click on device manager button > in the is next screen on the bottom should have>>universal serial bus controllers
(write these down just in case it cant find them)
right click on them and uninstall
reboot let windows reinstall them

Also told Microsoft hotfix causes this problem try uninstalling the last hotfix
If that doesn't fix it try the USB cable

May 08, 2007 | Creative Labs Zen MicroPhoto MP3 Player

1 Answer

Data seems to be lost and it crashes

have u tried turning it on in emergency connection mode ( press the reset buton connect it to the pc then hold the power buton while holding the o enter button) u can reformat it then. after you reformat it u will have to reinstall the firmware (u can get this from it should work after this:P

Aug 08, 2006 | iRiver H10 MP3 Player

1 Answer

Same problem with MP3

try to connect it other computer,if it works normal on other pc then its ok, or you can also try to use other usb port in your pc, and if this doesnt solve your problem, i think you should replace it.

Jul 30, 2006 | Creative Labs MuVo V200 MP3 Player

Not finding what you are looking for?
Philips GoGear HDD6330 MP3 Player Logo

71 people viewed this question

Ask a Question

Usually answered in minutes!

Top Philips MP3 & Digital Media Players Experts

 Mike M
Mike M

Level 3 Expert

3320 Answers


Level 2 Expert

48 Answers

Pieter Vleeshouwers

Level 3 Expert

1315 Answers

Are you a Philips MP3 and Digital Media Player Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides