Question about Lanzar VIBE531 Car Audio Amplifier

1 Answer


Posted by on


1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Disconnect the speaker wires and the RCA cables from the amp. If the protection light still comes on, the output transistors have likely failed.

Posted on Nov 03, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Sony CDP-C910 will no longer play cds or eject changer cartridge

Mine did the same thing. My player was primarily used in the garage and the cold weather may have caused my player to do the same thing. I just fixed my player. I removed the top cover and looked at the CD in the play position. In the upper right corner from the CD, you will see a spindle motor with a belt on it. Gently spin the motor back and forth carefully with your finger. I rotated it a half-spin in either direction, careful not to dislodge the belt. When I turned the player back on, the mechanism operated as it normally would and began playing the disc. I was able to eject and reinsert the magazine without any issues, solving the problem. Hopefully that will work for you.

Dec 17, 2012 | Sony CDP-C910 10-Disc CD Changer

1 Answer

I have an 06 kicker zx 1500 monoblock amplifier. The other day i was bumping it pretty hard and it just stopped playing so i stopped and then i stopped to look at the amp and the light was off but the...

Check the impedance of the speaker to be sure that it matches the output of the amp. Common error on this detail can cause the amp to overheat and shutdown/protect.

Jul 23, 2011 | Kicker ZX1500.1 Car Audio Amplifier

1 Answer

Thumping speakers - no power light is on - wired correctly

the amp is going into protect mode due to something wrong in the amp or some thing in the wiring to it ooh yea if you are getting 18v power to the amp that is way to high it should not be higher then 15v if the amp is in protect mode it will not play at all.

Nov 02, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Amp Power light will not go on. Protection light is lit- Thump sound in speakers

It probably has shorted output transistors. To eliminate other possible causes, read through the following page.

Amplifier in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Oct 31, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Cd player installation

read my other solution on the other one you posted. yes, the fuse is more-than-likely blown. but also you wired it completely wrong. look on my other solution on the other one you posted, it has the correct wiring diagram. there are 2 wires on the wiring diagram i posted that have the lights. one red is the int.light, and the other one is the turn signal wiring.

Aug 22, 2008 | 1990 Ford Taurus

2 Answers

Trying to install after factory radio in 94 Honda accord ex and can't get any sound

I have a 93 accord ex with the bose amp system. Had a Sony deck put in it. It had the popping and the noises. It was installed at a store and they had to hook the red power wire to the antenna wire to get the sound to come out of the system when playing a CD. I thought that was bogus to have the antenna up all the time so I took it back out and put another quick hookup harness in it and it did the same thing. Will not put out any sound till the red power wire is hooked up to the antenna wire so that it goes up when the key is turned on. Installed the same stereo in a 94 taurus SHO with amp and it worked great. I believe that there is an expensive kit that converts the bose system to hook up a unit so that it doesn't pop click buzz, and have to have the antenna up to play.

Jun 19, 2008 | Car Audio & Video

1 Answer

Sound cut-out

Most likely this unit goes into protect mode due to heat detection. Try to see if there is a pattern to when this behavior starts. Does a lower volume level allow the unit to run longer? Perhaps there is a problem internally that is allowing DC voltage to get to the output stage. This will cause excessive heat which can then cause the protection circuit to kick in. This unit may need to see a bench with some test gear to locate the exact problem. If you can, look for any pattern and update this.

May 13, 2008 | JVC RX-6042 Receiver

3 Answers

Cd player dosen't play with amp

hmmm...what cd player are you using?..

May 03, 2008 | Kenwood KDC-MP828 CD Player

3 Answers

Red LED "Protection Light is on" What is the problem

The red light means the amp is in protection mode. A few things can cause protection mode..... First disconnect the subs completely from the amp, and turn it on, if it powers up you have blown subs. Also try checking the main power wire at the battery...sometimes the current your meter is seeing is backfeeding from the remote wire, so your main power line could be blown at the fuse under the hood. hope this helps

Jul 17, 2007 | Crunch BlackMaxx BMX2250 2 Ch 1000W Amp...

1 Answer

Amp not working

1. Did you witness this amp ever working if not then you may have a blown amp. Hook up the speakers, get a portable player with a head phone jack get one of those cables with a headphone plug on one end and RCA's on the other plug the portable player into the amp and hit play. If sound comes out then your problems are elsewhere. If not I'm afraid your amp is probably toast. If the OHM rating of the speakers are too low for the amp then the amp will go into protect. This will be indicated by the protect LED lighting up or the power led changing color from say green to red.

Jun 28, 2007 | Kenwood KAC-729S Car Audio Amplifier

Not finding what you are looking for?
Lanzar VIBE531 Car Audio Amplifier Logo

Related Topics:

171 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

Chris Ward

Level 2 Expert

158 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

The Knight
The Knight

Level 3 Expert

75025 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides