Question about Focusrite Saffire LE FireWire Audio Interface Sound Card

1 Answer

Connection Lost & No Audio Device as well (Vista 64 & Saffire LE)

Saffire doesn't show up in the audio devices. It only does in device manager.. as if windows don't see it as an audio card...
I also had trouble with installation. The installer got stuck while "Waiting for firmware to boot up". Then it timed out and the installer DIED!
Also i red in that useless answerbase of focusrite about the "low power mode" which can prevent the line/inst switch from functioning. Their suggestion is to plug in the power supply. I have a 4 pin FW so i ve already done that. However, i checked the (included) power supply's specs and it says 12V 600mA. At the bottom of the saffire le i read 12V 1A !! So i plugged in another power supply with a 1A currency capacity. And guess what.. the installation moved over the boot up thing and completed succesfully.
That's all i managed to do. I still have the problem of not having the audio device available in windows. Also, for some hours now the line/inst buttons DO NOT WORK.
I guess i m lucky cause having a hardware part not working will definitely get my money back.. hehe
thnx to all

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

No sound device

Posted on Jun 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

The Audio doesn't work I need an Audio driver I have hp pavilion dv2000 with windows 7 operating system


  1. Go here http://h10025.www1.hp.com/ewfrf/wc/softwareCategory?cc=us&lc=en&dlc=en&product=1817074
  2. Select Windows Vista or Windows Vista 64-bit , if you have 64-bit Win 7 (drivers from Vista should work on windwos 7 too)
  3. See Driver - Audio for you drivers

May 09, 2011 | Computers & Internet

1 Answer

My Saffire Le doesn't show up in AUDIO DEVICES but all is instaled corect and in my device manager I can that fire wire and Saffire are ok please try to help... it began after I reinstaled windows (now...


Go to Volume Controls - Options menu - Properties... is it in the Mixer drop down box there? You might find the problem is that any onboard soundcards you have on the motherboard are now set to default since you reinstalled. In which case go to device manager and disable it. If problem persists try a reinstall of saffire whilst the onboard card is disabled. Some motherboards allow you to disable the onboard sound from the bios menu too, that could be something to try

Oct 31, 2009 | Focusrite Saffire LE Sound Card

2 Answers

My firewire does not connect to my firewire focusrite saffire


I had the same problem during instalation... Try connecting first and then connect the power cable. It worked for me and installed properly. The problem is I'm facing a new problem now... The Azmixer.exe -or something similar - won't load on memory... The sound card doesn't work and isn't recognized... Any idea...?

Apr 20, 2009 | Focusrite Saffire LE FireWire Audio...

2 Answers

No sound device connected to pc!


Do you now have a solution for the problem coz I have the same poblem....
Your soonest reply will be appreciated! Thnx...

Apr 10, 2009 | Focusrite Saffire LE FireWire Audio...

1 Answer

Conexant audio when updated displays no media device to support.


go to your motherboard's web site and download the latest drivers, make sure it mateches the right version of your windows.

do you have x86 or 64 version of windows xp in other words do you have a 64 bit processor.
what service pack do you have with windows XP, SP2 ??? or SP3 ???

Mar 22, 2009 | HP 417035-001 - HP Pavilion dv2000 Series...

2 Answers

Firewire connection lost


Ok, here it is. There is an answer is the answer based section on the Focusrite website. Basically it is recognizing it as a firewire device and not an audio device, or so I have gathered. So you need to uninstall the Saffire software and then: 1. Find your FireWire (IEEE 1394) controller in Device Manager (START>CONTROL PANEL>SYSTEM>). 2. Click "Update driver" 3. Select "Browse my computer for driver software" 4. Click "Let me pick from a list of device drivers on my computer" 5. Install the driver that ends with "(Legacy)". 6. Reinstall your Saffire driver using the latest version from the Focusrite website, and re-connect your device.
Hope this helps,
Cheers - DJ Zerokewl

Dec 27, 2008 | Focusrite Saffire LE FireWire Audio...

1 Answer

Samson G-track - Vista requiring to install USB Audio Codec


If the LED doesn't light when you plug it in, and it doesn't show up in Device Manager ("USB Composite Device" or "USB Audio Device"), then the mic must be defective. Contact Samson for a replacement.

Nov 24, 2007 | Samson G-TRACK USB RECORDING MICROPHONE...

Not finding what you are looking for?
Focusrite Saffire LE FireWire Audio Interface Sound Card Logo

Related Topics:

682 people viewed this question

Ask a Question

Usually answered in minutes!

Top Focusrite Computers & Internet Experts

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

kakima

Level 3 Expert

102366 Answers

David Payne
David Payne

Level 3 Expert

14161 Answers

Are you a Focusrite Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...