Question about Hoover F7220900 SteamVac V2 Upright Vacuum

1 Answer

Brushes do not turn worked , fine last time i used it a month ago.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 54 Answers

The brushes are run by vaccum. Take the brush out and there is a passage way in there that could be blocked. If I rememer correctly there is a screen in there. If that dont help then there is a spring hooked to a lever underneath so when you lay the back down it engages caccum to the rollers. It could be that this is stuck and not moving. Try moving it by hand with the scrubber running.

Posted on Jun 20, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Brush won't spin on hoover wind tunnel bag less upright when on carpet, belts are fine


The belts may look fine but may be stretched and worn. Replace them. Make sure brush spins free. Idler pulley should tighten belt tension when handle is released

Jul 25, 2014 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

My vacuum was great when I first got it a few months ago, now it won't pick anything up off of the floor. The removable hose works fine, but the main vacuum isn't working at all. I checked the hoses for...


you could have a clog at the begining of the suction port above brush roll check that and make sure the brush roll is spinning if not it wont pick up anything

Feb 16, 2011 | Eureka 3276AZ Pet Lover Bagless Upright...

1 Answer

Hoover WindTunnel, month-old belt, now too large to turn brush


I suspect you have been bitten by the Chinese bug.
A very large percentage of replacement parts for all manner of appliances and vehicles are now being conterfeited in China who we should know by now has no respect for the intellectual property of others and a flood of low-quality stuff is being made as 'knock-offs' since they are generally easy to fabricate with fairly primitive means. Our eldest son just returned a supposedly 'new' steering pump for his (US) car but this one at least had China as the origin shown on the package.
Make sure though that the brush roller turns freely and isn't being impeded by trapped thread in the bearings. 

Mar 21, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Brushes not working


Check the filter from the bottom, it has a red frame, pull it out far enough to clean it, if it is clooged, then the brushes won't spin. If it is clean, pull the brush block out, make sure the shaft that goes up into the turbine is not brokked off, if it is replace thebrush block. With the brush block out, turn on the machine and look up where the brush block goes, there is a square hole, if it is turning, then it is ok, if not, then the turbine is either clogged up or the turbine has gone bad.

Jun 20, 2008 | Hoover F7220900 SteamVac V2 Upright Vacuum

1 Answer

No suction


If the belt is stretched, then it can't turn the brush rol under load, if you haven't chenged it in the last 6 months, then I would put a new one one. Also check the dirt inlet by the brush roll for a blockage.

May 30, 2008 | Riccar 8955 Upright Vacuum

1 Answer

Bissell Lift Off pet revolution vacuum losing suction


You may have a clog in the hose. Unhook the hose and see how the suction is there, if ok, then check the dirt inlet by the brush roll. If suction is low at the hose, then there is a clog in it.

Mar 20, 2008 | Vacuums

Not finding what you are looking for?
Hoover F7220900 SteamVac V2 Upright Vacuum Logo

Related Topics:

245 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1461 Answers

Brad Brown

Level 3 Expert

15639 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...