Question about Clarion Car Audio & Video

1 Answer

Car amplifier just shut off and goes on and off when it wants

It was playing fine then all of a sudden it stopped , but then cam on and went off again now hasnt really been on since. i have a clarion 1200 watt single channel mono d class hooked up to memphis audio M3 MOJO 15" Dual 2 ohm Subwoofer 1000 rms 2000 max and i also have a capacitor hooked up also and all fuses are good on the amp and the fuse line fuse aswell on the battery . ive checked the remote wire and switched it to the accesory wire since i assumed that was problem . please help

Posted by on

  • rogerf3
    rogerf3 Apr 21, 2014

    even the capacitor shows no sign of power from the battery except now and again but i had issues for days where no capacitor or amp working and have tested the wires with volt meter and the wires when out of the the amp would start high on the meter then would slowly decrease

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Clarion Master
  • 34,066 Answers

Driving the amplifier too hard causes it to go into protect mode to prevent damage. The amp periodically recovers and operates normally until the next overdrive peak hits it.

Posted on Apr 21, 2014

Testimonial: "this amp has been used for almost a year and i had no problem until this happened and i have used it way harder before and never had any issue so i dont think this is the problem"

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Planet Audio PX1500M Amplifier Problem


Check the FUSE to ensure that current is not cut off.

Jul 16, 2013 | Planet Audio PX1500M - 1500W MOSFET...

1 Answer

Car amp not working


is amp getting power or not could be wires came loose inside speaker box

Mar 29, 2012 | MTX JackHammer JH600 Car Audio Amplifier

2 Answers

Kicker amp powers no audio all connections made properly


Hello,

Is this the first time installing it or have you had it a while and it suddenly stopped playing ?

Aug 07, 2011 | Kicker Car Audio & Video

1 Answer

Protect mode


Protection circuit.
Checek the wiring of the amp and speakers, don' forget to look for shorts at the speakers. Make sure no wires are touching each other

Apr 30, 2010 | Volfenhag 1600 WATT CHROME AMP AMPLIFIER 2...

1 Answer

Have alpine m200 went into protect mode


Try shutting the igniton off for 10seconds and turning back on. See if it resets. If it doesn't check your wiring (disconnect the speaker wire) and then try again to see if the short is there. Check your power/ground wire too. If all is well with wiring you have a faulty amp

Sep 07, 2009 | Alpine MRV-100M Car Audio Amplifier

1 Answer

Jbl am in protect mode


if it goes in protect mode means ur amp is turn up to high or it is over heating so it protectn it from fryn ur amp try to adjust it down

Jul 12, 2009 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Amplifier unit of MHC-W770AV stopped working all of a sudden.


Start with the simple things first, hunt round for fuses near where the mains goes in. Keep on the lookout for anything that looks burned or broken. If there's no power to anything it will be something in the power supply section.

Apr 12, 2009 | Audio Players & Recorders

1 Answer

CDA 9885 No idea why it suddenly stopped working


It sounds like you have a bad ground connection. You need to take the radio out and check all the connections. I bet you have a loose one somewhere. That is what the problem was with my bronco

Sep 08, 2008 | Alpine CDA-9885 CD Player

1 Answer

Amp not working correctly goes into protection


Disconnect the speaker wires from the amplifier and see if it still goes into protection mode. If it still goes into protect with the speakers disconnected, there's a problem with the amp; if not, you may have a blown speaker or a shorted speaker wire.

Feb 22, 2007 | Legacy LA2098 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Clarion Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

Marco Avila
Marco Avila

Level 2 Expert

56 Answers

Are you a Clarion Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...