Question about Fusion Car Audio & Video

Open Question

Amp goes into protect mode when engine is running

Fusion 2000 watts amp works fine when on ignition but when engine is running it goes into protect mode

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
thesoundman
  • 41 Answers

SOURCE: prower acustic amp in protect mode

1) Make sure the amp is properly connected to +12V power source. 2) Make sure the amp is grounded well, directly to metal - if you have a voltmeter, an easy way to check the first two is to see if there are 12 volts across the power and ground wires. 3) Make sure the speaker output wires aren't touching each other. If none of these are the case, there is an internal problem with the amp and it should be serviced or replaced.

Posted on Sep 21, 2007

Ad

SOURCE: amp staying in protection mode

No, this amp is not a heavy power consumer- matter of fact it takes very little power to run.Maybe you should check the fuses on the amp to see if they are what is recommended.Also check your fuse kit to your amp- your fuse might not be big enough.If neither works take it back where u got it.

Posted on Jan 02, 2008

  • 631 Answers

SOURCE: 2000 watt legacy predator amp

Disconnect all speaker wires from the amplifier's speaker terminals and disconnect the RCA cables from the amp. If the amp still goes into protect, it probably has shorted output transistors.

Posted on Feb 17, 2008

  • 631 Answers

SOURCE: mmat amp 1200 watt

If the amp is in protect mode, it probably has shorted output transistors.

What model amp is it?

Posted on Aug 20, 2008

  • 1 Answer

SOURCE: the amp turns on but goes to protection mode

Have you checked the REM wire, if it is the wiring may have gotten fried.

Or you may need to get new parts replaced within the amp.

Both issues happened to me.

Posted on Mar 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Jbl am in protect mode


if it goes in protect mode means ur amp is turn up to high or it is over heating so it protectn it from fryn ur amp try to adjust it down

Jul 12, 2009 | JBL BP1200.1 Car Audio Amplifier

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

FE-300D a good amp ?


if its a 2 channel amp you can only run in stereo mode can not bridge amp will get hot

May 23, 2009 | Fusion FEW12PK Car Subwoofer

1 Answer

Fusion car amp turns on then gos in protect mode


look behind ur headunit could b a wire touching or a piece of metel

Apr 08, 2009 | Car Audio & Video

1 Answer

Kole amp in protect mode?


Are you setting the bridge switch for both left and right or are you trying to run both subs off of one set of terminals? If you running the subs off one set of terminals you are effectively running the amp below 2ohms and thus the amp is not 2ohm stable and you will destroy it.

Some amps actually all ready run a bridged output for left/right operation, this could also be the reason why the protection circuit is kicking on.

Either way it's a component mismatch and you either need a stronger amp or different subwoofer setup.

Mar 09, 2009 | Kole audio Nitric XP2-2000 Car Amp

1 Answer

Car audio amp in protection mode


If you power up the amp with the RCAs plugged in, does it go into protection mode.

If you power up the amp with the RCAs plugged in, does the woofer pop?

Oct 26, 2008 | Pyle PLAD413 Car Audio Amplifier

1 Answer

My Amp


sounds like the sub that throws it into protect mode is cross wired pull sub out and make sure they are wired right make sure ground from sub goes to ground on box and do same for power wire

Jun 11, 2008 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

1 Answer

Fusion Amp Starts In protected Mode


check remote wire coming from back of radio

Jan 08, 2008 | Fusion FEW12PK Car Subwoofer

1 Answer

Audio bahn 1205n


sounds like your over working your amp 800 watt on a 2000 watt sub. might wanna upgrade your amp

Nov 28, 2007 | Lanzar 2H 1000W MOSFET AMP Car Audio...

1 Answer

Amp not working correctly goes into protection


Disconnect the speaker wires from the amplifier and see if it still goes into protection mode. If it still goes into protect with the speakers disconnected, there's a problem with the amp; if not, you may have a blown speaker or a shorted speaker wire.

Feb 22, 2007 | Legacy LA2098 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fusion Car Audio & Video Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Fusion Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...