Question about Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS 2 OHM Car Audio Amplifier

1 Answer

How to hook up my v12 mono amp with my 12" type r

Car was already wired get good bass but if i put my stereo over 20 the amp kicks out ? mono v12 alpine amp and 12 " type r in ported type r box wondering if i have the rca hooked up wrong the box has bridges the hookup so i assume that it would put me 2 ohm stable but not sure if i hookeed the rca s wrong or whats going on and why it kicks out ?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

Check your ground

Posted on Apr 29, 2014

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

UpfrontAudio
  • 47 Answers

SOURCE: how do i run it 2 ohm stable

This is how 2 type r's are wired to one amp at 2ohms hope this helps dont forget to rate me thanks

Upfront Audio :)

1a81949.jpg

Posted on Apr 23, 2009

  • 149 Answers

SOURCE: Amplifier wont move subs

I dont know if this will help you but start at the deck and make sure that the outputs(RCA) arent crossed over to highpass and do the same at the amp make sure that its set for lowpass- set half gain -bass boost half gain- subsonic minimum - If that doesnt help try using an i pod with an adaptor that you can play it right into the amp this is to see if you are getting signal from the deck to the amp if it doesnt work with an i pod or mp3 plugged directly into it then you may have got you a blown amp going on- good luck with that

Posted on May 30, 2009

  • 222 Answers

SOURCE: i have a v12 amp hooked up to 2 12

swithc it to mono

Posted on Jun 13, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a comp s 12 2ohm kicker and a comp vr 12 dual 2ohm kicker how do i wire these to stay at 2ohms to the amp


you can wire them to be at 2ohm load you need two of the same speaker. its is very bad on the amp to run like that and you will not get a good bass sound because one will over power the other sound wise

Mar 23, 2013 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

1 Answer

I need to know how to hook up an alpine v12 amp 2 ohm i have two tens


Hi there,

This really depends if your 10" subs are 4 ohms each or 2 ohm - for this exercise, I'm presuming they are 4 ohm each.

You already know your amp can deliver 600W RMS (@ 2ohm), so you need to be careful you do not exceed the maximum RMS input power of your subs.

Normally you would wire subs in "parallel", which would reduce the circuit load to 2ohms - however, the 600W RMS power may be too high for your subs to handle.

In this case, it may be safer to wire your subs in "series" - this will increase the circuit load to 8ohms, which will effectively decrease the amps RMS power output.


Cheers,

Sep 05, 2011 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

1 Answer

I have two audiobahn aw1206t 12in. subs in a box hooked to a 100.1 american bass amp its 1000 watt mono block. i also ran a capacitor due to my lights dimming. but for some reason my amp keeps kicking over...


This could be caused due to the impedance load being to low. Your amp is stable to 2 ohm load however its very possible that you have your subs wired to a 1 ohm load that would cause the amp to go into protect mode. The subs you have are dual 4 ohm voice coils and would need to be wired in series/parallel. I've included a link that will show you how the subs should be wired.

http://a248.e.akamai.net/pix.crutchfield.com/ca/learningcenter/car/subwoofer_wiring/2-DVC-4-ohm-mono-low-imp.jpg

May 16, 2011 | AudioBahn AW1206T Car Subwoofer

1 Answer

How do i connect my pv2600amp to my peavey subs and top speakers, i have the leads but what do i do?


Line outs Left and Right from mixer to power amp Left and Right inputs,
Power amp outs to Subs(if they have passive crossovers built in check specs on subs).
From Subs then to Main spkrs. Make sure power amp is set in stereo mode using this way.

Alternative: You will need at least a 2-way stereo crossover unit inline after mixer and before power amps if the subs don't have a built in passive crossover. Most of them do have passive crossovers in the subs these days. Then separate amps or one channel would drive the subs and the other the main speakers. True stereo would require at least a 2 way crossover and two stereo power amps if hooking them up this way.

There is another option as is common with many sub setups. Send the signal to the mains using L/R outputs from mixer and a separate Mono output to the subs only. Putting only bass/kick and low frequency outputs in this send would help too.

Oct 13, 2009 | Peavey PRO-12 (00497070) Main / Stereo...

1 Answer

Amp turns off


what ohm is it running at? if you have all three hook up it parallel then its to low of ohms and it would be louder if you unhook your 10" sub as it moves differently form the 12"s and it cancels out some bass. but if you want it then you have to change the wiring around a bit. take the positive wire off a 12 and put it on the positive side of the 10 and then take the ground for the 10 and hook it up to the positive side of the 12. so you should have one wire from the amp going to the negative side of the 12 and one going to the positive side of the 10 and a jumper wire from the 10 to the 12. and if it still shuts off then you have bigger problems.

Sep 25, 2009 | Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

My alpine v12 turns on but no sound


no you don't have to hook up both of the power terminals. but should have it hooked up so you get the proper power to the amp. use a disubution block with two 8 gauge wires.

do you know if the radio's rca jack's are good? have you ever had another amp in the car? if it worked before try new rca's from the radio to amp. recheck all connections from amp to speakers and make sure no wires fell off.

Sep 22, 2009 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

2 Answers

I got a 4 gauge power wire w a 20 amp fuse hooked up to a kenwood stereo/bridgeable amp 350 watts max power model #kac~6295 it just dnt sound rite any sugestions?


make sure you run your power and ground wires opposite of the rca/speaker wires. you tend to pick up alternator noise when all wires are bunched up together. Also, make sure you have a good chasis ground to the amp, and the stereo has also a good ground. good luck

Sep 04, 2009 | Car Audio & Video

1 Answer

Installing two amps


No, thats what you don't what to do. Even if you have 2 matching amps you don't do that. Every amp puts out different, and for 2 subs, you want to play at the the same time. If your only running 2 10's, I personal would just run the alpine (it's a mono amp made especially for subs) thats plenty for what you have. make sure you bridge them to get the full response. And your other amp i would use for your highs or mids, but run it @ stereo , which is 300 w @ 4 ohms. (Note: 600w @ 2ohms would be bridged and would play in Mono)

Building Competition stereo's is a big hobby of mine.

May 04, 2009 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

3 Answers

Adjusting wattage on kenwood kac 9103 class D mono amp


That amplifier is 900W x 1 @ 2ohms.
If your subs are 4ohm SVC wired Parallel, resulting in a 2 ohm load, each sub will only see 1/2 of the rated power. (450W ea.)
Your gain (sensitivity) setting should be between 75% and 85% to max. You will be fine.

Jan 02, 2009 | Kenwood KAC-9103D Car Audio Amplifier

Not finding what you are looking for?
Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS 2 OHM Car Audio Amplifier Logo

Related Topics:

172 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Jaime Hernandez

Level 3 Expert

2318 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...