Question about Terminator Aquastar 125FX Tankless Water Heater: FX Hood Horizontal Vent

Open Question

Intermittent ignition and flame-out

Starts, goes out; starts, goes out: 3-second intervals between Piezo firings. Nice bright blue flame covering the entire main gas burner, but then it dies out and re-starts again. I've cleaned the flame sensor, checked the pilot orifice (although it's tiny), can hear the fan start and run. What's next, please!

Posted by on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 25 Answers

SOURCE: burner will not always light

clean the flame sensor!!

Posted on Jan 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Chef Regency Gas Wall Oven - oven fan working,light working , grill working as well but the main oven not responding when turning dial. The Piezo ignition is intermittent and no gas sound coming out.


The Piezo control board opens the gas valve while it makes a spark. Once the flame is lit the milivolt flame sensor holds it open from there on. Replace the piezo control board to fix.

Jan 16, 2016 | Kitchen Ranges

1 Answer

Hot surface igniter will glow and put out a flame but is not a blue/orange flame


First you need to get a nice blue steady flame to prove to the ignition module there is flame. Check you orifice and bypass tube.

Feb 22, 2014 | Lincoln Impinger 1116 Gas Oven

1 Answer

My Ruud achhiever 90 starts to fire but as soon as the blower fires the burner goew out. I also noticed that the "igniter" on the end isnt firing. Could that cause the burner to not stay lit when the


There is an ignitor and a flame sensor. If the ignitor does not ignite the gas after a time, it goes out. If the flame sensor does not detect ignition the gas valve closes. When you start it you should see the ignitor come on like a light bulb and glow, then the gas valve opens and you get ignition. Then the flame detector turns on when the ignitor goes out. Flame detectors are like a chrome wire that has one connection to it and it sits part of the way in a burner. They get dirty and corroded. When that happens it shuts down. You can clean the flame detector with steel wool of scotch brite pads. Dont get too carried away doing that though.

Dec 25, 2012 | Heating & Cooling

1 Answer

Pilot lights up but would not fire up into heating, I have brivis buffalo 85


This is the proper cycle of a furnace and what should happen.

Inducer motor kicks on, it runs for a little bit, about 3-5 seconds, then you should see a bright yellow glow, this is the igniter, shortly after, you should hear a click and the gas should start to flow, almost immediately it turns to a blue flame. Then your igniter should turn off and the blower motor start up.

If the pilot turns on and the gas ignites, then shortly after the unit shuts off, chances are this is your blower motor. It is not starting up, then the heat limit is reached in your unit and the safety shuts it off.

Mar 02, 2011 | Honeywell Programmable Thermostat Heater

1 Answer

My furnace will ignite then after about 3 - 5 seconds it goes out and blows cold air, I was told it was the flame sensor, is that what it sounds ike to you


That is a good possibility--
Did you try cleaning it- and making sure the wire is tight from the Flame rod, thru to the circuit board it connects to.

What type of ignition?-- Glowing ignitor?-- Is it nice and bright, and the correct ignitor?

Try doing some trouble shooting, and tell us more what you see and hear at the ignition process process, step by step.

Tell us more-

Mack B

Jan 23, 2011 | Heating & Cooling

2 Answers

I have mpi monitor e 13 keeps coming up


E13 means that the flame rod couldn't detect fire during it's 300 second cycle. If you can see fire through the window, start by cleaning the flame rod.
If no fire is visable after 300 seconds, feel the ignitor cover. If it is warm, check the fuel system, chances are the ignitor is working. If it's cold you have a bad ignitor.

Dec 26, 2010 | Rinnai Toyostove Direct Vent Heater: Laser...

1 Answer

Dsi flt after trying to fire 3 times piezo works


Try removing the safety cut out (looks like a resistor in a plastic sleeve going to thermostat terminal) . Just disconnect it at both ends and connect the female spade from power wire directly to thermostat male terminal where the cut out was connected and try it. If it works, replace it when you get a chance. That protects system in case of flame jumping up in that area due to problems or spider webs etc. Once it's been tripped, it's no good. If that's not the problem, try cleaning your ends of your electrode, and make sure they are in front of flame when burner ignites, as it also act as a flame sensor. Let me know how you make out.

Jun 21, 2010 | RTO Atwood DSI-RV Water Heater-6 Gallon

1 Answer

My Rheem Ruud 25M01A water heater flame goes out before the thermostat is satisfied. The igniter goes into a ignition sequence from here on trying to get the flame to ignite for ever. If i turn the unit...


Check the air lines going to air pressure switch for cracks or splits. I know that will affect the gas valve but not sure if that is your problem.

May 07, 2010 | Heating & Cooling

2 Answers

Low and intermittent flame of weber Q 220


You can try replacing the regulator to cure the gas flow problem, I believe the ignition is a piezo, if it does not click when you push it or turn it, it most likely needs to be replaced. If it still clicks, then there could be a bad wire or electrode.

Dec 22, 2009 | Weber Baby Q Grill

Not finding what you are looking for?
Terminator Aquastar 125FX Tankless Water Heater: FX Hood Horizontal Vent Logo

Related Topics:

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Terminator Kitchen Ranges Experts

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

paulcarew

Level 3 Expert

2463 Answers

Are you a Terminator Kitchen Range Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...