Question about Eureka WhirlWind Litespeed 5844 Upright Vacuum

1 Answer

I have the Eureka Whirlwind upright vacuum. All of a sudden there is no suction- the hose has suction but not main part. I have no idea- but the brush part is not turning??? should I get a new vacuum or is this an easy fix? thanks!!!!!

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 328 Answers

If the belt isn't turning then it has snapped. Check the top of the hood for two or three crosshead screws; two at the front and one under neath by the left hand side if looking at the upright from the front. Its easy to fix if you take your time and you have a spare drive belt. Check EBAY in your country for spares.

After you put a new belt on make sure the roller beater is completely free of threads as this will keep the belt longer for running.

Posted on Jun 19, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Eureka Model Whirlwind litespeed. The rotart brush does not turn or rotate. Should it turn or rotate in order to give better suction?


Hello fnintel, yes, if you are using the upright vacuum it should spin, ( the belt likely slipped off, or the brush is clogged with hair and the likes.)
However, if you are using the hose on the vacuum like a shop vac, some models bypass the rotary brush.
Good luck!

Jan 09, 2011 | Eureka Whirlwind Litespeed 5840 Bagless...

1 Answer

No suction when vacuuming, but suction is good when using hose


check for blockage from where the hose sets in its
holder to the roller brush. Also see if the brush is
turning, the belt maybe broken.

Tom

Oct 22, 2009 | Eureka WhirlWind Litespeed 5844 Upright...

1 Answer

Eureka rm 4480


Hi there SmartAlec from NelsonVacuums.com.au . Unless there is a bad sound coming from your vacuum i would suggest you have a blockage. This machine is prone to getting blockages in 3 different places.
  1. at the base behind the brush.
  2. Inside the main suction hose - this should be removeable so you can drop a small coin through. If it doesnt fall easily viola blockage found.
  3. Where the dirt enteras the chamber or bag.
Basically start by removing all hoses and filters and turn machine on put your hand over all inlet and exit points provided you can feel airflow at one of these points work backwards from there and identify the point at which you no longer feel airflow.
HAPPY vacuuming !

Aug 26, 2009 | Eureka Whirlwind 4480 Upright Vacuum

1 Answer

No suction.


Mine is doing the same thing, the hose picks up things fine but the rollers turn and instead of picking up it is blowing air out????

Nov 29, 2008 | Eureka WhirlWind 4381 Upright Vacuum

1 Answer

Low suction with Eureka Whirlwind 4481 Upright


Most times it is plugged at the inlet. There 2 screw on top, one on each side, in one of the holes or slots. Take top cover off, then check that inlet and hose to see if it is clogged there or not, you might replace the belt while you have cover off, part# 54312. I am sure it is stretched if it hasn't been replaced in a while. If the hose is clogged, the you will have to take off the handle, then the hose can be taken off so you can clear any clog in it.

Jan 24, 2008 | Eureka Whirlwind 4481 Upright Vacuum

2 Answers

How to change belt on Eureka Whirlwind


On the top cover, there are holes at the front on both sides, there is a screw on each side in one of the holes. Take the out, and the cover should come off, then you can get to the brush roll and belt.

Dec 27, 2007 | Eureka WhirlWind 4381 Upright Vacuum

1 Answer

Main vacuum suction won't turn off


try cleaning out hoses,if that dont work turn it on its side if the roller doesnt spin u need to change belt if it does take the bottom cover and try cleaning out the hole under roller

Nov 22, 2007 | Eureka Altima Upright Vacuum Model 2996AVS...

Not finding what you are looking for?
Eureka WhirlWind Litespeed 5844 Upright Vacuum Logo

360 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18408 Answers

JoeVacs

Level 2 Expert

357 Answers

Alan Matzke
Alan Matzke

Level 2 Expert

81 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...