Question about Kicker IX702 Car Audio Amplifier

Open Question

Amp gets power....everything hooked up good but no boom....i think selector switch is broken cuz it seems to want to work when i play around with it....can and where can i get that replaced??

Posted by Anonymous on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1986 Silverado. The inside tank selector switch isnt getting no power


there is a fuesable link that blew. you will spend days looking for it. I would just run a new wire from an aux fuse to the switch

Mar 11, 2013 | Cars & Trucks

7 Answers

Not outputting to all speakers from CD, but does from DVD


Hi,.

With the indulgence of the others...
dfadfab.jpg
If I understand your problem right:
1. CD works only in Speaker A (but not in Speaker B);
2. DVD works on either or both A/B;
3. CD will work if plug into to VCR input but selector must be of another source (not VCR).

A couple of suggestions:
a. pls try doing again the reset as ginko has suggested but make it a bit longer, i.e. unplug it from the mains for a couple of hours;
b. since you have remove most of the wiring, why dont you try switch A & B. make the family room speakers the B while the speaker selector the A;
c. hook the CD (only) using the RCA cables (red/white) nothing else;
d. play any CD music and go through the paces of selecting source, speakers, surround/hall/theater/etc as troylove11 has suggested.

This would be now a simple setup, 1 source (CD) to 1 output/speaker (the family room) via the Denon. Try different settings. If the CD plays normally then, without changing any setting nor powering it off (but with volume level all the way down), remove the family room speaker wiring and replace it with the wires to/from the speaker selector.

the idea is to determine which is the real issue, the Sony, the Denon settings/hardware or the speaker selector.

Hope this be of initial help/idea. Pls post back how things turned up or should you need additional information.

Good luck and kind regards.

Thank you for using FixYa.

Apr 15, 2008 | Denon AVR-3801 Receiver

1 Answer

I have a marantz st100 receiver, and everything seems to work well with one exception. There is static in one channel that comes and goes, and sometimes gets quite loud. The problem follows the channel...


It could be a burned out resistor in the main power amp. Follow the channel wires from the speaker that is playing up till you get to the power amp. Look around for anything odd. Compare it with the other channels, as they are good.

Oct 03, 2017 | Marantz Audio Players & Recorders

1 Answer

I have a visonik 800watt amp and i got it from a friend for free and i hooked it up right and as soon as i turned it on the 2 fuses blew then i replaced them and tryed it again and it stoped again so i...


Its the amp, do not put any more fuses in it
you need to get it checked out by a technician.

Its probably a power supply fault or blown output devices.

Hope this helps
Thanks for using FixYa

Aug 02, 2010 | Visonik V2508 2-Channel Amplifier

2 Answers

I have a pyle pld5mu and everything is working but the sceen wont show now


may be some connection are broken.. or lost contact with the board..

Mar 24, 2010 | Pyle PLD5MU Car DVD Player

1 Answer

Amp is connected to the + wire, shared with the car radio itself. When i turn on the car radio the woofer only ''booms'' around every half a second and gets louder, even when no music is being played. Amp...


the problem lies in your wiring . you need a amplifier wiring kit u can get best buy that can handle 650 watts and go direct to battery under the hood. just the battery positive running to the + on the amp.make sure the remote wire or the r+ on the amp is not hooked up to power.what radio do u have?

Mar 06, 2010 | Car Audio & Video

1 Answer

Just hooked up the cde 100 and can't get my amp to power up


Solved it by attaching the very small hot wire, that is located on the RCA cablethat runs to the amp, that looks very unimportant, but is very very important to a accessory hot wire. Problem solved. Plays like a champ.

Dec 31, 2009 | Alpine Car Audio & Video

1 Answer

I need to add outdoor speakers,and the headphone


I would run the headphone jack to an amp then hook up you outdoor speakers to the amp.

Oct 07, 2009 | Sirius SUBX1 Universal Plug and Play Boom...

1 Answer

Sony radio sub outputs don't work at all


you may need a new head unit. it sound like you have lost the fron rca hook ups on your unit. common prob. usually cause by a surge traveling then the rca cables. i myself have had this happen and there is nothing you can do to the unit to fix it.

Sep 26, 2009 | Sony XS-V1330 Coaxial Car Speaker

1 Answer

Problem with subs and amp


I would first suggest un-hooking the subs, and hooking them up to another known good radio other than the one its hooked to now. Just to make sure you didnt blow the speakers. What is the wattage of the subs? Then if the speakers do work I would hook them up bypassing the amp just to see if the problem exist before or after. Come back after doing this. Thanks

Jul 05, 2009 | Car Audio & Video

Not finding what you are looking for?
Kicker IX702 Car Audio Amplifier Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...