Question about Balboa Instruments Duplex Digital Panel 2 Pump

Open Question

Dr error with balboa m7 system

I have Balboa spa with M7 system, I just replaced circuit board and heater. I refilled water and powered up spa. It passed priming mode and then showed dr error when spa tried to heat the spa. Pumps run and water flowed from jets to filter.

Posted by Anonymous on

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: I have the Balboa 500Z pump heater kit. Its hooked

I have a 6 month old Balboa 500Z. I have noticed that the filter system tis running all the time 24/7. I have reset the filter cycle to run for 2 hours { F2 }. It still is running all the time. It dose not seem to make a difference what I set the cycle for it just keeps running

Posted on Jul 19, 2011

Ad

SOURCE: I have just refilled by

Priming can be done many different ways depending on thetubs design. Some tub manufactures provide bleed valves located on the plumbingjust beyond the pump and heater unions. Some pumps have a bleed valve locatedon the pump. If there are no bleed valves then you will have to release theunion nuts to allow the air to escape.
You can find answers to common spa or bath problems online at http://www.balboadirect.com/support.aspx
Hope that helps.

Posted on Sep 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Jacuzzi spa with a Balboa R576 (522205) control box. The control panel constantly shows "OH" (overheating) even when the water temp is 50-100 degrees F. When I reset the system by flipping the...


Hi,

There are some things to check.
Make sure the vents on your cabinet are not obstructed.
Make sure your filter cycle is not too long
Make sure you are not running high speed for more then 30 mins.

Have you looked through the Balboa error message site. I have attached a link follow your error through and you may find your answer. Diagnostic Messages

Mar 02, 2015 | Balboa BB58048 Jacuzzi R574 R576, 4.0KW,...

1 Answer

Balboa hot tub m7 wont power on at all


Either the spa is incorrectly wired or one of the fuses is blown in the spa pack. Typically this is due to your electrician wiring the spa incorrectly and blowing the fuse on accident.

Aug 06, 2012 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

I have a Balboa VS500Z . The circuit board burned up where the heater buses are located . I replaced the board and the heater . Know when I start the Spa it primes at low speed for about a minute . Then...


Hi,

DR code - Inadequate water detected in heater.
HL code - Hi Limit, Spa over heat. In your case the Hi Limit is preventing the element from burning out.

This means there is no water or not enough water flowing through the heater.
Common causes:
Hi Limit sensor failure.
Blocked suction, skimmer.
Are the gate valves all the way open/up?
Pump is not functioning correctly, impeller/wet end failure.
These are the most common, but there are also other causes.

I hope that helps

Feb 20, 2012 | Garden

1 Answer

Spa Heater problems- Balboa VS-501 controls #54356.


Use a high quality external temp probe and make sure the temp sensor in your system is correctly reading the water temp.
If the water is truly 110 then you may need to replace the board completely.

Jun 20, 2017 | Pool & Spa

1 Answer

I have a balboa board #55098 and nothing works. I have disconnected everything and then tried powering up and it only clicks until the breaker trips any suggestions?


As with any troubleshooting over the Internet, this is like giving a haircut over the phone. So, that being said, this problem could be any number of reasons.

Here are some things you should have a spa technician look at (not in any specific order):

  • Power connections
  • Relay
  • Whether the transformer is seated properly
  • Whether there are loose wires
Disconnected all the components and see if it still does the same thing. If not, then one by one, reconnect the components until you isolate the problem. If the problem persists, then you might have a larger problem like a blown circuit board, etc.


Hope that helps!

Jun 17, 2011 | Balboa Instruments BALBOA 30 kW HEATER W...

3 Answers

Balboa vs500/501/502 gs500/501/502 I just refilled spa yesterday and now I'm getting error codes HL and dr both indicate low flow issues, The water level was re-filled to where it's always been. Any help...


A lot of times you can get an air lock as the spa fills. All you need to do to fix this is open the drain valve for a few seconds till it runs just water and no air. Or start the pump wile the drain is open. This should fix your problem. Good luck.

Sep 04, 2010 | Balboa Instruments Duplex Digital Panel 2...

Not finding what you are looking for?
Balboa Instruments Duplex Digital Panel 2 Pump Logo

Related Topics:

46 people viewed this question

Ask a Question

Usually answered in minutes!

Top Balboa Instruments Garden Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Paul Stonecypher
Paul Stonecypher

Level 1 Expert

28 Answers

Mister Danger

Level 3 Expert

5631 Answers

Are you a Balboa Instruments Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...