Question about Hoover F7452-900 SteamVac Upright Vacuum

1 Answer

Machine not dispensing water or solution.

Machine turns on and sounds like it's working, but won't dispense water or solution. I cleaned valve as suggested in the owners manual, but still not working.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 100 Answers

Air locked.

Posted on May 06, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 126 Answers

SOURCE: not sucking up dirty water

The F5914 has a lid that must be engaged with the tank in order for the suction to reach the floor. Gently lift the front of the lid on the tank and if it lifts up, you haven't engaged the two tabs on the tank into the lid. Remove the lid and make sure the tabs on the tank fit into the grooves on the lid and snap it closed. This should solve your problem. Also, make sure that the removable duct in the front of the tank is in place. It is removed when the hose is used, but must be replaced when the machine is used on the carpet.

Posted on Feb 02, 2008

reddevil6
  • 1673 Answers

SOURCE: Will not dispense water or solution

On the bottom of the tank is a valve, push it in and see if water comes out Where the tank sits, there is a black round seal, is it in the proper place? The rod in the handle hits just under that seal, with the tank off, you can see if the rod is movin up and down when you depress the trigger. The resevior asm. may be bad, that is what the tank sits on.

492f9ff.jpg

Posted on Mar 11, 2008

reddevil6
  • 1673 Answers

SOURCE: Hoover 3010 FloorMate Plus not dispensing liquid

With the tank off, can you see if the rod in the handle is hitting the spot where the tank sits on, if not then there is a problem in the handle. If it is, then the reservior asm may be bad, it is what the tank sits on.

Posted on Jun 17, 2008

  • 8 Answers

SOURCE: won't dispense cleaning solution

I had this same problem. There is a solution posted elsewhere on this website. Search for Hoover Floormate H3000.

The following solution is the one I tried: Remove the fluid dispensing tank and put a small dab of hot glue on the tip of the blue/greyish "plunger" piece that is located in the middle of the black rubber circle. Let the hot glue dry (this forms an extension to the plunger piece...) and replace the fluid tank.

I did this and my machine is working properly again! Whoever posted this solution was very helpful!

Posted on Aug 29, 2008

  • 8 Answers

SOURCE: Hoover FloorMATE 3000 won't dispense cleaning solution.

I had the same problem with my Hoover Floormate H3000 and found the solution elsewhere on this website. Try doing a search for Hoover Floormate H3000. The posted solution is basically as follows:

Remove the liquid dispenser tank and set it aside. Look into the cavity of the machine where the tank attaches and find the plastic "plunger" piece (the one on my machine is a blue/grey color) that is surrounded by a black rubber circle. Put a small drop of hot glue on the tip of this plastic "plunger" piece and let it harden. Replace the liquid dispenser tank and try the machine again. My machine dispensed liquid properly after this fix-it.

I really appreciate the poster who provided this simple solution!

Posted on Aug 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Water not dispensing


Check the release valve on bottom of clean water reservoir unscrew if needed, once again if your not sure run hot water in the solution tank through the system to help remove old soap residue and always run hot water through to prevent future problems after cleaning carpet and storing.steve

Jun 06, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

2 Answers

Soap solution valve on wand is not working.


No quick fix. Just make sure to run clean water through it before storing. Also, soak it in hot water, when it becomes plugged. I have dismantled my a few times, to clean it out, but have kept it clean to void future problems.

Nov 27, 2009 | Bissell 1425 Little Green ProHeat Handheld...

2 Answers

Bissell ProHeat Rug and Floor cleaner. Won't


Hi,

Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems

heatman101
sf

Oct 20, 2009 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

I have the Quick Steamer Plus 160 Series/2070 Powerbrush. It will not release cleaning solution and will not pick up solution that had already been dispensed. Is this something simple I can fix???


I checked the bottom of the fresh water supply container and all was well there then I used a pin in the tiny air valve on the container. Turned the machine on, pulled the lever to release water and held it for several minutes and finally the water started to release and the machine works fine now.

Aug 01, 2009 | Bissell 1960-3 QuickSteamer Plus Upright...

1 Answer

Water does not dispense on wash cycle


this would be the soap/ water valve. it is stuck closed or isn't opened.( no cure for an non-opened valve, just replace.)

Jul 16, 2009 | Hoover F7220900 SteamVac V2 Upright Vacuum

2 Answers

Soap dispenses, water won't


Could be the pump, but this model clogs up easily. You could try taking the noozles off and blow thru them to see if they are clogged or not. Other then that you may have to take it in for repair, It can be problem to find where it is clogged, if the noozles are ok that is. Unless you want to take it apart and try to find the problem yourself.

They all have problems. Hoover over Bissell, or Eureka. But it is hard to know which is better.

Aug 01, 2008 | Bissell 9500 ProHeat 2X CleanShot Upright...

4 Answers

Flow Indicator Not Moving, Not Dispensing Anything


The water tank and the solution tank both have red gaskets that attach to the bottoms of the tanks. Make sure they are on properly, I just had the same problem and spent hours taking apart the machine and inspecting lines to find out it was a gasket.

On my machine the red gasket for the solution got stuck in the chasis for the machine. The bissel website alludes to this, but isn't very clear.

Other posters talk about the heaters, or the lines being clogged and I immediatley inspected these areas, turns out it was a gasket that was hiding in the chasis. Both the water tank and the solution tank should have one, and make sure they don't get nestled in the chasis!

Apr 13, 2008 | Bissell 9500 ProHeat 2X CleanShot Upright...

3 Answers

Not dispensing water and no suction


I'm assuming the belts are OK.... Your heater is clogged. Unplug the machine and let it sit for 30 minutes. Take the handle apart, there will be a 4 inch by 8 inch metal box inside. This is the heater. Remember I said to let the machine sit for 30 minutes? If you didn't, the heater may be EXTREMELY hot!! Disconnect the two hoses going into it, and clean the metal pieces out (that the hoses connected to) with a needle or very small drill bit. You may want to remove the 6 or 8 screws holeding the heater together and remove the cover to clean it out. Reassemble and fill both tanks with VERY hot water ONLY and run the machine to rinse the entire system.

To prevent future reoccurences... use only Bissell extraction shampoos. Never put anything in the detergent tank except shampoo. (And only water in the water tank) Mixing chemicals with anything else turns the water/detergent mix to sludge. Also, when finished shampooing, put ONLY water in both tanks, and run the machine until one of the tanks run out of solution. Doing this rinses the hose lines out and prevents hardening of the solution in the heater ports.

I've fixed these machine for years. No dispensing is almost always the heater clogged.

Sep 29, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

4 Answers

Bissell pro heat cleaner


This could be due to dried out soap in the works below the dispenser. Try cleaning the hole, putting plain water in the soap dispenser to clean it out further. You could just put some soap in with the water. Be sure to run lots of rinse water through afterward to clean out the heating unit.

Aug 18, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

Not finding what you are looking for?
Hoover F7452-900 SteamVac Upright Vacuum Logo

Related Topics:

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

Brad Brown

Level 3 Expert

15478 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...