Question about Maax Home

1 Answer

Purge line MAAX tub has bottom and side jets, the jest still work but the unit nolonger purges after being drained after 15 minutes as it should, result is water being left in jets and mould coming out when they are turned on...I can trick the tub into thinking it is full of water and put jets on, in manual says if purge cycle doesn't work reset breaker, is this breaker in basement (which I did), or a breaker in the electrical equipment of the tub?

Posted by on

  • Michel Chiasson
    Michel Chiasson Apr 13, 2014

    thanks for 3 responses already, want to clearify, the jets themselves work great, bottom jets, both side jet systems, all blowers seem to work great, they just dont purge with qir for 15 seconds after the tub is empty for 15 minutes as they should be programmed to do, so it doesnt seem like a blower problem, the manual talks about resetting the breaker??? what breaker??? when I look under the tub there are just a bunch of sealed black electrical boxes...

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Maax Master
  • 717 Answers

The breaker the manual is referring to will be the main circuit breaker at the panel.
If the system is not running the purge cycle as it is supposed to and turning the power on and off does not reset the control box then it is likely that the control box has a bad part in the circuity and should be replaced.

Rod
US Parts Center

Posted on Apr 13, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 80 Answers

SOURCE: need replacement parts for a

Try Guillens.com or usparts.com I have had some good luck finnding jets. Maax is still in business and you might be able to get the jet directly from them, although they are in Canada. Hope this helps.

Posted on Aug 12, 2010

  • 15 Answers

SOURCE: my bathtub jacuzzi wont work. I reset the circuit

make sure you have power to outlet that motor is plugged into,if so try pushing jet button in tub about ten times in a row quickly then on tenth push use as much force as possible and hold.if this does not work,air hose from back of button to pump motor may be disconnected.

Posted on Oct 04, 2009

  • 80 Answers

SOURCE: Cold air blowing into Maax Velvet 6032 Bubble Tub

The air coming from the blower will be cool, but should not be cold. Turn on the blower or bubbler feature (no water necessary) and go to the access panel ( as specified by install instructions), reach in and feel the tube connected to the blower, the tube should be warm, if not the heater coil is not working and the blower assembly needs to be replaced.

Posted on Aug 19, 2009

  • 274 Answers

SOURCE: Our Max jetted tub won't

see if ther is another panel arond tub,there may be another breaker,try resetting breakers turn off the back on,see if this works

Posted on Aug 29, 2010

  • 2 Answers

SOURCE: Jetted bath tub has stopped working. Motor hums

I had this same problem on my tub, which uses a GE motor. I looked at the motor, and on one end (the end opposite where the water comes out) there is a hole in the middle. In that hole is the head of the shaft, which has a regular screw tip. Turning this turns the motor. I filled the tub, inserted a slotted regular screwdriver and turned it about 10 times clockwise, then 10 times counterclockwise. You should see the whole motor turn. Doing this loosened it up, and then it started.

Once it started, all kinds or residue came out, which was probably why it had stopped working. I hadn't used it for a while.

After getting it running I'm going to run some cleaning solution through it, and make sure I run it more often to prevent this in the future.

I'm not a professional, just a guy trying to fix his own tub. So take my advise with that grain of salt.

Posted on Nov 24, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

We have a Kohler Purist Air Bubble Massage tub... the last couple days the dial has randomly started lighting up with the green light tracking down the middle and you can hear the motor or the jets on the...


This is sounding like a relay not working on the circuit board inside the control box. You will want to have a Kohler service center send someone out to have it checked. You most likely need a new control box.

Aug 14, 2011 | Kohler K-1110-AH-0 Purist whirlpool with...

1 Answer

Need replacement parts for a MAAX WESTCO INC A159869 8Z31 Jet Bath Tub Would like to replace the white plastic parts in side the tub with chrome as they have turned yellow


Try Guillens.com or usparts.com I have had some good luck finnding jets. Maax is still in business and you might be able to get the jet directly from them, although they are in Canada. Hope this helps.

Aug 11, 2010 | Home

1 Answer

ICEU220HA1 ice machine is half full of water - water fills up through drain hole in the tub when cleaning/purging pump


You have a restriction in the drain line beyond the ice machine and the water is backing up into the unit. You can try some Drain-o or snake the drain.

Apr 21, 2010 | Ice-O-Matic ICEU220HA Undercounter Ice...

2 Answers

Overheating after driving 10-15 minutes


The most common overheating problem with the Northstar engine is a blocked purge line. It's job is to purge air out of the cooling system.
There is a small diameter hose coming from near the top of the coolant tank (not the cap) ,this is the purge line.
With the engine idling,pull the purge line from the tank,if there is no coolant flow from this small hose,it is blocked and this will cause overheating.If the hose is clear, check for blockage at the nipple on the tank.Or trace the hose back until you find the blockage.The hose goes in to the engine to a crossover and comes out the other side to near the thermostat housing,the blockage may be there.

Apr 17, 2010 | 1996 Cadillac DeVille

1 Answer

Hi, We purchased a Maax 10 jet Whirlpool tub


http://www.maax.com/Upload/guides/fr/000_10050073_0305.pdf.......this should take care of what you need. If you have any questions just ask.

Thx
Ken

Aug 12, 2009 | Home

1 Answer

Fuel problem 1999 blzer


Rather then guessing if there is water in the fuel , take a sample . If there is water in the fuel the water will be on the bottom an gas on top . Water is heavier . Disconnect fuel line at the fuel rail an cycle the key a few times , collect the sample in a glass jar . Let it sit for 5 mins. If there is water in the system it will be able to see for sure . Water In Gasoline What Does it Look Like How to Test the Alcohol Content of Gasoline

Apr 14, 2017 | 1999 Chevrolet Blazer

1 Answer

Cold water and jets don't work


Likely your mixer valve cartridge has a blown o-ring.
Replace the cartridge.
Jets not working may be as simple as the GFI outlet being tripped.

Thanks

Dec 16, 2008 | Maax Studio 1-Piece Hydromax Whirlpool Tub...

1 Answer

Jacuzzi


you have to call the maker of your unit because the gasket can start leaking if you use the rong kind of cleaner

Dec 12, 2008 | Maax Studio 1-Piece Hydromax Whirlpool Tub...

2 Answers

Indoor jacuzzi bathtub problem


Just add 1/2 cup bleach to a full tub of clean water, turn on the jets.

Grab a small goldfish strainer / net and scoop out the moldy chunks.

Keep cycling the water until most of the chunks are gone.

Drain the rub, refill and add 1/2 cup bleach again, repeating the process.

The problem is caused by water left in the lines after use, and it turns moldy.

After each use...drain the tub completely, then turn on the jets for about 10 seconds. This will purge the lines of any standing water.

Fill the tub with clean water and cycle the jets with bleach once a week to prevent any further problem.

Hope this helps...it worked for me, I had the same problem.

Nov 27, 2008 | Home

Not finding what you are looking for?
Home Logo

Related Topics:

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top Maax Home Experts

Donni Steen

Level 3 Expert

659 Answers

Mike

Level 3 Expert

4340 Answers

James Feragola
James Feragola

Level 1 Expert

24 Answers

Are you a Maax Home Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...