Question about Kenmore Electric Smooth Top Stove

1 Answer

While oven on range top front is very hot

Model 790. The Front Part of the Stove top above oven door reaches temps great than 175 degrees while oven on and range top is not being used.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kenmore Master
  • 3,368 Answers

I do not know the unit but check if the oven vent is near the front. It is also possible the door seal on the top of the door is failing.

Posted on Apr 29, 2014

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 31 Answers

SOURCE: I have a Kenmore Elite Gas Range. #790 series.

Possibly a malfunctioning electric gas valve. The electronics may be sending the message to open that valve, however it could be stuck, clogged or, worse, the electric servo that manipulates it could be fried (no pun intended).
Do you have your exact model #? {Not serial} I can research where to troubleshoot a valve problem or an electronics issue.

Posted on Jan 05, 2010

  • 189 Answers

SOURCE: Kemore gas range model #790: oven does not get

Hello- Sounds like lower burner ignitor is bad. Resistance should be more than 4ohms. across ignitor. Parts available locally at app. parts store for 50-75$. Fairly easy to install. - Hope this helps. Thanks- ED

Posted on Feb 28, 2010

Testimonial: "Thanks!"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenmore 790 oven won't maintain temperature


anyone know where to buy the battery for hand phone model mini i9500 ? manufacturer is
z.doxio

Nov 12, 2013 | Kenmore Kitchen Ranges

3 Answers

I need to replace the hinge receptacles on a Jenn-air wall oven (WW30430PC). How do I access those parts?


The only way to replace the hinge receptacles is to pull the oven out of the opening. If you need parts you can get them on the link below. Also if you call the link below they will walk you through on how to replace.

http://www.appliancepartspros.com/partsearch/model.aspx?model_id=45883&diagram_id=28594572#d28594572

May 16, 2011 | Jenn-Air Ovens

1 Answer

Electric stovetop gets VERY hot


LIFT TOP FROM FRONT ABOVE OVEN DOOR. TURN OFF POWER BEFORE SEVICING.

Oct 20, 2009 | Maytag MER5775Q Electric Kitchen Range

1 Answer

Oven is not heating properly


Could you find the completer mode number because the number listed above your post is for a gas oven.
Look at following areas for the model number
  • Under Right Front Burner
  • Under Left Top Burner Front Or Rear
  • Under Main Top Left, Rear Or Center Front
  • Under Left Rear Or Right Front Element
  • On Nameplate Inside Burner Box
  • On Front On Burner Box Bottom
  • On Nameplate On Oven Door Liner
  • On Main Front Behind Oven Or Compartment Door
  • On Front, Center Bottom Of Burner Box
  • On Thermostat Cover Under Main Top
  • Thank You, Sea Breeze

Mar 25, 2009 | DCS RGS-484GG Gas Kitchen Range

1 Answer

Jenn-air stove temperature not constant


Sounds like your oven probe sensor has got issues. Pretty easy to fix, just look inside oven for the probe (small round cyclinder, about a pencil width or smaller, mounted usually in the back top corners), remove the two screws, then slide it out. Some models have the probes where you will have to take the back off to get to them. If your probe is ok, then you might possibly have an issue with your main oven control, which may be computer or knob type. These (especially if computer driven) can be very expensive to fix, and some need calibration. Good luck and let me know if you need any other assistance.

Nov 16, 2008 | Kitchen Ranges

1 Answer

Frigidaire Stove elements not working


First thing I would check is see if you are getting 220 volts to the stove.  Must be a constant 220.  Let me know what you find.

Oct 15, 2007 | Frigidaire FED300AS Electric Kitchen Range

1 Answer

Oven does not maintain temperature. Part 2


sometimes when they get hot that is when they fail

Sep 18, 2007 | GE Profile Spectra JGBP90 Gas Kitchen...

Not finding what you are looking for?

Open Questions:

0 Answers

Kenmore simmer select board problem The SS button tripped my house breaker. I haven't used SS since (button is now 'off') so not sure it is working - pretty sure it is not. Otherwise, all of the stovetop elements seem to work fine. The 'Element on' light works (on when any burner is on, off when they are all off). However, none of the 'hot surface' lights work for any of the burners now. Is this just a SS board component that needs replacing? Or the whole board? I do have meters and experience to fix if someone can link me to a schematic or steps to test. Whatever happened to the SS board appears to have prevented the 'hot element' lights from working. EDIT: the model info is 790.96223409 **************************************** EDIT2: I found a schem for this; as the SS board indicator light shares neutral wiring with the other lights, is there a simple fix to disconnect one of the connections to this part of the board wiring, so that those lights will work again while I'm waiting for a new board? Pretty sure I have a bad relay on this board and will need to swap the whole board out, but I'd like to be able to check that those other indicator lights and circuits are ok so when I do get a new board, everything will work normally. ************************************** EDIT3: I rechecked the stove around lunch today; it does look like my 'hot burner' lights now work (maybe a relay was partly stuck open or shut on the board?); so, I may only need a new SimmerSelect board. I'll check for anything that looks burnt when I have the time to pull the oven out and open up the back. I did get the time to turn on each burner to 5 or 6, make sure they all got hot, and then turned down and they do all seem to regulate ok. If my 'hot burner' lights stop working again/become intermittent, I'll drop another update here. It does appear these boards are a common problem - are the relays not designed for 'hot switching' on these, and the burner switch should be completely 'off' when tripping the SS switch? That would seem to be a design flaw, if so.

Sep 27, 2016 | Kenmore Electric Smooth Top Stove

See all Kenmore Electric Smooth Top Stove Questions

Kenmore Electric Smooth Top Stove Logo

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Kitchen Ranges Experts

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Cindy Wells

Level 3 Expert

5054 Answers

Mike Carew

Level 3 Expert

969 Answers

Are you a Kenmore Kitchen Range Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...