Question about Jl Audio E6450 Car Audio Amplifier

1 Answer

Jl audio E6450 cutting out

I just installed a jl audio E6450 w/2 10w3v3 subs and as soon as I turned it up she goes into protective mode why? Now I installed it myself, but I used all JL audio install kits. Does having the Bass boost remote make a diffrence? Does the way you bridge it make a diffrence and what can be done? Help please........O the amp is used but only 6mo old. What would be the propper way of installing the subs (max watts to each sub etc..) to the amp?

Posted by on

  • ONE2PAC842 Apr 07, 2008

    hi, ...i have the same amp
    ....and as soon as i finished the connections ...and connect the remote
    on wire,,, the amp goes on ...making a ticking sound with the green
    light blinking and the red light staying solid on ...whats the problem
    please help ....how can i fix this ......my amp is a jl e6450 ....im
    using a panasonic cd player with a built in amp ....and thats the cd
    player im trying to connect to the jl amp ...please HELP

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi, have you figured out whats wrong with ur amp ...i have the same amp ....and as soon as i finished the connections ...and connect the remote on wire,,, the amp goes on ...making a ticking sound with the green light blinking and the red light staying solid on ...whats the problem please help ....how can i fix this ......my amp is a jl e6450 ....im using a panasonic cd player with a built in amp ....and thats the cd player im trying to connect to the jl amp ...please HELP

Posted on Apr 07, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What can I do when my amp goes into protect mode? A6450 class a/b Jl audio


Check your speakers wiring to make sure they are not touching. This will make your amp go in protection mode.

Mar 10, 2015 | Jl Audio Car Audio & Video

1 Answer

Jl 1000/1 goes into protective mode with low frequency


Do you have a capacitor????? If not, when its up loud and hitting hard it might be going into protection because of a voltage sag....If it goes below 11.8v they will usually do that.....Get a multi meter and put on the hot and ground of your amp when its playing loud and see what the voltage is dropping to.....If its going below 12v, thats your remedy...gd luck....

May 02, 2012 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

XA10002 dual channell amp pushing a single 12 inch JL Audio sub and continues to go into protection mode. All setting are turned to the lowest possible and remote wire, power wire, and ground wire are all...


Make sure you are wiring the sub to the correct ohm's. Some amps have a protective feature that will send them into protect mode if they do not since the right ohm load. If the sub is wired correctly double check your ground wire on the amplifier, and if that if also fine then your amp will need serviced.

May 31, 2011 | xXx XA10002 Car Amp

1 Answer

When i turn my volume up to a certain point the power light on my amp will blink off and on and the subs will cut off...what could be some possible solutions? is the amp not suppose to be tuned up? it...


Sounds like you are showing too low of an impedance load to the amp. The E1200 is only stable as low as 2 ohms. If your subs are wired to show lower than a 2 ohm load then the amp will go into protection mode as the volume or gains are turned up

Dec 23, 2010 | Jl Audio E1200 Car Audio Amplifier

1 Answer

Amp goes into protection mode when i turn up volume


Sounds like you are running your subs at to low of ohm. Amps are rated differently on the levels of ohms or resistance that they can get to. If you have a dual 4ohm sub and run it in pairrell it will drop to 2ohm and if you run the same sub in series it will be 8ohm. Your amp will go into protection if the ohm is to low.

-david

Nov 07, 2010 | Jl Audio 12W6 Car Subwoofer

1 Answer

I have a JL total mobile audio T500.1 mono amp and it was playing then all the sudden it stopped and the power light which is usually green is now red and stays red and no sound comes from the subs any...


This happens when the amp goes into protection mode. 90% of the time, it means there is a short or has another issue inside the unit and has to be fixed or replaced. Hope this helps and good luck!

Jul 09, 2010 | Jl Audio Car Audio & Video

2 Answers

Amp comes on then shuts down JL 500/1


what do you have hooked up to it? Subs, Speaker, so on. it sounds like it is going into protection because of improper wiring... or it was improperly wired. if it is malfunctioning you need to take it to an authorized JL audio dealer. It's going to cost some cash unless you have a warranty on it and it was installed by a liscensed technician.

May 31, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I hooked up my two 10 inch JL Audio W3v2 2 ohms to a mono JL Audio 500.1 amp and the subs will not work. I have the subs wired in a series. I then hooked them up to my friends amp and the subs worked. Any...


try one at a time. if they work then try hooking them up differently. if none work, then check to see that your amp is not in protect mode. if amp is ok, then check to make sure you have your rcas connected to your amp. in other words, re-check all your wiring. if still nothing, try your amp on your friends car and vise versa.

Apr 01, 2010 | Jl Audio 10W3v2 Car Subwoofer

1 Answer

When i turn on the key the protect light comes on and it makes a funny sound


Something is shorted most likely. Check the wiring to your speakers. Check especially for stray strands of wire where the speaker wire connects at the amp and speakers.

Nov 16, 2009 | Jl Audio E6450 Car Audio Amplifier

4 Answers

I have a jl 1000/1 amp hooke up to 2 12 w6 subs and when i turn the volume up half way the speakers cut out and amp stops working but i turn the volume back down and it works fine. what could this be?...


what is happening is the amp is going into protect mode because it most likely is at the wrong oms and is getting over loaded and shutting itself down to protect it self!

do you know what ohm load you are presenting to the amp? or what ohm are the subs ?

if you correct the ohm load it will fix your issue and make the system sound way better! let me know if you have any more question and let me know about the ohms! good luck

Oct 02, 2009 | Jl Audio 1000/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio E6450 Car Audio Amplifier Logo

378 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

hoyzee1

Level 2 Expert

150 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...