Question about Alpine MRD-M300 Car Audio Amplifier

1 Answer

My MRD-M300 amp will stop working when I turn the volume up and E-3 will come up on the amp. I know E-3 means there is too much current and I have tried changing the settings on the amp but it will still turn off when I turn the volume up. So please help me cause this amp is pissing me off!

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

There are a few things you should check:

Check that you have the correct fuse on your power cable. If it is allowing too much current, the protection feature of the amp will kick in. Similarly if the resistance is too high, there will not be enough current to power the amplifier.

You may also want to check the earth/ground cable to ensure that it has a good connection.

Try increasing the gain slightly on the amplifier (not too much or you will blow something). This will mean that you don't have to turn the head unit volume too high to get a loud output.

Nice amp BTW.

Posted on Jun 18, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a alpine mrd-m300 amp and it will come on the voltage meter comes on and everything comes on i just get no sound to subs i hooked it up to another amp and it work just can get sound of of this amp...


Make sure your safety mode is off. Go to mode 9 and ENT and make sure it is off. If it still dont work you proabably have bad RCA wre or speaker wire. Hope this helps!

Mar 02, 2013 | Alpine MRD-M300 Car Audio Amplifier

1 Answer

My alpine Mrd-1005 has been best amp ever. But the other day it all of a sudden started blowing fuses on the amp and the current protecter mode kicks on.. as long as I keep volume down in works but as soon...


make sure there is equal amps on the fuse under the hood and at the amp...also make sure to never mount your amp to anything metal....wood only! hope this helps, mine did the same thing

Sep 04, 2011 | Alpine MRD-M1005 1000 Watt Mono Amplifier...

1 Answer

Ok i got a mtx 12' 500 sub matched to a alpine mrd-m500 mono amp. The deck powers the 4 speakers, as i turn the volume up on my deck (alpine cde 100) the sub/amp cuts out at around volume 20-22 and E-3...


Sorry,after rereading your problem,I gave a wrong answer.Do you have the deck sub RCA pre-amps connected to the amp,then the wires from the amp to the sub?If you do,you need to check what the sub and amp are rated as such as,peak or rms.They are 2 completely different meanings.Greg

Feb 11, 2011 | Alpine MRD-M500 Car Audio Amplifier

1 Answer

E-3 comes up


Hello svjonny13,

Excessive current draw can be caused by a short in the wiring, especially the output. Also, an amp may draw excessive current when operated into a lower impedance load than it can handle.

Too low of a supply voltage may result in the amp drawing excessive current, especially when operated at or near it's rated output. Voltage multiplied by the current equals watts. So if the amp is trying to produce X number of watts, the lower the voltage, the more current it needs. A power wire that is too small or too long may have too high of a voltage drop. A high resistance in the ground connection can also result in a significant voltage drop. Again, too small, too long, loosely fastened, or perhaps corroded. I'd check all wiring

Internal component failure can also cause excessive current draw. In that case, the amp needs service.

Hope this helps.

Jun 16, 2009 | Alpine MRD-M300 Car Audio Amplifier

1 Answer

Watts


The MRD-M300 has speaker-level inputs so you can easily use it with any car stereo. Hook it up and hear what good bass can sound like!
Details:
  • 150 watts RMS x 1 at 4 ohms
  • 300 watts RMS x 1 at 2 ohms
  • MOSFET power supply and output stage
  • STAR Topology for cleaner sound
  • Bass Engine® features:
    • low-pass digital crossover, 30-200 Hz, 24 dB/octave
    • variable subsonic filter (15-50 Hz in 5 Hz steps)
    • parametric EQ variable from 30-160 Hz
    • Bass Compensator enhances low-end definition
  • top-mounted digital control center with cover
  • time correction 0-10 milliseconds in 0.5ms steps
  • phase correction 0-180° selectable
  • digital readout
  • detachable front cover
  • blue power LED
  • delayed turn-on
  • requires 8-gauge power and ground leads — wiring and hardware not included with amplifier
  • speaker- and preamp-level inputs
  • gold-plated terminals
  • 8-5/16"W x 2-11/16"H x 11-1/2"D (10"D without front cover)
  • 1-year warranty

May 29, 2009 | Alpine MRD-M300 Car Audio Amplifier

1 Answer

How to get amp status to come up on the screen of alpine d 310


you have to have an alpine kce-510m amp link module. You must also have a compatible amp, such as mrd-m300, mrd-m500, or the mrd-m1000. The amp link module plugs into the (ext) plug on the iva-d310 and the other end of the cable into an alpine kce-060m y-cable. The shorter of the y-cable plugs into the amp with the lowest id #.

Feb 11, 2009 | Alpine IVA-D310 Car DVD Player

1 Answer

Lights on, nobody home


Appears to be an issue with current. Is the speaker the correct impedance for the amplifier ? Have you confirmed there are no short circuits in the wiring ? I'm not familiar with this particular product,

The alpine catalogue gives recommended amp/speaker combos. If you don't have an aplpine sub, then look at the specs and find a similar one. You may be trying to load the amp too heavily and it will protect itself.

Nov 18, 2007 | Alpine MRD-M300 Car Audio Amplifier

2 Answers

Could you help


i have lost the instruction manual for my alpine v12 mono power amplifier mrd-m300 could you send me a print out of it by any chance. Without it i am unsure of the controls on the unit thanks.

Apr 27, 2007 | Alpine MRD-M300 Car Audio Amplifier

1 Answer

Led read out


E-3 The amplifier has been shut- down due to excessive current. Find and eliminate the cause of the excessive current, then turn the power off then back on from the remote control unit.

Jan 28, 2007 | Alpine MRD-M300 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRD-M300 Car Audio Amplifier Logo

Related Topics:

236 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4875 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Jaime Hernandez

Level 3 Expert

2318 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...