Question about Vacuums

1 Answer

Miele model s-314-i

Does not run when plugged in and switch is turned on

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Vacuums Master
  • 76,846 Answers

U will need to pull the power switch out of the vacuum and test it.

Posted on Jun 16, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Miele revolution 5000 no power light flashing


I would refer to your owner's manual. If the manual has no resolution, then I would contact the manufacturer directly.

May 08, 2012 | Miele Vacuums

1 Answer

It's plugged in but won't turn on?


Let's do some trouble shooting:

With it plugged in, do you see any lights on the control panel?
Miele also has a little device, that let's you 'park' the floor want in a neat little slot at the handle end of the machine-- and when it is plugged in there, the machine shuts off.

Finally there are switches on the top of the machine that control the speed of the machine-- what happens when you operate that switch-
The other switch turns it on and off-- Do you feel the switch snap when you push it?

Let us know what you find--

Mack B

Jan 20, 2011 | Miele S318 Bagged Canister Vacuum

1 Answer

Our miele red star(s314i) vacuum was running great and quit suddenly. It had not been running for a very long time and just quit. Newish bag, no clogs in hose and doesn't seem overly hot. the over heated...


Ok, so if the cord test didn't fix the problem, then it sounds like either the plug has gone bad, or the switch. The plug is a very common problem to go bad, and can be caused by just simply yanking the plug out of the wall, or putting too much tension on the cord while you're vacuuming. Here's a link showing how to replace a plug on your Miele. You may purchase a plug at a Home Depot for very cheap. If this doesn't fix your problem, then it is either going to be the entire cord reel assembly that's gone bad, or the switch. The plug is the easiest, cheapest next best option, so hopefully this is your problem. Here's a link on how to change the plug out;
http://electrical.about.com/od/diyprojectsmadeeasy/ss/replacecordplug.htm

Please just use the comment field again if this doesn't fix it, and I'll walk you through step by step the more detailed process of replacing the cord reel.

Jan 17, 2011 | Miele Red Star Bagged Canister Vacuum

1 Answer

My miele titan is not turning on when plugged in. i think it might be some sort of clog? but the electric head is working... help!


Wow!, that's not typical of a Miele, especially a new model like the Titan which has been on the market for less than 2 years. If I read this correctly, your power nozzle (electric head) is working, but the main suction motor is not. Thta's usually a sign that the carbon brushes in your suction motor are stuck or too short. Again, not a common problem with Miele. A clog could cause your machine to run hot from reduced airflow and then shut down until it cools, but it would shut the whole machine down, not just the suction motor.
Is your power dial, (located just forward of the main switch and cord retractor buttons) set to minimum? If so, you just might not be getting enough suction. If, after turning the dial to maximum, you still get no suction, then you should definitely take it back to the dealer you bought it from. You have a 7 year motor warranty and a 1 year warranty on all non-wearing components. If you bought your vacuum on the internet then you can go to www.mieleusa.com and search for a local dealer. There is a 'Dealer Locator' link on the left side menu.

May 18, 2010 | Vacuums

2 Answers

Miele just stopped working?


Hello,

When a Miele canister just stops working all of a sudden, it's usually a pretty clear indication that either you have a bad cord reel, or a bad switch. I would say that in 60% of Miele repairs that I do with this problem, the cord reel has gone bad.

One easy thing that you can try to see if the cord is bad, is put one hand on the on/off switch, and the other hand grab the cord (making sure it's fully retracted inside the canister). Now pull the cord out slowly with your one hand, while continously turning the switch on / off, on / off. Keep pressing the switch on and off while pulling on the cord. Usually if the cord reel has gone bad, then you may hear the vacuum attempt to start, or even turn on while you're pulling on the cord. The cord reels in Miele use a metal spring inside that makes connection with the rest of the vacuum. Over time this spring will start to loose it's strength, and eventually will get so bad that it no longer makes contact with the rest of the vacuum. By pulling the cord out slowly and pressing the on / off switch, a lot of the times the spring will make connection somewhere, and the motor may turn on temporarily.

If this happens, this indicates your cord reel needs to be replaced. I have done a detailed repair here on Fixya on how to replace the cord on a Miele canister vacuum that you may read here;
http://www.fixya.com/support/t2281026-miele_s514_will_not_come

If you can't get the vacuum to turn on at all, this can only mean a few things. First the cord reels spring is gone completely, and wont make any connection with the rest of the vacuum, and you'll still need to replace it.

It also can mean that just the plug that plugs into the wall is bad, is your plug bent, or no longer straight on either prong?

It can also mean that your motor has gone bad. This however is usually the least likely of all the problems. The Miele motors are almost bullet proof, and typically last 20 years. I can count on one hand the number of Miele motor replacements I've ever done in 10 years of fixing vacuums.

I can try and help you diagnosis this further if my suggestions didn't help you. Please use the clarification request that you see here on this page to ask me a question. Please just let me know what happened when you tested the cord out as I suggested above. I really hope this was helpful to you. If you found this to be helpful, please be sure to rate the repair as helpful to you by clicking the thumbs up icon. I really appreciate that.

Chris J.

Mar 21, 2010 | Miele S318 Bagged Canister Vacuum

2 Answers

Miele, model # S 514 does not turn on.


Sounds like the cable may be damaged. I think you're going to need professional repair... sorry can't be more help.

Feb 17, 2009 | Miele S514 Solaris Electro Plus Vacuum

2 Answers

Miele Solarus Canister Vacuum stopped working


I am an amateur and novice.
Tracked My Miele problem to a bad connection at the outlet plug.

i think the constant slapping of the plug against the housing during rewind prob disconnected the wires inside the plug? Replaced plug

Apr 14, 2008 | Miele CatAndDog700 Bagged Canister Vacuum

1 Answer

New Miele Red Star - Powerbrush not working


Wish you had listed the model number of the vac and of the powerhead. The plug going into the cannister, is it pushed all of the way in, also same for the plug going into the hose end? You can hook up the powerhead plug to a/c and see if it runs, if it does, then it is ok. Unhook the hose and plug and hook up a/c to that plug end and see if the powerhead will run, if not maybe the switch on the hose handle has a problem. Otherwise you have a problem in the cannister. If this is brand new, then it has a warranty, take in for repair.

Feb 21, 2008 | Miele Red Star Bagged Canister Vacuum

2 Answers

Miele Vacuum cannister


Most times you have to replace the neck on the powerhead. Sometimes the switch in the handle of the hose will have a bad solder connection. But S300 is not a good model number, also the powerhead has its own number on the bottom, so couldn't look up parts for you.

Feb 21, 2008 | Miele S300 Bagged Canister Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18407 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...