Question about Polti Vacuums

Open Question

When you press switch it goes on and off

When you let go switch it keeps going for a few seconds

Posted by Anonymous on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Please help-the suction on our dc26 keeps cutting out a few seconds after switching machine on. Filters all cleaned and no visible blockage. What should I do?


Take it to your local vac shop for diagnosis. It could be several different things that can cause that.

Feb 19, 2015 | Vacuums

1 Answer

Bikegit


Replace the switch! It shut down when battery get depleted. and then when you start it again the cycle is shorter because the batery regenerate but not as previous cycle.

Jul 16, 2014 | Karcher WV50 Window Vacuum

1 Answer

The powerhead on my Hoover Duros will not keep running. If I push the on/off switch it will come back on sometimes, other times when I push it it turns the whole thing off as its supposed to do.


I just had the same problem with my hoover duros, the vacuum was running fine but the powerhead kept going off. I would make a sweep with it and powerhead would be running and then next sweep powerhead would shut off. I had tried checking connection and belt, etc. I thought it was the powerhead. But then I found the problem. On the duros there are 2 pieces of wands that hook powerhead to hose on canister. They both connected and clicked in fine but I decided to check them separately. I hooked just one piece to hose and powerhead and then turned it on and then I did the other piece. ta-dah! that's what it was...it was only one section of the wand. When I hooked them up separately, one piece the powerhead worked totally fine and vacuumed like normal. When I removed that piece of wand and tried the second piece (actually the bottom section when both are hooked together) the powerhead did not work at all. So I just need to get a new section of wand. Hope this helps!

Nov 17, 2011 | Maytag Hoover Duros S3590 Vacuum...

1 Answer

Sebo X4 Extra brush light remains on despite changing brush, any solutions?


Sorry you've had to wait so long for a reply. Perhaps you no longer need help, but here goes anyway. Must confess I'm not certain about this, but my guess is that the automatic height adjust mechanism (let's call it the HAM for convenience) isn't working properly. The HAM works by sensing the drag of the brush roll against the carpet, and raising or lowering the front of the machine as necessary to maintain constant drag. So first you need to check the HAM, as follows: with the handle in the locked upright position, switch on and wait for a few seconds (there may or may not be any signal from the green UP or DOWN lights). Then, still switched on, lower the handle to the normal operating position and check that the green DOWN light comes on. Wait until the DOWN light goes off and then return the handle to fully upright (switched on all the time). When fully upright the UP light should come on for a few seconds and you may be able to see the handle tilt backwards as the front of the machine rises. If this is all working properly, we need to look elsewhere for a solution. The next thing I would look for is for a broken belt. Just turn the machine over while it's running and look to see that the brush is rotating (keeping fingers and clothing well clear, of course). Sebo belts usually last 15 years or more, but breakages are not unknown.
I realise this may not exactly solve your problem, but it should give you something to work on. If you need more help, post a reply here, saying what you've found so far, and I'll try to be more specific.
Good luck!

May 09, 2010 | Sebo X4 Bagged Upright Vacuum

1 Answer

Foot activated power switch will not remain on


This kind of switch will turn on the power when it's pressed down a little, but must be pressed down further for it to actually lock itself on. First, make sure that you're pressing it far enough. One way to tell is operate the switch with the vacuum unplugged. You'll here it click when it locks. Make sure there isn't a foreign object or gunk stuck under the foot pedal that's keeping it from moving the whole way. Finally, you'll have to open the vacuum up, with it unplugged, and check the power switch inside. Try operating the power switch with just your hand. If you think it needs a new switch, you'll easily be able to find one, and really should be able to find one for only a few bucks if you're willing to do the shopping. Just hook the new one up like the old one was.

Dec 29, 2009 | Vacuums

3 Answers

Dyson DC 24 pick up head wont spin


- Look for the reset button on the side of the brushbar housing - there should be a red sticker and a red button. Push it once. It's
not gonna stay depressed, it's gonna pop right out - that's normal.
- Step on the red pedal on the back
- Turn the machine on with the red power button
- Press the gray button next to the red power button - this is the ON/OFF switch for the brushbar - if it doesn't spin, press and hold the gray button down for 10 seconds
- If it still isn't spinning, remove the brushbar and make sure nothing is blocking it and withholding it from spinning
- For further troubleshooting assistance call the Dyson helpline, they know what they're doing

Jun 20, 2009 | Dyson Ball DC24 Bagless Upright Vacuum

1 Answer

The hoover keeps switching on and off automatically.


Sounds to me like there is either a loose wiring in the pedal or mains power cord. Check that the plug is secure. Check both filters though - one behind the bag (usually square and slides out) as well as the main exhaust filter at the back between the power on and cord rewind button. I used to own many Telios models but they are known to have cheap shearing cords which can only be replaced by a Hoover repairer. Sometimes the On pedal can be affected as well particularly if it has been stamped on heavily.
Dont forget to rate, ty.

Mar 28, 2009 | Hoover S3330 / S3332 Straight Suction...

1 Answer

Roomba going backwards


I had the same kind of problem with my model 400 today...after starting it and having it go in a circle for 30 seconds or so it would finally run into something and then back up a few inches, turn, then go forward a few inches, then back up a few inches, turn, then go forward a few inches, etc., etc.. I tried cleaning off the four pairs of sensors under the bumper and blowing out various things underneath (by mouth since I didn't have any canned compressed air). It didn't really help. It then occurred to me that I had a leaf blower! I put the Roomba upside down on the grass, put the leaf blower on high, and blew at it from all directions and up close. More dust came out than I thought would. It has been running normally now for the last 45 minutes.

Aug 11, 2008 | iRobot Roomba 4210 Bagless Robotic Vacuum

1 Answer

Electrolux Epic 6500SR Full Bag sensor working, Does not Reset properly


The problem was a sticking switch that was not being reset. The vacuum on/off switch mechanism is comprised of two switches. One is the main switch that turns the vacuum on and off. The second is a shut off switch that gets tripped when the full bag sensor is engaged. This second switch is supposed to get reset when you push the on/off switch on the outside of the machine. The full bag shutoff switch was stiff and it, therefore, was taking a couple of presses of the on/off switch to move the shutoff switch back into the running position.

Jun 19, 2008 | Electrolux Epic 6500 Vacuum

1 Answer

No power to the motor


http://geeksquad.fixya.com/ThreadView.aspx?prdid=49977&thid=601650
No power to the motor
Posted by jdw121 on May 16, 2008
When I turn the machine on (both red and black switches) the red heat light goes on but the motor does not. If I leave the unit unplugged for a half hour or more, the unit will turn on. If I turn it off and then try a few seconds or minutes, the motor will not turn on.

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. It sounds to me that you may have a thermal switch problem – when the machine gets too hot it will shut off to protect the machine until it cools off and then it will re-start or if it gets hot or plugged. The one light could be for the heater and the other could be for the motor, but it is a good idea to check with the customer service dept @ Bissell to see if they have a better solution and also check in the trouble shooting part of the owner’s manual. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://www.bissell.com/ Customer Service 1-800-237-7691
Hours of Operation Monday thru Friday 8:00 am to 10:00 pm EST
Saturday 9:00 am to 8:00 pm EST
Mail To: Headquarters, Bissell Homecare Inc
P.O. Box 3606 Grand Rapids. MI 49501
http://www.a-1vacuum.com/ 1-800-657-1874 Customer Service
Thanks, Don the Vac Man
Go Ahead. Use Us.

May 16, 2008 | Bissell 1698 PowerSteamer ProHeat Upright...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polti Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

cwradio73

Level 3 Expert

1162 Answers

Kolbrun...

Level 3 Expert

1205 Answers

Are you a Polti Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...