Question about DB BASS INFERNO BassInferno BI4200 Car Amplifier

Open Question

Ken wood kac-846 not working

No power light

Posted by Anonymous on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Stereo shut down


Did you check fuse block in the car as well as the stereo fuses?

When the face plate is down does that model have any indicator lights in the rest of the deck to see if it is getting power? My old ken wood used to have a red light that blinked behind the faceplate.

Sep 06, 2014 | Kenwood KDC-X993 EXCELON Flip-Face CD/MP3...

1 Answer

My kenwood amp doesn't light up, fuse is good


your amplifier has a power supply problem,contact Eric @ Capital Audio & Electronics Repair 850-339-1130 email poppa1puff@aol.com

Feb 01, 2010 | Kenwood KAC-529S Car Audio Amplifier

1 Answer

Kac-8101 no power


no its not dead u prob blew a couple of heat sensors or a capacitor. most defenetly a capacitor. ceck ur capacitor and see if its blowned

Jun 28, 2009 | Kenwood KAC-8101D Car Audio Amplifier

1 Answer

Canon iR2200: ends PD-ME calibration with E-846.


A E-846 is a problem with the scanning lamp calibration. To resolve the problem you can do one of two things. First you will have to replace the scanning lamp & the scaner inverter PCB as a pair with the up-dated version PCB. Or if you have a parts machine, you can use a working scanning lamp with the PCB and replace them as a set or pair. You can not use a lamp from one copier and a pcb from another.. They have to be a matched set... Good Luck

May 12, 2009 | Canon imageRUNNER 2200

1 Answer

Kac-8152d powers on, but no power output to subs


Well, the sad thing is, it can be a number of things. You will have to do a process of elimination. Try replacing the amp first, borrow one off a friend. Second try replacing the subs. If those don't work, read the manual to your deck. Find the audio settings, and check to see if the sub section is "on".

Jan 29, 2009 | Kenwood KAC-8152D Car Audio Amplifier

1 Answer

Kenwood KAC-9152D Car Audio amp


There could be several problems. The following page should help you determine if you have a problem with the amp or something connected to the amp.

Amplifier in Protection Mode - Troubleshooting

Let me know if you have any other questions.

Sep 17, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Cooling fan light on My KAC-X401M


disconnect all power including ground for 20min

Jun 14, 2007 | Kenwood KAC-X401M Car Audio Amplifier

3 Answers

Amp stopped working...


Has the amp been overheating lately? It's quite possible that the amp could have just blown. Smell around the outside of the amp for an electrical burnt smell. If available, see if a friend also has an amp hookup and try removing your amp and copnnecting to the friend's cables. That will tell you if it's a wiring problem or an amp problem.

Sep 13, 2006 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
DB BASS INFERNO BassInferno BI4200 Car Amplifier Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top DB BASS INFERNO Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

74896 Answers

The Knight
The Knight

Level 3 Expert

73611 Answers

Are you a DB BASS INFERNO Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...