Question about Pool & Spa

1 Answer

Cal spa not running

Blown fuse in balboa spa pak dont know why

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Which fuse is it? Fuses protect the board from getting fried when something goes out on your spa. Which fuse is it? Usually when I hear a fuse has been blown, I start looking at the pump motors, or ozonator etc. You might go through some fuses but unplug all the spa accessories from the pack and re insert one at a time until the one you plug in blows the fuse. That will be one that has the problem. Let me know what you find.

Posted on Apr 04, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a Balboa Hydra pool spa model #du-hp-the power comes on power to the fuse and all it does is click when you press the Jets or light like a tick fuse is blown on top 1


Balboa Hydra pak?

The problem you stated is not clear.

Check for proper voltage to the main terminal block. You should get 240, reading across both the line terminals, not one to L1 and the other to ground. Across both hots. If you have only a 120 volt system then make sure you have 120 at the terminal block.

Your comment "I have power at..." is very vague. How do you know you have "Proper" power?

Replace any bad fuses with like.

Good luck

Nov 06, 2014 | Pool & Spa

1 Answer

What runs on the .3amp fuse?


look on inside cover of control unit it has a schematic

Jul 04, 2014 | Balboa Instruments Pool & Spa

1 Answer

2001 cal spa blowing 20 amp fuse in Balboa spa pak


Probably a bad pump motor. Drain and refills are notorious for stuff like that.

Mar 28, 2014 | Dryers

1 Answer

My Spa is getting power but I can't get anything to run


Unplug everything from the pak and then plug them in one at a time to see what is tripping.

Jan 17, 2014 | Balboa Instruments Pool & Spa

1 Answer

No temperature display cant set temperature


Located behind the access panel there is a grey box that is the spa pack. Open that up with the 2 screws on the top of the pack. There is a small glass fuse on the circuit board. One of those fuses is most likely blown. If that is not the culprit you need a new topside control. More than likely it's the fuse.

Mar 04, 2013 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

I have a density riverspas hot tub and it is stuck in sleep mode and there for won't heat up how do I take my density riverspas hot tub out of sleep mode


Difficult to answer without knowing the "Brand" of your Spa Support Pak System. Lets presume you have the most common basic pak available - Balboa.
Press "Temp" button and then immediately press "Light". You will then sequence between 3 modes:
  • Economy - may display as Ec
  • Standard - may display as Std or St
  • Sleep - may display as Sl
Should save last setting

Dec 03, 2012 | Pool & Spa

1 Answer

Balboa hot tub m7 wont power on at all


Either the spa is incorrectly wired or one of the fuses is blown in the spa pack. Typically this is due to your electrician wiring the spa incorrectly and blowing the fuse on accident.

Aug 06, 2012 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

QCA Spa Contol Panel Issues


Flow issues can be frustrating, check each of the following
1. Low GPM.
2. Low Water Level.
3. Blocked Suction Fitting.
4. Blocked Skimmer.
5. Dirty Filter. (Try run system w/o Filter)
6. Too Many Closed Jets.
7. Closed Slice Valve.
8. Heat Related Pump Not Running.
9. Heat Related Pump Not Primed.
10. Malfunctioning Impeller.
11. Incorrect Heat Related Pump.
12. Circ System Misconfigured.
13. Sensor Malfunction.
If none of those help try this. There is a link to s Balboa site for service tech diagnostic help. There are step by step instructions for diagnostics.

Jan 23, 2012 | Pool & Spa

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

3543 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...