Question about Jl Audio JX500/1D

Open Question

Jl jx500 isnt turning on

I have everything wired up but the power light still isn't coming on, I blew my inline fuse because I had the wiring on the capacitor wrong, could this have blown something in the amp to cause it not to have any power?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 14 Answers

SOURCE: Car Sub JL 12w3 low sound

So I am assuming that you have just setup/wired this up recently? Have you had this working before?
You can have a look at the gain control on the amp & see if this have been set really low. This will help if the signal coming from your stereo is weak. The other thing I would suggest is to make sure that the amp can actually push this sub. I know what the specs say:

  • 1 channel audio amplifier
  • 1 x 350W RMS @ 1.0% THD
  • ThermalThrote full-on power assurance
  • 2 ohms stable (non-bridged mode only)
  • RCA type inputs
  • 0.3-6.0 VRMS input capability
  • Continuously variable High-Pass & Low Pass 50-250 Hz
  • Continuously variable Bass Boost settings (0 tp +12dB)
  • Frequency responce: 10-30,000 Hz
  • S/N >104 dBA at full power @ 0.1% THD
  • >80 dBA at 1W/1M
  • Remote gain control, mounting hardware & screws included
but I don't believe most of these. Many manufacturers embellish what their products can actually do! With the bigger more established brands such as JL Audio you will have no problems, their products have been tried & tested so much on the competition circuit.

Posted on Dec 28, 2007

SOURCE: blue low voltage light

might wanna do a 0-guage to 4-gauge conversion.... hit me up on AOL Instant Messanger and i'll give you more details as to why on there (normando86)

Posted on Feb 14, 2008

  • 631 Answers

SOURCE: Jl Audio 500/1 Car Audio

There are no fuses inside the amp.

Are any of the lights lighting up on the amp?

If so, which ones?

Posted on Jun 09, 2008

  • 160 Answers

SOURCE: if my jl amp e1200 is on green, but no power is going to the sub

your audio wires from the head unit have been pinched or discontected or the head unit is not putting out a signal

Posted on Dec 01, 2008

  • 12 Answers

SOURCE: jl 1000/1 popping fuse

hi there r u running any other amps in the vehicle as well as the 1000/1?

Posted on Jan 30, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I blew the fuse inside the fuse block (60A). I replaced it so now I know I have power getting to the amp. I checked it with a meter and I show 12 volts passing throught the fuse block. I can not get the...


Sometimes there is a fuse inside but they are usually thermal and reset when they cool. You said u blew a 60 amp fuse. Is that what the manuf reccomends? Check your remote turn on wire (blue) make sure u have power on the remote wire when you turn the radio on. only thing really left are the grounds

Jun 11, 2011 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

1989 ciera orange wire going to the oil pressure switch was accidently grounded. Will turn over backfire but not start . Fuel pump won't power up. No power to fuel pump relay. Took relay apart manually...


You didn't post an engine size but you are correct in thinking there is a fusible link that blew when you grounded the orange wire but there is also an inline fuse that protects the oil pressure switch and the fuel pump relay. It is usually located on the firewall.

You can check the fusible links near the starter for continuity. If one of them is burnt up start there by replacing it. If none of them are bad you will need to find the inline fuse. At least the 3.3 liter engine is set up this way.

Nov 28, 2010 | 1989 Oldsmobile Cutlass Ciera

1 Answer

Output of amplifier gives wired noises no Bass


check how your wires are run from the radio to the amp try to split them up and see if the noise still comes. buy some new rcas this will help with noise. make sure you have tru connections

Mar 10, 2010 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs


maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

NEW AMP PROBELMS JL


check the fuses in the amp if it has any then check your ground make your have a good stable ground and if thats not i dont know if you have a fuse that is tied in with the remote wire that goes to your amp in the back of the radio if so check it as well

Oct 29, 2009 | Jl Audio HD750/1 Car Amp

1 Answer

The Red & Black wires connected to my AMP touched


You blew the inline fuse on the AMP power wire. If it was not fused "inline" you may have blown a fuse internal to the amp. Look on the amp(or consult the manual) for the location of fuses "internal" to the amp.

May 01, 2009 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Jl 500/1 amplifier will not turn on


you may have burned the channel you were using..try taking the cover off the amp and checkin for burned spots or any wires that may be loose or touching within the amp.

Feb 24, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My 800 watt kenwood


Sounds like you shorted out the main power wire somewhere and killed the amp. Is the amp on the fuse intact or blown? Do you have 12 volts at the amp? check you connections and see if it helps.

Jun 03, 2008 | Kenwood KAC-7201 Car Audio Amplifier

1 Answer

Amp problem


you either have a bad ground or your power line is too small, the farther you go from the battery the larger wire you need.

Dec 18, 2007 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

Hok up amp and all fuses blow on distribution block


somehow, DC car voltage has gotten to the speaker outputs of your amp! your fuses are saving your speakers from meltdown. your amp has melted down. toss it after checking with ohmeter as follows: disconnect amp completely. red wire from ohmmeter to +12Vin. black wire to SPK+. if ohms are anything below 1000 ohms, then toss it. An electrical short is equivalent to flooding your entire house with a leaky faucet. No telling what that rapid current will encounter along the amplifier section. you could get lucky and find all power MOSFETS have shorted and replace them. good luck.

May 31, 2007 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio JX500/1D Logo

Related Topics:

86 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Clothing Experts

treeeee
treeeee

Level 3 Expert

519 Answers

shuyumeng
shuyumeng

Level 3 Expert

951 Answers

Erin Wood
Erin Wood

Level 3 Expert

458 Answers

Are you a Jl Audio Clothing Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...