Question about Sony Exm-502 Mosfet 2 Channel Stereo Bridgeable Power Car Amplifier Amp

1 Answer

When installed, amp gets power but produces no sound

I arced a screwdriver against the amp while it was hot. power is getting to the amp but produces no sound. I hooked up another amp to make sure RCAs, power, and ground were ok and they were. the trial amp works fine. what do I need to do to fix this?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Sony Master
  • 637 Answers

If you have a small mom and pop shop in your area. I would have them check it out. You might have gotten lucky.

Posted on Jun 18, 2014

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 113 Answers

SOURCE: Sony XM-2002GTR 1200 w amp power problem

check for broken solder on terminals

Posted on Aug 09, 2007

  • 631 Answers

SOURCE: Sony XM-2200GTX...Power, Green Light, All OK, No Sound!

Sony generally drives their power light from a source that does not rely on the amplifier's switching power supply. This means that it's not a good indicator as to the health of the amplifier.

 

As long as you have B+ and remote voltage, it will light up. Since you've tested the speaker and the signal source, I think the amplifier is likely defective.

Posted on Oct 17, 2007

  • 1 Answer

SOURCE: Sony Xplod 500w green power light no sound

ok, i have a sony xplod 1000w amp, with a single kicker cvt12, and at low,very low volume you hear a little distortion,when the bass hits,but sounds great when volume is turned up,this is a new sub, and the old sub did not do this,both are 4ohm,

please, any advice would be great, i am new to car audio ,thanks fgsportcraft@yahoo.com

Posted on Mar 08, 2008

  • 631 Answers

SOURCE: Sony amp 1000w

Check the wiring of the speakers (both inside the box and between the box and the amp). It sounds like one speaker is wired incorrectly at one connection point.

Posted on Sep 11, 2008

  • 631 Answers

SOURCE: my amp stays in protection mode

Does it go into protect in the vehicle if you disconnect the speaker wires from the speaker terminals of the amp?


Posted on Nov 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bmw 525i wont start no starter action battery ok


rarely fail,but do.if the battery load tested out to be good . you get 12 volts to the starter signal wire when you turn the key to start. then the starter is bad or the engine or something driven by the belt is locked up.

Jun 09, 2012 | 2006 BMW 5 Series

1 Answer

What color wire from fuse panel to radio on 1989 Camaro


Base line radio,... Orange -hot all the time, Acc fuse ..-20amp. Yellow ,Hot -key on.. Radio fuse -10amp.... Delco, Bose system...Orange,-20amp ARC fuse..Hot all the time, Yellow, radio fuse, -10 amp, hot with key on. Your second orange wire powers your Amp Relay, in the Acc fuse,- 20 amp ..it has a constant hot, or power..so you might be getting power @ the Radio, but Nothing out the speakers.. Hope that helps..

Oct 02, 2011 | 1989 Chevrolet Camaro

1 Answer

The solonid finally went out but I can't get my car fixed until Monday. When I try to crank it, all power comes on but the car clicks. I know there's a way to bypass the starter and start it with a...


Assuming that you have made sure that both ends of the battery cables are clean and secure, you need to bridge the large terminal on the solenoid to the one on the right of that terminal, facing the starter.
It is extremely important that the vehicle be in park with the brake set and ignition switch be in the run position.(having someone behind the wheel with their foot on the brake is a plus. It is equally important that you do not touch the screwdriver or whatever you use to bridge the terminals to anything except the terminals. You also may get a spark from there...keep your face where it won't get in your eyes as often small particles of hot metal can damage and burn them.(sparking is just like an arc welder and produces cast-off)

Dec 31, 2010 | Chevrolet Impala Cars & Trucks

1 Answer

There is the liquid seeping out of the breakers, it is not water the box is dry and it feels like an oil of some kind. breakers are working and are not hot. i have not seen this before. what is it and what...


It is oil. It's used to extinguish the arc.

When a circuit breaker trips, there is an Arc of electricity made inside the breaker, due to the contacts.
The contacts are instantly brought away from each other.

There are three methods employed to extinguish that arc.

[Extinguish the arc. Non-technical explanation. With out some medium to extinguish the arc produced inside, it would go Z-z-z-z-z-z-z-z-z-z-z-z-zap, instead of z-zap]

Oil, Air, and Sulfur Hexafluoride.

So yes, as long as the circuit breaker doesn't have to trip, and produce the arc inside, it is a working circuit breaker.

Is it a safe unit?

NO

The method employed to extinguish the arc if the breaker trips is leaking out.

Replace all breakers that are doing this.

Average cost for a GE single-pole 15, or 20 Amp is around $11 here. A few dollars more for 30 and 40 Amp, but usually double-pole breakers are used for 30, and 40 Amp.

Nov 18, 2010 | GE Circuit Breaker THQB BoltOn 1 Pole 15...

1 Answer

I bought a 20 amp arc welding kit from canadian tire and dont have an instruction manual with it. i have given it the proper electrical current and amperage and still cant get it too work. looking for the...


20 amps seems like a fairly feeble arc welder--most light models run up toward 80 to 100 amps for a stick welder with wire feed models somewhat lower. Even accidently touching the two leads together should have produced some arcing. You may have a defective unit. Hope this helps!

Aug 16, 2010 | Garden

1 Answer

I have a audio source amp 100 on a volume control . it get real hot after being on for just a few minutes.


It is normal for power amps to get warm. Overheating can be caused by deffective speakers, or internal leakage on the transistors. Does is produce normal sound?

Nov 23, 2009 | AudioSource AMP-100 2-Channel Amplifier

1 Answer

NO arc or power on my Welder/Generator


check your back panel fuss and brakers

Oct 11, 2009 | Welding Tools

3 Answers

57xbr10w pops & sparks under one of the lamps & shuts off


The Lamp (CRT) got shorted / leaky that gets spark / arcing and requires replacement. TV is an old model and I'm not sure that CRT is available any more.

May 31, 2009 | Sony KP-57XBR10 57" Rear Projection...

1 Answer

Pulsating Arc


Sounds like one or two of the power diodes are defective (open), producing a half wave pulse instead of full wave, giving it a dotting effect.

Apr 19, 2009 | RTO Esab Handy Plasma 550 W/25' Pt 31XL...

2 Answers

Hello: I have an old electrical box with the old style Zinsco beakers. For some reason, the left side of the main 200 amp breaker continues to go out. only one side. the breaker arks right where I screw...


The screw is loose. It is always HOT (has electricity going to it) so be careful. If you feel confident, cover a screwdriver with a few layers of electrical tape and tighten it. Depending on how long it has been arcing, the breaker will need to be replaced. Since the incoming wire will have power to it, have a licensed electrician do the job. He will possibly remove the meter head to cut the power while he does the work.

Jan 03, 2009 | General Electric 100Amp 3-pole circuit...

Not finding what you are looking for?
Sony Exm-502 Mosfet 2 Channel Stereo Bridgeable Power Car Amplifier Amp Logo

88 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4874 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...