Question about Kenwood Car Audio & Video

1 Answer

Kac m646 amp cuts out when car accelerates above 3000 rpm. earth and power supply are not the issue. any ideas?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Capacitors inside amp could be going bad, cheap fix.

Posted on Mar 31, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

sumthin
  • 71 Answers

SOURCE: Kenwood KAC-9104D

Circuit City ? I'll keep that opinion to myself.
If all is properly hooked up, Check the ground wire for the amp.
Give it a tug where it is connected to the car chassis, NOT the amp,
if it moves or comes loose thats easy to fix, scrape the paint off the grounding point use a high quality ring terminal and a oversize screw with a star locknut. Also check the wiring in the box.
Subs and boxes are quite heavy. And if it's banging around, I hope you have it in a trunk, they are very lethal projectiles in a hatchback should you have a accident.
My second thought is that you may have dislocated a component , solder joint, or cracked the PC board,
When in doubt see a installer. Good luck Sumthin
Sumthin

Posted on Jun 11, 2008

  • 631 Answers

SOURCE: Kenwood KAC-9152D Car Audio amp

There could be several problems. The following page should help you determine if you have a problem with the amp or something connected to the amp.

Amplifier in Protection Mode - Troubleshooting

Let me know if you have any other questions.

Posted on Sep 18, 2008

  • 3 Answers

SOURCE: Why does my KAC-8404 cut off at high volume bass?

My uncl had the same problem and he went back to the audio shop twice...Then called me...I discovered that the powr cords they used were not thick enough,giving the amp a low current to work on...but if you have the original cords you got when you bought the amp...it might also be a weak power supply....try playing the music while driving on a high speed or while reving the car to give more voltage from the alternator...If that doesnt work...come and shoot me please...im out,PEACE

Posted on Dec 29, 2008

  • 27 Answers

SOURCE: BLOWN FUSES IN AMP

maybe try the ground or make sure you dont touch metal to metal

Posted on Mar 30, 2009

  • 2 Answers

SOURCE: leads for old kenwood car stereo amps

Hey wdalley69, I've got the KAC-8070. My setup has the crossover module for it.

Posted on Feb 27, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 jaguar xj8 when I drive it won't go over 3000rpm


Jaguar wont rev 3000 rpm Questions & Answers - Fixya

www.fixya.com > Forum > Tags > wont rev 3000 rpm
1998 Jaguar XJ8 won't rev over 3000 rpm ... Wont go beyong 3000 Revs s type 2001, wont go beyond 3000 Revs and it' in limp ... Question about 2002 X-Type ... My jaguar xjr8 year 2000 battery went dead started car went for short drive back ...

Jaguar engine cuts 3000 rpm Questions & Answers - Fixya

www.fixya.com > Forum > Tags > engine cuts 3000 rpm
1998 Jaguar XJ8 won't rev over 3000 rpm ... engine cuts out and shudders at 3000 rpm won't accelerateobd code p0332 2002 jaguar x type 3.0 l P0332 - Knock ... Car is boging out in park and will not go over ... driving, don't worry about it.

Rev Won't go up

www.jaguarforum.com/showthread.php?t=14662

Dec 15, 2015 | Jaguar Cars & Trucks

2 Answers

Beeping sound from amp when car headlights turned on


it could be a indication of low amps.

Does it happen when car is running and lights are on?

If car is off do lights dim to the music at night?

You could be using more power than your alternator can supply.

Most alternators are capable of producing 55-65 amps. This is adequate for sound systems producing up to 350 watts RMS. Some more modern vehicles have alternators rated up to about 120 amps. This will be sufficient for systems of up to about 600 watts. Some pre-1985 cars, on the other hand, have alternators only rated for 35 amps. This will only support about 125 watts in amplifier power.


One easy, effective solution maybe installing a capacitor. Heavy-duty capacitors connect to the power cable (just before it reaches your amplifier) and act as a buffer zone between your amp and your car's electrical system. They store up a reservoir of power which can supply the amplifier's peak demands (like a bass drum beat) without having to draw current from the battery.

First, Check your earth is excellent and not all clustered on one point. Ensure power leads are thick and secure. Separate speaker and power cables.

Check auto turn on wire (thin blue on amp) is not connected to lights power source, use elect aerial output on head instead

Run 4 gauge earth wire to car body near amp, power cable must be heavy gauge too, expessally with a sub woofer running.
446801c.jpg

Jan 31, 2008 | Kenwood KAC-8403 Car Audio Amplifier

1 Answer

When driving my 1997 Audi A 4 1.8t there is a loss of power around 3000 rpm, what could be causing the issue?


run the fault codes and look for a problem area in the vane actuator of the turbo
it could be a sensor problem or a MAP sensor problem
this is indicated by the pressures being generated or not generated by a turbo generating pressure from the throttle opening on acceleration or held at constant speed

Oct 19, 2015 | Audi Cars & Trucks

1 Answer

Low fuel pressure on mazda rx8 2008 model, car does not accelerate properly on gets full power after 6500 rpm


You will need to have the fuel pressure monitored under a load with a special tool and also drive it for a while and see if the check engine light comes on, if it does have the system scanned and diagnose the codes received.

Oct 18, 2012 | Cars & Trucks

1 Answer

92 NISSAN WITH BOGGING AT 2800 3500 RPM AND AT LEVEL SPEED 4CYL AND 5 SPEED


For this types of problem,there are few help inks to troubleshoot the problem.Click the link below to go through the troubleshooting procedure to resolve the issues :----Idles rough and quits when gas pedal is pressed less? http://technoanswers.blogspot.in/2012/01/1999-ford-f-150-idles-rough-and-quits.html-----------van idles rough? http://howtobyme.blogspot.in/2012/01/2004-ford-freestar-van-idles-rough.html
--------------runs lean and idles rough? http://technoanswers.blogspot.in/2012/02/ford-runs-lean-and-idles-rough.html
-----------Car still runs Rough after tune up? http://howtobyme.blogspot.com/2011/12/car-still-runs-rough-after-tune-up.html
------------Idle flair is noticed on car? Rough idle? car will not idle? Erratic idle speed? http://technoanswers.blogspot.in/2012/02/idle-flair-is-noticed-on-car-rough-idle.html
----------High rpm in neutral? Inconsistant high RPM in neutral? http://technoanswers.blogspot.in/2012/02/high-rpm-in-neutral-inconsistant-high.html
------------Engine Backfires? http://technoanswers.blogspot.in/2012/02/jeep-backfires.html----------- Nissan stalls and bucks on Acceleration?

http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-stalls-and-bucks-on.html

-----------
Nissan Pathfinder Backfires? http://technoanswers.blogspot.in/2012/02/nissan-pathfinder-backfires.html
---------How to adjust rpm? http://schematicsdiagram.blogspot.com/2011/12/how-to-adjust-rpm-on-2009-dodge-charger.html
------------Engine cuts out at 3000 RPM? http://schematicsdiagram.blogspot.com/2011/12/engine-cuts-out-at-3000-rpm.html
----------This will help.Thanks.

Feb 17, 2012 | 1992 Nissan Pickup

1 Answer

I have a kenwood kac-9152d running a 10 inch rockford fosgate power t1 and the amp keeps going into protect but i have a smaller kenwood kac-8102d running on another t1 and i have no issues with it why...


either the wiring your running is short circuting,or the amp is shot, or the subwoofer is shot, try hooking the same speaker up to the other amp. along with the other speaker to the other amp, see if the same thing happens.

Feb 04, 2010 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

I have a kenwood kac-728s and two coustic 10in. subwoofers hooked to it and every time i start my car and the radio powers on the two 20 watt fuses on the amp blows.any ideas?


That is pretty much saying that the amp's power supply is shorted or at least has a low resistance path to ground which is causing the fuses on the amp to blow. The amp has protection circuitry to prevent damage to the output stage so that is not what is causing this. Is the amp new?

Dec 30, 2009 | Kenwood KAC-728S Car Audio Amplifier

2 Answers

1996 honda VT1100c2 backfiring & missing when accelerating


Replace Fuel Filter.
Test fuel pump output.
Remove and service carburetors.

Jun 07, 2009 | 2005 Honda VT 1100 C2 Shadow Sabre

2 Answers

Why does my KAC-8404 cut off at high volume bass?


amp 101

1/0 wire to the amp or the amps will loose power

check the connections mainly the negative

wiggle the wires see if you get a cut out or not

a cap will help you give constant power to the amp and not allow them to drain on long bass notes

hope this helps

Dec 26, 2008 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

75051 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7727 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...