Question about Crest Audio Audio Players & Recorders

1 Answer

Crest audio ca12

Clip light on with on signal into amp protect led off

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 42 Answers

Dust in the unit - clean with Canned air like a computer.

or Delamination on the printed circuit board.
Don't forget to clean all contacts on the backside of the unit!


If cleaning doesn't work - head to the local Crest "AUTHORIZED" Service Center.

Posted on Jun 14, 2014

Testimonial: "bad i.c on pre amp board (2901)-14pins"

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
marsrover
  • 682 Answers

SOURCE: every time I turn the amp on it shuts its self off.

disconnect all speakers and test if the problem corrected you will have a problem in your speakers(either wire or speaker itself)-try to connect the speakers one by one until you find the bad one and change it--if all above does not work send your amp to service center near you

Posted on Mar 30, 2009

Grubhead
  • 5190 Answers

SOURCE: both fuses burnt and both clip and signal led on?

Suspect an overload in either the power supply section or the devices on the main heat sink. In the power supply you are either looking at a transformer problem or semi-conductors associated with it. However since the clip and signal lights are on, I would go to the amp devices on the heat sink. If they are transistors test them with a Ohm Meter on the 1K setting in circuit even! You will soon notice which ones are gone! The meter will show like you had touch the test probes together!

Posted on May 19, 2010

  • 867 Answers

SOURCE: I have a Crest Audio V900, a set of Bose 901, a Gemini EQ-3000. Do I need a PREAMP? Or can I hook up the Crest AMP to the Equalizer?

You could use the EQ but it won;t sound as good as it will with a pre amp and also could make it a bit trickier when adjusting the volume and getting it to sound right.

Posted on Mar 10, 2012

Testimonial: "Thank you very much. I wouldn't like to mess up my Bose. So I guess It's better to buy a PREAMP and then connect accordingly. Once again, thank you for your time and concern , oh, and your most valuable information."

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

He never active and ACL Led stays on and the cooling fan go for hi speed


Hello folks,
The same thing happening with my crest cc4000. The plastic connector, connecting the wires from the transformer to the circuit board was burnt damaged and was removed. but acl light still stays on and amp not active.

Dec 19, 2012 | Crest Audio CC4000 Amplifier

1 Answer

M-audio Fast Track Pro Signal & Clip LED Always ON I have a M-audio Fast Track Pro, I'm facing this weird problem. As soon as I switch the M-audio Power on. I can see the Clip & Signal LED...


I have the same problem. Here is what it looks like. Any ideas? This happens without any inputs. I'm using a macbook air on yosemite but I have tried it with ealier macs and still.
m-audio-fast-track-pro-signal-amp-clip-ni4luhx4uq5ph035q1qzraj2-5-0.jpg

Apr 26, 2012 | Computers & Internet

2 Answers

Am a technician, i havent dealt with crest sound before. my client's amp has lit the clip light, control light but not the signal light. initially it was ok but all of a sudden, they went to operate it and...


The signal light is triggered by the presence of an audio signal on the input side and should be visible. With the clip light on without any input signal, suggests a problem in the front end. This is not an amp to be worked on without a schematic. Try getting the prints for this from Crest (Peavey owns them now).

Dan

Feb 17, 2011 | Crest Audio CA 6 Amplifier

1 Answer

Why my crest audio ca6 has the lights clip signal


disconnect you load (speakers) power amp up. If this fault persists there might be a problemm with the amp

Apr 21, 2010 | Crest Audio CA9 Car Audio Amplifier

1 Answer

How to turn off the clip light is on red it does not turn off?


You can't, the clip light is just that...the signal is being clipped/distorted and the clip light comes on to protect the amp/speakers from blowing. You need to check your signal and then cables and wiring to see where the problem lies, chances are your volume is too high and your over working your amp....(turning the volume too high when the amp doesn't put out enough power for your speakers and this distorts the signal causing it to clip)...Try turnig the amp down, should not be any higher then 1/2-3/4 of the way never max. And if that doesn't work check your signal from the radio as well. If it works fine with the volume down and doesn't clip then your amp is too small for your needs and your need to invest in a larger amp for more power...Look for RMS watt ratings at 12-14 volts not max watts at like 16-18volts (those are fictious #'s and those amps should be avoided)

Nov 02, 2009 | Crest Audio CA9 Car Audio Amplifier

1 Answer

Clip and protect LEDs but no speaker output


Protect is a mode that it goes into that prevents future damage, i would recommend replacing the fuses.

Sep 26, 2009 | Crest Audio CA9 Car Audio Amplifier

1 Answer

My CA9 has protect recurrent problems.


if you are bridged in parallel instead of in series the amp wont support the load so it turns the power protect on till the amp cant handle nomore then the amp will go if you have two subs bridged run them left speaker possative to to the amp possative for bridged mode then laft speaker negative to the right speaker possative then right speaker negative to your amp negative for bridged mode if you have them left and right speaker possative to amp possative and left and right speaker neggative to your negative to your amp thats parallel the ampwont support the 2 ohm load

Feb 08, 2009 | Crest Audio CA9 Car Audio Amplifier

1 Answer

Red status Light


If the protection LED is lit, the amp is in protect mode and probably has shorted output transistors. To eliminate other possible causes, read through the following page:

Amp in Protect Mode - Trubleshooting

Let me know if you have any other questions.

Nov 07, 2008 | Boss AUDIO RIP-596 2-Channel Ripper Series...

3 Answers

My amp is on but the protection light stay's on!!


Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If the protect light remains on, the amp likely has blown output transistors.

Feb 28, 2008 | AudioBahn A2801Q Car Audio Amplifier

3 Answers

Problems with Infinity Amp 611A


are you running a large ground wire directly to the battery negative terminal?

Jun 03, 2007 | Infinity Reference 611a Car Audio...

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

166 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crest Audio Audio Players & Recorders Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Owen Barnes

Level 3 Expert

867 Answers

spacil
spacil

Level 1 Expert

21 Answers

Are you a Crest Audio Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...