Question about Polaris 2010 Rush 600

1 Answer

Polaris problems recently rebuilt my top end now when it is running it cuts down to one cylinder when it reaches temp. what should I check

Posted by Anonymous on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 220 Answers

Check for a clogged main jet in ur carb.

Posted on Oct 02, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

93 xlt 580. Only runs on 2 cylinders sometimes at cold. Change plugs and works sometimes.. Not always same cylinder.. Any way to check stator,coil?


Ask The SnowMan Your Sledding Questions Answered: Off ...

www.off-road.com/.../ask-the-snowman-your-sledding-questions-answer...
Mar 1, 2009 - Its a 96 polaris indy xlt 600 triple not the special edition though. ... THEM SITTING ON THE HEADS BUT ONLY 2 CYLINDERS ARE RUNNING WHEN ... Q: I have a arctic cat ext580 the compression in both cylinders is about 70psi .... i have a93 polaris 600 xlt and I just got home and the antifreeze is ...

93 XLT Carb settings? - Snowmobile Forum: Your #1 Snowmobile Forum

www.snowmobileforum.com/polaris.../41045-93-xlt-carb-settings.html
Nov 27, 2009 - I bought a new to me 95 polaris sport last year. it had not run in twoyears. ... It's all in the tuning, clutching, jetting and gears.. i have a 93 xlt 580 and i ... he is loading up with fuel and just cutting the spark out of a cylinder.. i had ... XLT w/ Triple Pipes Question?
May 8, 2013
93 XLT Ran Great, Shut Down, Now Backfires
Feb 13, 2012
Dead cylinder
Dec 11, 2011
1998 ski doo f3 700 wont run right
Feb 22, 2011
More results from www.snowmobileforum.com

Polaris Indy 600 XLT HELP! - Snowmobile Fanatics


Jan 04, 2016 | Cars & Trucks

1 Answer

Why are so many trouble diagnostic codes being thrown


sounds like you speed sensor and your throttle poistion sensor

Sep 02, 2014 | Cars & Trucks

1 Answer

Polaris troubleshoot


If I was a betting man, you should do a compression Test on your Engine. What you are going to find is the PTO Cylinder has a lower compression than the Cylinder on the Right. Doing a Top End Repair on your Sled will only take 4 hours to do correctly. You can do RINGS ONLY but you may want to replace the Piston if the SKIRT has marred the Cylinder Walls to ensure a longer life. It is also recommended that you make sure your Oil Injectors are not clogged and functioning correctly.

Feb 11, 2014 | Polaris 2004 EDGE Touring 340

1 Answer

Rebuilt a Stihl TS400 concrete saw, and now it wont cut, the engine dies down and has no power but revs up? Ive tried everything!


All these people are missing a basic thing: check the compression. If you did all thus work yourself, you may have reused the head gasket or not installed the new one correctly. It will run with no load, but once force in exerted, the pressure finds the leak and exploits it. There is a reason 2-cycle engines run at 130-160 psi normally.

Dec 27, 2012 | Stihl Ts400 Cut Off Saw Carb Carburetor...

1 Answer

Rebuilt top end 30 over and now it starts fine but will not idle down...... what should we do?


Check the throttle freeplay, should be about 1/8 to 1/4 inch freeplay on the throttle. That would be probably the first place to start. Also if it will not idle down it could be an air leak in the carburetor intake. The rubber boot can develop cracks and **** air in after it is mixed in the carburetor causing a lean condition, this can also cause the atv to not idle down. Let me know if you need any other ideas, Daniel.

Sep 11, 2011 | Polaris ATV

2 Answers

Hi,redone the top end of my Rm125 1989,it struggled to reach powerband for a while, but eventualy it reached it!Next morning I started the old lady and there was almost no compression with a funny noise in...


Hi, i presume that before you rebuilt the top end you had no issues? Normaly this happens when either you have exsessive play in either the big end or the small end bearing, this would be recognised by up and down moovment in the conrod for big end and piston for small end, this would account for spark plug contact only. The other thing to check was the piston identical in height to the old one, did it have the same cut outs for fuel transfere, and finaly did you install it in the correct direction with the rings located in the peg positions facing the inlet side of the barrel, was the new head gasket the same thickness as the old one, did you run i the new piston for a while if the piston and cylinder were new a bed in period must be observed

Mar 13, 2011 | 2003 Suzuki RM 125

2 Answers

Polaris 300 it will run get loud and die


2 strokes get loud before they run out of gas. check your fuel lines and carb to see if your getting enough fuel to the engine.

Dec 17, 2009 | Polaris ATV

1 Answer

Sportsman 800


HELLO;Yes if the motor wasn't rebuilt with a piston of lower compression than your running at a higher level and you might look at rejetting the carb and also checking the timeing. GOOD LUCK......GREASY.

Aug 24, 2009 | Polaris ATV

2 Answers

Polaris rmk 500 backfires when it gets hot then won't start


Ok this sounds like a similar problem that I have had with a 500xc engine...This engine has been running fine for the last 5 yrs until a few weeks ago when it became a pig to start and when it did only run on one cylinder eventually running on both and when it gets to a certain temp would cut out and then not start again for 5mins, changed everything we could think of, checked compression, barrels fine, carbs clean new cdi, coil, plugs, leads, fuel pump and pipes, then someone came accross with checking the resistance on the temp sensor on the top of the head which were different values to the the book and on another identical engine, I borrowed a spare sensor and although still a pig to start it was an improvement when running, need to buy a new sensor to rule it out
, can anyone else shine some light on this?

Feb 20, 2009 | Polaris New Genuine Polaris Snowmobile...

Not finding what you are looking for?
Polaris 2010 Rush 600 Logo

Related Topics:

389 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris Winter Sports Experts

Todd Arndt
Todd Arndt

Level 3 Expert

2044 Answers

yadayada
yadayada

Level 3 Expert

75005 Answers

Lawrence Oravetz

Level 3 Expert

9324 Answers

Are you a Polaris Winter Sport Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...