Question about Car Audio & Video

Open Question

Kenwood amp kac 81010 no sound n blue light is blinking

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 5 Answers

SOURCE: Kenwood KAC-8103D Power Amplifier wont turn on

it sounds to me like its burnt.but with some amps the screws that hold it in place have to be screwed into the car chassisfor grounding. be careful not to srewe into hidden wires.

Posted on Apr 15, 2009

Ad
etirbynnor
  • 655 Answers

SOURCE: To bridge a Kenwood KAC-9102D

Hello laurogleal,

The Kenwood KAC-9102D is a mono amp. There is no bridging. Having two sets of terminals is just a more convenient way of connecting two subwoofers. The amp is stable down to 2 ohms impedance, so it is safe to run 2 4 ohm loads in parallel.

Hope this helps.

Posted on Apr 28, 2009

  • 113 Answers

SOURCE: What does it mean when the power light blinks on the amp?

sounds like u r overheating and then cooling try a 12volt fan

Posted on Jul 05, 2009

  • 11 Answers

SOURCE: blinking E-03

somthing is fried on your motherboard

Posted on Jul 30, 2009

  • 2 Answers

SOURCE: leads for old kenwood car stereo amps

Hey wdalley69, I've got the KAC-8070. My setup has the crossover module for it.

Posted on Feb 27, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My amp indicator is blinking blue and my sony xplod sub is not workin thru the amp but works wen i connect it in my other car how do i fix it so my light stops blinking, and my sub works again


yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Jan 03, 2010 | Kenwood KAC-X650D Car Audio Amplifier

1 Answer

When I hook up my kenwood kac-7201 the power light


leave power connections hooked up disconnect rca and speaker wires if they still blow more than likely problem with amp

Dec 31, 2009 | Kenwood KAC-7201 Car Audio Amplifier

1 Answer

Kenwood Excelon KAC-X811D blinking e-03


Hello mogly20,

The amp probably won't know if it's you or the homeless guy, so try smashing a glass bottle on it like he did. If that doesn't work, I'd recommend you locate another homeless guy and buy another amp.

Hope this helps.

Aug 08, 2009 | Kenwood Excelon KAC-X521 Car Audio...

1 Answer

On a kac-x650d does the power light stay on or flash


Hello mpredday,

The Kenwood Excelon KAC-X650D power light is ON during normal operation. It blinks blue to indicate BMS selection, yellow for low voltage, purple for DC voltage on the outputs, red for overheating, and green for a shorted or grounded speaker wire.

Hope this helps.

Jul 29, 2009 | Kenwood Car Audio & Video

1 Answer

What does it mean when the power light blinks on the amp?


genrally kenwood amps are power hungry amps so after playing for a while if it doesnt get the amount of amperage to make it work it will shut down cus you car cant charge the battery long enough for the use of that amp so my idea is try a farad capacitor and see if that helps good luck .......tk

May 29, 2009 | Kenwood KAC-7252 Car Audio Amplifier

1 Answer

No sound from my woofer


Check your speaker connections... try using a multimeter set to "OHMS" and see if the speaker is reading around 4-8 ohms... if it shows no reading there is no continuity in the coil of the speaker

Mar 24, 2009 | Kenwood KAC-929 Car Audio Amplifier

1 Answer

Problem with my kac-959 amp


The amp is likely going into protect mode due to failed output transistors. To eliminate other possible causes, read through the following page:

Troubleshooting - amp going into protect mode

Let me know if you have any other questions.

Sep 24, 2008 | Kenwood KAC-959 Car Audio Amplifier

1 Answer

Kenwood kac-5201 amp


12 VOLT FROM THE BATTERY SOURCE GOES TO 12VOLT BATT CONNECTION.12 VOLT GROUND RETURN MUST BE FIXED TO THE FRAME OF THE VEHICLE.SOME VEHICLES HAVE FACTORY GROUNDS UP HIGH ON THE SIDES OF MOST VEHICLES, U CAN USE THIS GROUND LOCATION. IF CONNECT REMOTE WIRE FROM THE RADIOS REMOTE TURN ON LEAD WHICH IS A BLUE/WHITE WIRE OR A STANDARD BLUE IF ITS JUST ONE BLUE WIRE. CONNECT THIS LEAD TO THE REMOTE TURN ON CONNECTION ON THE AMP , SOME KENWOODS HAVE TWO ,INPUT AND OUTPUT LEADS.U ALSO NEED A TEST LIGHT, OR U CAN USE A SPEAKER TO TEST FOR POWER AT UR CONNECTION.IF U USE A TEST LIGHT , CLAMP THE END U WOULD GROUND TO THE VEHICLE, TO THE AMPS GROUND, THEN TOUCH THE PROBE END OF THE TEST LIGHT TO UR WIRED CONNECTION TO VERIFY U HAVE POWER AND GROUND TO YOUR CONNECTION.IF TEST LIGHT DOESN'T WORK ,CHECK UR FUSE AND REMOTE TURN OR LEADS.

Sep 02, 2008 | Kenwood KAC-5201 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4869 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76673 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...