Question about Vacuums

1 Answer

Hoover s3765 Hose works, but when I attach the wand and floor tool, very little suction and when I increase all the red lights goes on...checked everything...help please

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Vacuums Master
  • 1,244 Answers

There may still be a clog or restriction somewhere. If the hose. Has good suction the problem may be. In the wand and floor tool.

Posted on Mar 26, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Red light on then cuts out how do i unblock please? lost the manual.


Hi There,.

So when this light is displaying, it's says "Bag Full or Clog" on the indicator. If you have changed the bag, and it's still showing this light, it means that you either have a clog in the vacuum, or your filters are dirty, which is reducing the suction and making the machine think that your bag is full. If your machine is actually cutting off, this indicates that your machine is definitely clogged, or something is stuck inside which is causing the motor to not get air flow, and cauing the machine to over heat. When it shuts off like this, it's a protection system that prevents any damage from happening to the motor when it can't breathe and starts to overheat.

My guess is that there is probably a clog in the machine somewhere, or the filters are dirty. Here's what you may do to diagnosis the machine, and try to isolate the clog to find out where it is in the vacuum.

Step 1. Remove the hose and wand assembly from the vacuum cleaner completely. You may do this by pressing the two tabs on the end of the hose that plugs into the vacuum cleaner:


cca2760.jpg
With the hose and the wand removed from the vacuum, it should look like this:

b7c34c5.jpg
Step 2. Now turn the vacuum cleaner on and check to see if the red light comes on while the hose and the wand have been removed. If the light comes on, then this indicates that your filter is dirty (or the PCB electric board is bad if the filter is clean) and needs to be replaced.

Step 2. Re-attach the hose and wand back on the vacuum, but just the end of the hose that goes into the vacuum cleaner, leave the wand out of the vacuum cleaner so it looks like this:


db25806.jpg
Turn the machine on now as if you were using the attachment hose to clean corners or above the floor and see if the red light comes on here. Also listen to the noise the motor makes and see if the noise changes when you put the hose back on the vacuum cleaner. If the red light appears, or if the motor makes a higher pitched noise now, then this indicates that you have a clog in your hose or wand. You may verify this by remove the hose again from the vacuum, and also removing the wand from the hose by pressing the hose release button on the wand and pulling the hose out of the wand. Look down both of the parts and see if you can see thru both sides. If you're not able to see light through the hose, or the wand, this indicates this is where the clog is. You may take a metal clothes hanger, and try removing the clog this way.

Step 3. If the red light did not display with the wand not inserted into the vacuum, put the wand back into the vacuum cleaner as if you were vacuuming the floors:


1a089d0.jpg
Turn the machine on, and see if the red light comes on in this position. If the light does come on, then this indicates that you have a clog in the bottom of the vacuum cleaner. To check and see the clog in the bottom of the machine, I find it easiest to remove the upper bag housing from the vacuum cleaner completely so you're just looking at the bottom power nozzle of the vacuum cleaner. There's a button at the bottom of the machine that is either a grey, or yellow color depending on what color your vacuum is. Simply press this button in, and lift upwards on the handle or the bag housing at the same time:


2b91587.jpg
Step 4. After the bag housing has been removed, turn the lower part of the vacuum upside down so the brushes are facing upwards. There's a little orange flap on the bottom of the machine that is actually a clog port. Almost every time there is a clog in a Sebo, this is where I typically find the clog. Open up this orange colored trap door, and look to see if you can see any obstruction or clog underneath of here:


08da832.jpg
Step 5. You may rotate the neck of the power nozzle part towards you so that you may look inside to see if you see any obstructions inside:

c034305.jpg
Step 5. You may also remove the brushes from the vacuum and look behind the brushes at the suction port, or the area where the suction goes through the vacuum to see if you see anything obstructing the suction here.

These are really the only places that the Sebo can get clogged. If you checked all of these areas, and the red light is still displaying, this means that your PC Board that controls this indicator has gone bad, and needs to be replaced. If this is the case, please just reply to this repair using the comment field, and I'll be more then happy to help you through the replacement of replacing the PCB Board.

I hope this answer was helpful to you, and you were able to find the clog and fix the problem. If you found my repair helpful, please be sure to rate the repair

Aug 09, 2012 | Sebo X4 Bagged Upright Vacuum

1 Answer

Hoover S3765


If you light and nozzle motor both go off at the same time, you might have a bad power cord. Mine had this problem which I could verify by jiggling/twisting the cord near the strain relief on the nozzle. It would go on and off as I did this. The cord is cheap to replace, around $13 for the part shipped. Part number is 59134072.

May 30, 2012 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

Light keeps flashing on top of canister of my Hoover Wind Tunnel but I emptied and cleaned it well. It sounds right when I turn it on then it goes into this sound like something is stuck but there...


sounds like a possible plug ,then when you first start it up the plug gets stuck a gain.
try taking hose off the unit and running water through hose .if water flows good ,check and see if lid is secure when closed.

Jul 08, 2011 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

Machine running hot. new bag but red flag indicator is fully closed at stsrt up. Runs but overheats and shuts off and red reset light comes on


you may have a blockage in either the hose, the telescopic wand or the power nozzle/floor attachment. The easiest way to tell, as you have a new bag in there is to disconnect the hose and start the machine. If the suction is good there, start to narrow it down. Take apart the hose from the telescopic wand, take the attachment off and look through the wand. Look in the connection on the attachment as well. If not there, look inside both ends of the hose, you may need a flashlight for this, and see if there is anything blocking there.

If the hose is blocked, you can try to unblock it by turning the machine on and inserting the handle into the machine where the hose would attach to the unit. Sometimes this reverse of suction is enough to dislodge whatever is in the hose.

Good luck

Nov 18, 2010 | Miele S548 Bagged Canister Vacuum

1 Answer

Is there a switch to turn-off the tools so that


On the Hoover U6311-900 there is no switch that turns off the suction to the tool hose. That hose is attached to the head of the vacuum on the side via a spring loaded "door". Just twist the hose to remove it, the door will close and you will have full suction again.

Apr 06, 2010 | Hoover U6311-930 Power Drive Bagged...

6 Answers

Hi my dyson dc18 has great suction from wand but when you got to use the vac for floors little suction but wand still got suction even while vacuming floors is it suposed to stop suction from wand


My Dyson dc18 had the same symptoms. The wand worked well and the floor bar had no suction. After removing pieces & shoving my fingers into the machine (no blockage) I found the suction pipe rotates between two positions (floor and wand). It looks like a piece of plastic broke on the outside housing, so it no longer rotates positions when the wheels are raised or lowered. My son found we can move the suction by sliding a finger into the mechanism behind the wheel cover, and rotating the plastic piece clock-wise or counter clock-wise until it locks into position. It's a big pain but it works for now. I wish I could find a replacement piece online. Patty

Apr 03, 2010 | Dyson DC18 all floors Bagless Upright...

1 Answer

My daughter's S3765 bagless canister has good


That means that you need to replace the belt. Here is the belt you need for your model.

Hoover Windtunnel Canister Belt

Dec 20, 2009 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

Can not figure out how I have to attach the Powered hand Tool


Just got connected it to the main hose and press the switch on

Mar 28, 2009 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

Brushes spin but the dirt does not go into suction hose


Most likely you have a clog. Starting at the brush head check every part of the lines for debris. More than likely YOUR clog is in the hose... easy enough to take a broom handle and gently push it through the hose (while the hose is NOT attached to the vacuum) Once you find the clog, you may have to use a little more pressure, but do so carefully, as you don't want to damage the hose itself.

Jan 19, 2009 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

Cannot disconnect the wand from the power cleaner


Looks like you will have to replace the quick disconnect asm. part # 38646086, you should be able to order this thru a shop that repairs Hoovers. If this is less then 1 year, then it is under warranty. You can call Hoover's 1-800 #. should be in your owner manual and on the metal tag on the cannister to find out where you can get part.

c82efa9.jpg

Oct 31, 2007 | Hoover S3765-040 WindTunnel Bagless...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...