Question about Ryobi 30 Cubic Centimeter Gas Brush Cutter

1 Answer

Ryobi SS30 starts great, runs fine, quits

After 5 mins of perfect running dies everytime..wait 30 mins start from fresh...works another 5 mins ...quits everytime...please help.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 462 Answers

The engine is getting to hot & shutting down either not the right fuel mix or not enough oil in engine sometimes the mixture screws need to be adjusted

Posted on Jun 14, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2000 Buell Blast runs great around town. Freeway speeds runs for 3 to 5 miles then out of nowhere dies. Acts like it's running out of fuel then dies. I have pulled the carb and cleaned the jets. C


If it starts up after sitting for a few minutes, (like 2 or 3) it could have a plugged fuel filter or the gas tank strainer built into the fuel valve could be plugged too. Drain the gastank anyway and change the gas with fresh. can't hurt. If it takes 15-30 minutes or after the bike cools some I would look at an ignition coil. Check to see if it has spark next time it quits.

Jul 05, 2012 | 2000 Buell Blast

1 Answer

97 lumina, 3.1. Starts runs smooth, drive for 30


I just recently have been fighting the same problem with the same make/model/year vehicle. For myself, I would drive off and on through the day and it would run fine. Then suddenly after a start it would run rough and die. I would have to wait 20 to 60 mins before it would start again. I had it checked and fuel pump was only putting out around 19 psi. It should be around 41 psi. Had fuel pump replaced and no more problems. Furthermore, now it runs so much better. It's funny how over time I didn't notice how the performance was slowly degrading. Unfortunaley fuel pumps for this car run around $300.

May 25, 2010 | 1997 Chevrolet Lumina

1 Answer

16.5 horse runs great for about 5 min then abruptly dies. wont start for another 20-30 min. fresh fuel, fuel filter & lines and new plug. air filter cleaned also.


sounds like you may have a ground issue.check for loose wires and make sure there are no bare wires that are touching the frame..good luck

Mar 31, 2010 | Garden

1 Answer

Fuel pressure intermittently drops causing sputter and die.


check for 12v constant at your fuel pump if you are not getting that replace your relay.
if you are getting 12 volts at your fuel pump the fuel pump is possible to run tuel it gets warm then shut down to a lower rpm I would then replace the fuel pump

Oct 10, 2009 | 1994 Dodge Ram

1 Answer

Ryobi SS30 Carburetor Problems


Replace thecarb screen, make sure you can see through the screen

Aug 18, 2009 | Ryobi Garden

1 Answer

Ss30 won't idle after starting


Hi Steve,

You will need to disassemble the carburetor and spray with carb.cleaner. Make sure the small screen in the carb. is free of debris. Use a Den Tek Brush, (http://www.drugstore.com/products/prod.asp?pid=165357&catid=1152), to clean the small portals in carb. Reassemble and start.

(NOTE: If the cleaning doesn't work, then buy a carb. kit and replace all appropriate parts.)

If you need further assistance, just let me know.

Jim

Jun 15, 2009 | Ryobi 15" Electric Factory Reconditioned...

3 Answers

89 regal won,t start but after 5 or 10 min. runs great


sounds like your fuel pump is going out. One thought might be that the fuel filter is causing enough resistance to over heat the pump. I would check the fule pressure to determine a free flow of fuel.

May 01, 2009 | 1990 Buick Reatta

3 Answers

Ryobi gas trimmer


I don't mean to over simplify this, but are you using fresh gas? Gas string trimmers are extremely ticky when it comes to gas. They like it SUPER fresh. And while the gas and oil mixture should be right, it can be off a little bit and still run. Try draining all of the gas out, and then filling up with fresh mix. This is ALWAYS my first step with string trimmers, and it fixes the problem 75% of the time.
Hope this helps!!

chad

Oct 03, 2008 | Ryobi 30 Cubic Centimeter Curved Shaft Gas...

Not finding what you are looking for?
Ryobi 30 Cubic Centimeter Gas Brush Cutter Logo

876 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ryobi Garden Experts

Nick Olsen

Level 2 Expert

183 Answers

Rexter1

Level 2 Expert

40 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Are you a Ryobi Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...