Question about Toshiba CF35F50 TV

1 Answer

Toshiba cf35f50 my tv works great when playing a dvd or xbox. the problem is when it is on cable tv it makes a loud popping sound and displays static every 10 seconds or so. i replaced the cable box and it is still having the problem only in tv mode. if i hit the tv at the bottom (old timers fix) it will stop the problem for a few seconds.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 45 Answers
Re: toshiba cf35f50

Bad connections in tuner. If your really careful, lots of very small parts, you can resolder the cracked solder ground connections to the metal box and metal shields.

Posted on Nov 04, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Only use to play games,,, now we have sound but no picture blue screen any suggestions?

Try a different input and see if you get a picture back...try tuner input. A blue screen shows up if it doesn't see an input signal. Try the game on another set. Problem may be with the game.

Mar 10, 2010 | Toshiba CF35F50 TV

1 Answer

When using cable input video is good but sound has fuzzy static

Your TVs tuner tuned a little off frequency. It could be as simple as having cable box on where you have good picture but fuzzy sound, use the TVs remote to change the channel and then change it back to proper channel. If that doesn't fix you may have wrong tuning type selected in channel set up menu.

Oct 11, 2009 | Toshiba 27A30 27" TV

1 Answer

TV has no picture, but sound works fine

Are you using the AV input for the XBox or other cable? If you use AV, then use the same input that the Xbox does not show picture, plug in a DVD and see if it works. If it does not have a picture, so 100% your TV has problem.

Aug 11, 2009 | Sony Standard (CRT) Televisions

1 Answer

Toshiba tube tv display doesnt show

when you unplugged it,it reset the need to set the clock.
on the remote play with the input,menu and display buttons until settings come the date and time is set,probably ok.the best thing is to see if your friend has the manual.there are literally hundreds of different toshiba t.v. alone

May 22, 2009 | Toshiba Standard (CRT) Televisions

1 Answer

No cable reception

hi, is problably your turner its damage

Jun 09, 2008 | Toshiba CF35F50 TV

1 Answer

Picture problem

Since it is 9 years model definetely loose contact and flux corrosion is there in wire connector and pcb also. Make one general service. Prolem solved.

Aug 23, 2007 | Toshiba CF35F50 TV

1 Answer

Toshiba cf35f50

You are missing the red color drive or it is weak. there are adjustments for that in the service menu or on the CRT drive board, but you should not attempt these adjustments unless you have a service manual or know 100% what your doing and how to do them. it could be the picture tube is weak or there could be a problem in the RGB drive circuits. Depending on how old the set is should determine or not it would be worth dropping any cash into it Good Luck

Mar 20, 2007 | Toshiba CF35F50 TV

2 Answers

Non-HD picture issues

Sounds like you may have something generating interference, such as a bad cable shield on maybe a ground connection inside your tv. You might try moving the cables while watching the screen and see if the pattern changes. Double pictures on a screen can be caused by "ghosts", which means that you're getting two signals--- one slightly behind the other. Anything oscillating generating a radio frequency may radiate into your circuits causing this strange problem. Stargazer

Feb 21, 2007 | Sony KP-53HS10 TV

1 Answer

Popping Sound

Just try replacing the audio cables and your connections, or sound setting.

Feb 08, 2007 | JVC AV27F476 27" TV

1 Answer

Toshiba 32" 2-Tuner PIP TV - Loud pop - then static

HI greetings from Belize.from the explanation i believe that there is two thing you might be having a problem in your tunner section whereby the tunner is going bad or the tunner circuit . or the cable from your wall is not connected corectly might lose.the video 1 and two is not associated with the tunner some how thats is the reason you did not get any disturbance.if your cable connection is good.then have your set checked out by a tech.good luck.

Nov 14, 2006 | Toshiba 35A44 35" TV

Not finding what you are looking for?
Standard (CRT) Televisions Logo

Related Topics:

86 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toshiba Standard (CRT) Televisions Experts

Jaime Hernandez

Level 3 Expert

2267 Answers


Level 2 Expert

49 Answers

Cindy Wells

Level 3 Expert

4718 Answers

Are you a Toshiba Standard (CRT) Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides