Question about Hoover U8143-900 Upright Vacuum

2 Answers


Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I took mine apart, cleaned otherwise inaccessible pipes, and assembled it back (that went well, huh!). The clog was made of human hair and and other long fibers (carpet pieces, etc).

Posted on Nov 24, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Took mine to repair shop for this problem. Dog and people hair caught up in housing you can't reach.

Posted on Oct 28, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Hoover power drive supreme has no suction

If there is no suction at all, not even a little bit, then most likely the suction fan is broken. They aren't too complicated to replace if you want to.

Jun 08, 2014 | Hoover U6311-930 Power Drive Bagged...

1 Answer

Hoover H3030-006 240 V Motor making a loud sound and burning smell

If you have little to no suction, that sound is happening because you most likely have a clog some were in the vacuum.

smell is probably your motor over working itself do to the clog.

also double check your belts on your brushes that they are moving with the motor. smell and sound could come from the brushes being jammed which would cause the belt to freeze and heat up and could burn the belt and or your motor.

if it is still running though your not in the red yetm so triple check that the machine is cleared off all clogs and jams in the belts and brushes.

Jul 02, 2011 | Hoover H3030 FloorMate SpinScrub 500...

2 Answers

On hoover steam carpet cleaner, the brushes do not rotate on low or high settings.

Follow these steps if the Brushes Fail to Spin
•If the brushes on your Hoover carpet cleaner fail to spin, there may be a problem---some sort of blockage---with the suction or with the belt that turns the brushes.
Turn the Hoover carpet cleaner over, and inspect the brush area. Debris, strings, or pet hair may be tangled in the rollers, keeping them from turning. Use a pair of scissors to cut away any obstructions in this area. Flip the Hoover carpet cleaner back over, and turn it on to see if cleaning the rollers has solved the problem.
To check the belt, turn the Hoover carpet cleaner over, and remove the bottom plate screw with a Phillips head screwdriver. Investigate the belt area to see if it is broken or has somehow slipped off. If it is broken, you can order a part from or from many of the other online parts stores.
When the belt arrives, simply slide it on in place of the broken belt, reattach the bottom plate and turn the Hoover carpet cleaner right-side up. Turn it on to test your solution.

Sep 03, 2010 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Dear Expert, the vacuum is not working in normal mode but if i use pipe then it works. Any suggestions? thanks khangee


So usually when an upright vacuum works well when using the attachment hose, but doesn't work well when vacuuming on the floor mode, this typically means that you have a belt problem. This is very easy to diagnosis. Turn the machine sideways so the brushes are facing you while the machine is plugged in. Be careful and make sure there's no hair, or clothing near the brushes, and turn the vacuum on. When you do this, are the bottom brushes spinning? If the brushes are spinning, with the vacuum running, put the vacuum brushes down on the carpet as if you were vacuuming, and listen to the brushes. Can you hear the brushes stop when you put the vacuum brushes on carpeting?

If your brushes are not spinning, or if you the brushes stop when you put the vacuum down on carpeting, this is a clear sign that you have either a stretched, or broken belt. Many people equate a broken or stretched belt to loss of suction because without the belt, the vacuum really can not pick up much at all off of the floor. When the vacuum doesn't pick up, many people assume the vacuum has lost suction.

Your roller brush may or may not also be bad. Installing a new belt properly will help you answer this question.

Please see the link below for the owners manual to a model that's similar to the model you posted this repair question under. The belt change will be identical. The belt change instructions starts on page 13 of the .pdf

I hope that this information was helpful to you, if so please be sure to rate my repair as helpful by clicking the thumbs up icon in the top of the repair.

If the belt is fine on your vacuum, please also let me know by leaving a comment here on the repair page, I can then go through some more advanced troubleshooting with you.

Thank you,

Chris J.

Apr 06, 2010 | Hoover Elite U5061-900 Bagged Upright...

1 Answer

While the windtunnel is upright the suction is awesome. When you lower it and engage the brushes is looses suction. It will not pickup anthing on the floor

check the brushroll if it spins freely, replace the belts 38528-034 and 38528-035. and make sure the tensioner for the V belt engages when you release the handle and pull the head back

Dec 30, 2009 | Hoover U8361-900 WindTunnel 2 Bagless...

1 Answer

Hose attachment doesn't work

If there is sufficient suction at the end of the hose, the brushes should turn. Temporarily cover the rectangular opening that contacts the carpet/upholstery. This increases the suction to the air turbine, and may start it. The only other thing the user can do is to try to turn one of the brushes to assure the components rotate internally. It will not rotate easily.

Sep 23, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Drive and brushes stopped

Look for a missing belt that may have burned off or broken. Was there a burning smell at some point before the roller quit turning? If so, the belt must be replaced. I would also look at the ends of the roller to see if there is any string, hair, etc. that might be binding the roller that needs to be removed.

Jan 24, 2009 | Hoover U8125-900 Savvy Bagged Upright...

1 Answer

Brush roller does not turn off in upright position

make sure there is not a lever to move in order to stop the brushes/agitator...
if the belt makes contact with the end of the shaft the brushes will rotate...
tighten all of course/and take the panel of to check behind the bag to make sure all is tight. (fasteners)
take off the face plate to make sure that the adjustment for the floor tools is not broke and belt is ok.

Sep 13, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer


This machine has no belts. There is an air driven turbine that propels the brushes. If you look under the little glass window at the left front corner of the machine, there is an intake screen just above the indicator dial. That screen is there to keep debris from entering the turbine and will have to be kept clean. If it is clogged, then the turbine will not function.It is also possible that moisture has entered the turbine and siezed the bearings. If that is the case, the turbine would have to be replaced. Also, because this turbine works off the suction of the motor, if the recovery tank lid is not on correctly, then the suction loss will effect the brushes. Check the lid and make sure it is on right.

Jan 12, 2008 | Hoover F5906-900 Upright Steam Vacuum

Not finding what you are looking for?
Hoover U8143-900 Upright Vacuum Logo

Related Topics:

159 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts


Level 3 Expert

18258 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides