Question about Peavey Xr 8600 8 Channel Powered Mixer

1 Answer

Xr8600 owner . was in truck in the cold, and brought it in for a gig and started crackling, and after about 20 minutes. lost of treble. gone. is this fixable? reset? i saw some of your posts about "co

Xr8600 peavy

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Peavey Expert
  • 232 Answers

Take it to the shop, we fix them all the time...

Posted on Sep 20, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My TH-15A starts making VERY loud crackling noises after a few minutes of being turned on. It does not matter if an XLR cable is plugged in or not, and the volume control does not change the volume of the...


buy a canister cold spray and spray on some active components if the noise begins You have a thermical failure in a component on the board can be faltering resistorcircuits or resoldering some active components.

May 08, 2016 | Mackie Tapco Th15a Thump Active...

1 Answer

Sudden static


Try some standards -- unplug EVERYTHING, and use the headphone out jack first. After 2-3 minutes, and it's still crackle or buzz, then it may be something wrong with the internals. Could be simple, but may be more than what the unit's worth to fix. If it DOES NOT crackle/buzz, then you might have a bad connection/cable somewhere. Just plug them all back in, one-at-a-time, and wait in between plugging in. Best of luck!

Apr 02, 2014 | Behringer Xenyx 1202 12-input 2-bus Mixer...

1 Answer

Extreme differences on overdrive channel


Please, take it to a tech in your area, or look for a good one to ship it to. An 2007 amp is not old at all.

Jul 24, 2017 | Marshall Mg100dfx 100-Watt Combo Guitar...

1 Answer

My peavy kb300 produces a crackling noise & cuts off intermitently when I raise the volume on all 3 chanels.


Low Voltage power supply regulation issue, particularly with +15V and -15V.

Dec 23, 2011 | Peavey Music

1 Answer

The treble on the equalizer doesn't seem to be working. The eq seems to have lost something. No depth to the sound. I've recently had it serviced but hasn't helped. Its lost its warm bright feel cheers


I had the same issue with my AS100D. When I first bought it the treble knob on the top channel was very responsive. At 10 is was unbearably "trebley". I was getting plenty of "high" treble set at 2:00, even 1:00. Then after about 6-7 mo, I started to feel it the brightness was leaving the amp. I was now putting my treble knob all the way to 10 and keeping it there, and it still wasn't enough. I had it serviced twice, no solution. Marshall got into the act and after months of going back and forth, they finally replaced the whole amp with a new one. I just got it. The treble was incredibly bright at 10, just like the former unit. But now after just a couple of days, I can already see the treble knob is not as responsive. I can't believe it! Now what?

Apr 07, 2011 | Marshall Amplification Marshall AS100D 2x8...

1 Answer

Trying to find the mute j111 on xr684f


I don't believe there is a mute function on the XR684F unit. There is a mute on the XR8600 but they probably use different boards in it. The mute button for the XR8300 and XR8600 are near the effects selector button and LIKELY is board mounted and would not have a J111 connector. If the electrical function is in the XR684, it MAY just be pads like test points, to only be used during testing and troubleshooting.

Mar 21, 2011 | Peavey Xr 8600 8 Channel Powered Mixer

1 Answer

Line 6 Spider III 15W- My Bass and Drive knobs arnt working... my mid and treble seems to be fine plus all my channels and effects but just those two knobs...and its buggin the **** out of me.... any...


resolder the three legs of the pots back down to the pcb. usually the treble feeds the bass, then from bass to mid then to ground. so if treble and mid are working its hard to imagine why the bass wouldnt be working. i would try to resolder, as you might have cold solder joints. keep it unplugged, pull off the knobs, open it up, remove the pcb screws and pull/flip out the pcb and resolder all of the pots.

May 25, 2010 | Line 6 Spider Iii 15 Modeling Guitar...

1 Answer

Hi, I've owned a Fender Hot Rod Deluxe since '01. Around '06 I started having problems like crackling sounds when on but guitars volume was all the way down. Loss of volume here and there. While amp was on...


In YOUR amp, take a pencil and tap teh sides of the tubes GENTLY, listening for any crackling... note SOME microphonics is normal in the preamp stages.

Since retubing it fixed it once, it is likely either a tube was bad OR a pin of a tube wasn't quite making so replacing the tubes cleaned it and made it work. Tubes DO go bad, especially when they are vibrated like in these amps... BUT don't just replace the lot, try to find which is at fault..

On your friends unit, LIKELY an electrolytic bypass capacitor for one of the reverb preamp stages has dried out and needs replacing.

Apr 23, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Marshall DSL 401 runs fine for about 10 minutes from cold then starts to crackle and sound disappears The amp is fairly new with not a lot of use


if this a tube amp then your tubes might be going bad. but if it is a solid state amp then im not to sure whats going on.

Mar 01, 2010 | Marshall Amplification Marshall MG250DFX...

Not finding what you are looking for?
Peavey Xr 8600 8 Channel Powered Mixer Logo

Related Topics:

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Peavey Music Experts

Ben Armstrong

Level 2 Expert

334 Answers

Vito Vacirca Jr.

Level 2 Expert

140 Answers

Lawrence Nentwig
Lawrence Nentwig

Level 1 Expert

8 Answers

Are you a Peavey Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...