Question about Bissell PowerForce PowerBrush Deep Cleaning System

Open Question

Does not **** up the water into the reservoir

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The steam comes out of the water reservoir cap instead of the steam Jet Nozzle.


I can only guess since I have never worked on one of these units, but I think you lost a gasket on the cap. Pressure must build in the reservoir before being forced out the nozzle.

Jul 13, 2015 | Tristar SB Steam Buggy Vacuum

1 Answer

Need a diagram of the water reservoir for the shark s3202


Here is a tip that I wrote about the Euro-Pro Shark Steam Mop and why it maynot be getting steam to the head...

Euro-Pro Shark Steam Mop Problem
.

Jan 06, 2013 | Euro-Pro Deluxe Steam Mop S3202 Upright...

1 Answer

Featherlite model 3M-852H


see this instructions:God bless you
Ensure the Dirt Devil is connected to a working power supply if it does not turn on or operate. Check the fuse or breaker and replace or reset as necessary.

  • 2 Empty the dirty water tank if there is little or no suction. Turn off the Dirt Devil and grab the top of the dirty water tank. Push on the latch to release the tank and pull the tank off the base. Remove the lid and empty the dirty water into a sink. Replace the cap and hook the front of the tank onto the machine base. Hook the nozzle on the base so that the nozzle is level with the cleaner base. Push the back of the dirty water tank down and into position.


  • 3 Check the dirty water tank and empty as necessary if there is water leaking from the cleaner. Open the latch on the top of the solution reservoir and pull the reservoir forward. Fill with Dirt Devil brand cleaner to the fill mark. Fill the rest of the reservoir with hot water and close the cap. Replace on the base unit.
  • 4 Make sure the solution reservoir is seated firmly in the base unit if there is no cleaning solution dispensing from the unit. Fill the solution tank with cleaner and water if the level is low.
  • 5 Examine the hose and nozzles for possible obstructions if the carpet cleaner does not seem to be operating correctly. Remove any blockages.
  • Jul 19, 2012 | Vacuums

    1 Answer

    I have the Platinum keurig and the water is going back into the reservoir and not into the cup??? is it beyond repair?


    Are you getting a message saying to "de-scale" it may need a good cleaning. That's usually the issue & the quickest fix. If the Keurig (or any other coffee maker) gets lime/calcium build up on the internal components it will ignore whatever has been programmed into it & just keep cutting off, keep making partial cups & just not working properly. Run some white vinegar thru it - fill the reservoir with a strong vinegar/water mix, remove any kcups/my kcup filters, also remove the reservoir carbon filter ( fyi - that's not going to eliminate any lime/calcium in your water - it's just to eliminate any bad tastes/odors) and "make" how ever many cups it takes to empty the reservoir.Depending on the build up - you may need to do this 2 or 3 times. Also run about 2 more reservoirs of just clear water to help rinse out the vinegar mix (otherwise your next cup of coffee will not be what you expected).
    This may eliminate your problem & should be done every 2-3 mths. If that doesn't solve it - your Keurig may already be too far gone. Good Luck.

    Jul 09, 2011 | Vacuums

    1 Answer

    Shows that it is ready to brew, but says "de scale"


    What model do you have? I'm guessing we are talking coffee maker, is it a Keurig? If you're getting a message saying to "de-scale" it need a good cleaning. That's usually the issue & the quickest fix. If the Keurig (or any other coffee maker) gets lime/calcium build up on the internal components it will ignore whatever has been programmed into it & just keep cutting off or keep making partial cups. Run some white vinegar thru it - fill the reservoir with a strong vinegar/water mix, remove any kcups/my kcup or filters, also remove the reservoir carbon filter ( fyi - that's not going to eliminate any lime/calcium in your water - it's just to eliminate any bad tastes/odors) and "make" how ever many cups it takes to empty the reservoir. Depending on the build up - you may need to do this 2 or 3 times. Also run about 2 more reservoirs of just clear water to help rinse out the vinegar mix (otherwise your next cup of coffee will not be what you expected).
    This should eliminate your problem & should be done every 2-3 mths, regardless of whatever the model of coffee maker you have. Good Luck.

    Jul 08, 2011 | Vacuums

    1 Answer

    Water is leaking in the back and not going into


    check bottom of reservoir thereshould be a rubber gasket make sure its in place or check to see if it fell out

    Apr 08, 2010 | Dirt Devil Easy Steamer Upright Wet/Dry...

    1 Answer

    Hoover steam vac clean water reservoir leaking.


    take the clean water tank out and look on the bottom for a fitting that screws on make sure its tight.also inside of that fitting trhere should be a washer or an oring to keep it from leaking.if thats not the problem then your pump mightbe leaking.for that i would take it to a vacuum repairman.i hope i have been of some help.please leave feedback

    Apr 07, 2009 | Hoover SteamVac F5914-900 SpinScrub...

    1 Answer

    Clean water tank


    Will the water come out of the tank when you depress the valve at the bottom og the tank? The tank sits on a resevroir asm., is the seal on it, black and round. Inside the handle is a rod, so when you squeeze the trigger, it pushes onto the reservoir to release the water, check to be sure it is, if not then you have a problem inside the handle or a bad reservoir asm. is bad.

    Feb 26, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

    1 Answer

    Clean machine


    This is what was wrong with mine....very simple solution to fix: Check the bottom of the water reservoir. It should have a black rubber washer attached to the lip that goes down into the main system. If that part is inside the main system, instead of attached to the water reservoir, the reservoir doesn't make a tight enough seal for the suction. Just carefully remove (I use tweezers) the black rubber part (almost like a thick washer) and put it on the reservoir. Should fix the problem!

    Aug 24, 2007 | Bissell 1697-7 Powersteamer Pro Deluxe...

    Not finding what you are looking for?
    Bissell PowerForce PowerBrush Deep Cleaning System Logo

    Related Topics:

    37 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Bissell Vacuums Experts

    Les Dickinson
    Les Dickinson

    Level 3 Expert

    18392 Answers

    Brad Brown

    Level 3 Expert

    15557 Answers

    Jim Thurston

    Level 3 Expert

    670 Answers

    Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...