Question about Arctic Cat F6 Firecat EFI Winter Sports

1 Answer

Katemjohnson26@yahoo.com I just replaced the stator and the sled was running great yesterday on about 1/4 tank of gas. Filled it up today and now has trouble starting and running period, what could this be?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 220 Answers

Sounds like you may have gotten some water in your gas. Flush thetank.

Posted on Sep 29, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

93 xlt 580. Only runs on 2 cylinders sometimes at cold. Change plugs and works sometimes.. Not always same cylinder.. Any way to check stator,coil?


Ask The SnowMan Your Sledding Questions Answered: Off ...

www.off-road.com/.../ask-the-snowman-your-sledding-questions-answer...
Mar 1, 2009 - Its a 96 polaris indy xlt 600 triple not the special edition though. ... THEM SITTING ON THE HEADS BUT ONLY 2 CYLINDERS ARE RUNNING WHEN ... Q: I have a arctic cat ext580 the compression in both cylinders is about 70psi .... i have a93 polaris 600 xlt and I just got home and the antifreeze is ...

93 XLT Carb settings? - Snowmobile Forum: Your #1 Snowmobile Forum

www.snowmobileforum.com/polaris.../41045-93-xlt-carb-settings.html
Nov 27, 2009 - I bought a new to me 95 polaris sport last year. it had not run in twoyears. ... It's all in the tuning, clutching, jetting and gears.. i have a 93 xlt 580 and i ... he is loading up with fuel and just cutting the spark out of a cylinder.. i had ... XLT w/ Triple Pipes Question?
May 8, 2013
93 XLT Ran Great, Shut Down, Now Backfires
Feb 13, 2012
Dead cylinder
Dec 11, 2011
1998 ski doo f3 700 wont run right
Feb 22, 2011
More results from www.snowmobileforum.com

Polaris Indy 600 XLT HELP! - Snowmobile Fanatics


Jan 04, 2016 | Cars & Trucks

1 Answer

Engine runs rough, no power, stalls


you may need to get your fuel filter replaced

Jan 28, 2014 | 1991 Ford F250

1 Answer

Gas tank lid wont close


The flap in the fuel filler pipe will not affect the vehicle if it's open or closed or not there at all.There is air in the gas tank at all times displacing the gas as you use the fuel.

May 30, 2017 | Chrysler Sebring Cars & Trucks

2 Answers

I filled up my 2002 Mazda MPV yesterday at Walmart, Manning


Could be bad gas, water in the gas? Run the tank down to about 1/4 and put gas from somewhere else in it. Maybe higher octane for one tank full. Maybe put an additive in with it. If it clears up, then it was the gas.

Mar 13, 2010 | 2002 Mazda MPV

1 Answer

1996 buick lasabre won't start in cold weather the battery is new--it cranks great--this happened once before late last year when it got realy cold. When it got into the 20's I was able to start the car. I...


buy a more expensive battery and check the fuel injectors to make sure they are not clogged from the heat that you pured into the tank. i do not recommend putting heat in a gas tank of any vehicle

Jan 05, 2010 | 1997 Buick LeSabre

1 Answer

Fuel pump 2005 nissan altima


Take it back to where you had it serviced. They probably simply missed connecting the fuel level sensor. The engine light is probably from a missed emissions hose that goes to the gas tank.

Jun 27, 2009 | 2005 Nissan Altima

1 Answer

My 1997 Chevy 4 dr 4x4 has fuel delivery problems.


try replacing your relay first not that expensive and easy to change also some models have a red jumper wire on the relay plug that sends power directly to pump

Mar 26, 2009 | 1997 Chevrolet Blazer

2 Answers

E85 fuel in a regular gas tank


drain the tank change the fuel filter motor will be fine
it'll run funky until the e85 is flushed out

Dec 12, 2008 | 2001 Ford Windstar

1 Answer

Gas stove


Make sure the fitting on the tank where your line comes from isn't freezing up. I don't know about large propane tanks but they might have the new safety valve in the shut off valve in your tank as well. Trying shutting off or if you don't feel safe maybe somebody else shut the valve off then reopening it.

Dec 06, 2007 | KitchenAid Superba Architect KSCS25INSS...

Not finding what you are looking for?
Winter Sports Logo

Related Topics:

305 people viewed this question

Ask a Question

Usually answered in minutes!

Top Arctic Cat Winter Sports Experts

ray gallant

Level 3 Expert

41458 Answers

 steve
steve

Level 3 Expert

3296 Answers

rhodesworks

Level 3 Expert

3082 Answers

Are you an Arctic Cat Winter Sport Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...