Question about Generac Guardian Ultra Source 15,000 Watt Portable Generator #04582

1 Answer

Starts up but will not run but for a few seconds

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 37 Answers

Check the oil. Some engines will shut down if the oil is low. Otherwise you probably have a dirty fuel filter and the carburetor fills up with gas long enough to start but isn't getting enough gas to keep it full.

Posted on Feb 16, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

03 subaru Legacy 2.5 won't start . Turns over but won't fire. I have replaced fuel pump , fuel filter , and the pressure regulator. Pure fuel in the intake and starts fine What could be the problem


Does it start and keep running? Or does it start and just run for a few seconds? If it starts and runs for a few seconds you need to check your fuses first. It could be the fuel pump or EFI fuse or a few others.
If you prime it and it keeps running, well, you've got me there.

Sep 12, 2015 | Subaru Cars & Trucks

1 Answer

Why wontsmart carb engine start if primed runs for few seconds


dirt or water in the carby jets
priming it just puts a squirt of fuel in the manifold and that is the initial start run

Jun 19, 2015 | Garden

1 Answer

HUSQVARNA 128LD WILL START RUN FOR A FEW SECONDS AND DIE.


You need to adjust your idle screws. Start at 1 and a half turns out for High and Low then go from there.

Aug 22, 2014 | Husqvarna 128 LD Weedeater

1 Answer

Car cranks but will only run for a few seconds then I wait a few minutes and it starts but only forb ab few seconds, why


You will need to figure out if it is fuel or ignition related to know how to proceed. Will it continue to run if you spray starting fluid into the throttle body ?

Jan 17, 2014 | 1993 Cadillac DeVille

1 Answer

Engin wont stay running after it starts


How long does it run? A few seconds or minutes? Sounds fuel related. Generally rebuilding or replacing the carburetor will fix it if it starts and dies after a few seconds. If it runs for a few minutes then we need to look at something else for the issue

Jan 15, 2014 | Tecumseh 5hp Engine Snow King Mtd Blowers...

1 Answer

RUNS AND QUITS


You could try replacing the ignition coil. If it's failed, then it may run ok for a few seconds, but as it heats up it fails. Trying to start again immediately will be too soon for the coil to have cooled down. Leave it a few minutes to cool down and it will run again, but only for a few seconds again.
Hope that helps

Jan 03, 2014 | kawasaki 2011 Teryx 750 FI 4x4 Sport

1 Answer

93 toyota pickup 4x4 it will stay running after I turn it on to start it up, it starts up then after a few seconds it kills


if I'm reading this right...
... the engine starts and dies within a few seconds.
... you jumpered the fuel pump test connector and it will keep running.
... you smell fuel after trying to re-start when it dies.

Disconnect the plug to the cold start injector. Even if you have an issue with the engine running then dying after a few seconds after doing this, if you don't smell fuel after disconnecting the cold start injector and try to restart it, the cold start time injector time switch may be failing.

Buy a can of starting fluid and have someone start the engine then spray short bursts of the fluid around all the intake fittings. If spraying the fluid in any particular area keeps the engine running, I'd start looking for leaks around that area.


It does sound like an AFM or COR issue considering it dies after a few seconds, but the fuel smell when trying to restart the engine may be a separate issue that needs corrected / isolated first.it will keep running.

... you smell fuel after trying to re-start when it dies.


Disconnect the plug to the cold start injector. Even if you have an issue with the engine running then dying after a few seconds after doing this, if you don't smell fuel after disconnecting the cold start injector and try to restart it, the cold start time injector time switch may be failing.


Buy a can of starting fluid and have someone start the engine then spray short bursts of the fluid around all the intake fittings. If spraying the fluid in any particular area keeps the engine running, I'd start looking for leaks around that area.


It does sound like an AFM or COR issue considering it dies after a few seconds, but the fuel smell when trying to restart the engine may be a separate issue that needs corrected / isolated first.

Mar 30, 2013 | Cars & Trucks

2 Answers

91 4x4 starts wont sta running more than a few seconds


maybe your mass air flow sensor on your airbox?

May 05, 2009 | 1990 Toyota Pickup

1 Answer

Takes multiple times to start


I think you have a faling fuel pump or a bad pressure regulator allowing fuel pressure to bleed down when the engine is off.
Try this test - When you start the car for the first time of the day, turn the key to "ON", wait a few seconds, turn the key off. Wait about 15 seconds, turn the key to "ON" again, wait a few seconds. Then wait one final time for 1 seconds and try starting the car. If it starts right away, that means fule pressure is bleeding of due to a bad check vavle int he fuel pump, a bad fuel pump or a bad pressure regulator.

The reason for the procedure is because when you turn the key to "ON", the fuel pump runs for 2 seconds and then shuts off if the engine is not running. The 15 seconds wait is for the power and fuel pump relay to cycle off before it will run the pump again.

Let us know how the test comes out. The fuel pump is in the fuel tank and hums when it is running.

Mar 01, 2009 | 1999 Chevrolet Silverado 1500

Not finding what you are looking for?
Generac Guardian Ultra Source 15,000 Watt Portable Generator #04582 Logo

238 people viewed this question

Ask a Question

Usually answered in minutes!

Top Generac Guardian Electrical Supplies Experts

jdthefixer

Level 3 Expert

744 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

ken skalski

Level 2 Expert

152 Answers

Are you a Generac Guardian Electrical Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...