Question about Car Audio & Video

Open Question

I have kenwood rxd-f2 . it was on and it got extra voltage. now its not working. the current condition is now when I turn it on, the display turned on for 2/3 seconds and then it shuts down. few green

I have kenwood rxd-f2 . it was on and it got extra voltage. now its not working. the current condition is now when I turn it on, the display turned on for 2/3 seconds and then it shuts down. few green -------------- dots blinks starts, some times "auto power control on " also displays.

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: Can't get to turn the sub On-Off

I had the same problem. The people at Kenwood are idiots when it comes to writing instructions. What you have to do is go to standby mode, hold the menu button until the menu displays. Now, scroll down to where it says "Rear." Push the control knob to the right. Now you have the ability to turn your sub on and off. Once that's done, just go back to CD or Tuner, push the knob down, hold for the two seconds, then it should say "On Sub." It took me a while to figure this one out.

Posted on Oct 17, 2007

  • 33 Answers

SOURCE: aoc lm725 display off after few seconds

I've had a very similar issue on many Dell Monitors. Mine have been under warranty and they usually send me a new monitor, but I believe the issue lies with the power supply within the monitor.

Posted on Jul 10, 2008

  • 4 Answers

SOURCE: Kenwood KDC-2011S display blinks

Download the MANUAL here.

http://www.retrevo.com/search/v2/jsp/downloadPage.jsp?doc=037b5697f7192f25431654464fa26ba6&q=Kenwood+KDC-2011S

Enjoy!

;) Mak

Posted on Aug 06, 2008

  • 3 Answers

SOURCE: Protection displayed and shuts off

Hey guys! Im glad you found my solution on my blog, and posted it here. I hope you ccan fix yours, or get it replaced on warranty. Im happy to help you with anything, the capacitors i think was 4,7 uF, 100volt, not sure. 
Here is the link to my solution: http://lemurt.wordpress.com/2008/08/18/defenition-of-waranty-void/
:D
/ lemurt

Posted on Sep 22, 2008

JustJeeps
  • 74 Answers

SOURCE: JVC KD-S70R

you have a blown fuse there are 2 fuses for this unit yellow wire and red wire one of them has no power

Posted on Nov 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwood Hi-fi component RXD-M1MD is not working


Hi,
I have kenwood rxd m1md . it was on and it got extra voltage. now its not working.
the current condition is now when I turn it on, the display turned on for 2/3 seconds and then it shuts down. few green -------------- dots blinks starts, some times "auto power control on " also displays.
Please tell me what happend to this unit? which IC or part have to change?
Thank You

Jun 13, 2012 | Audio Players & Recorders

2 Answers

Kenwood RXD-G2 clock setting


My kenwood is not a car system but it is

KENWOOD entertainment system


RXD-G2

Turn power on at wall

Clock is flashing

Press clock

Press memory

Hour flashes

Press up/down to set Hour

Press memory

minute flashes

Press up/down to set minute

Press memory

Press power on buton

Feb 13, 2012 | Car Audio & Video

1 Answer

When i turn on my kenwood kr-v990d it powers up for about 2min then shuts down


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Oct 23, 2011 | Kenwood KR-V990D Receiver

1 Answer

KENWOOD RXD-V555 PROTECT MODE WAS APPEARED . i CANNOT OPEN MY COMPONENT


MY MODEL IS RXD-V555 , LAST 1 YEAR NOT USE AND NOW START BUT PROBLEM IS WHEN POWER IS ON GO ON PROTACT MODE AND NO SCREN. PLEASE HELP

Oct 15, 2011 | Car Audio & Video

1 Answer

There's a problem with my Kenwood vr-506 the power


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be your output drivers- the MOSFETS/IC's fitted for both the channels, Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise like a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.
You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board, maybe the protect circuit by itself is shutting off due to a faulty bias , maybe a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the protect is off then check for short on the speakers.

Jul 22, 2011 | Kenwood Audio Players & Recorders

1 Answer

Hi.well I have a problem with my Kenwood and I've


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be your output drivers- the MOSFETS/IC's fitted for both the channels, Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise like a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.
You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board, maybe the protect circuit by itself is shutting off due to a faulty bias , maybe a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the protect is off then check for short on the speaker

Jul 22, 2011 | Kenwood Audio Players & Recorders

1 Answer

Kenwood RXD-A75 CD Drawer Stuck shut and ERROR message appears on display.


Look for a miniature little hole somewhere on the face of your unit,. Get a paperclip (smallish) straighten out one end and insert into holr. It might say reset, might not. You want to do a sort of heimlich manuever thrust (miniature style), insert the paperclip, thrust about a quarter of an inch, and the drawer should pop open. At least enough where you can "help it gently", don't yank its slide mechanism out, but verbally threatening sometimes helps............ Sometimes...............

Oct 02, 2010 | Kenwood XD-A75 CD Shelf System

1 Answer

Kenwood rxd-355


It's a safety measure by design to avoiding overloading your stereo system.

May 31, 2010 | Kenwood Audio Players & Recorders

1 Answer

My kenwood compact disk payer rxd-a53 shut off now it keeps click


Your problem is caused by a blown fuse on the main board 6.3amp 125volt time delay fuse replace with the exact same type. The reason the fuse blew is most likely because they is a problem with the amp.
I suspect one of the finals is blown 2SD2560 or 2SB1647. Open the case and with the power unplugged replace the fuse, next unplug the 4pin connector from the amplifier board 3 black wires and one red.
now plug in the RXD-A53 and turn it on. you should now have the display working and no clicking.
unplug it from the wall and reconnect the 4 pin connector and now plug it back in and turn it on if the fuse blows again take it to a qualified service technician, the above noted output transistors will run you about 6 bucks a piece they are 4 of them 2 of each for each channel plus labor.

Mar 02, 2009 | JBL On Stage Micro Speaker Dock for Apple...

1 Answer

Kenwood RXD 501


Do you already check the thermal fuse on the primary side of the transformer

Oct 01, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

33 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...