Question about Panasonic MC-V9638 Bagged Canister Vacuum

Open Question

Won't turn off, even if hose is detached

Vacuum does not turn off with control switch. Even if hose is not connected to canister, and plugged it the machine is on

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Lux5000 will run until hose is attached, then shuts down. Pushing the reset button did nothing.


Experienced the same problem, just fixed it! Lift up the control dial on top of canister. You will see two small clear hoses inside. Detach the hose going to the "bag full" sensor light. It'll fix the problem!

Sep 17, 2011 | Electrolux Lux 5500 Canister Vacuum

1 Answer

The machine keeps shutting off with a full bag lite everytime I turn it on..? the previous bag isn't full and it does it with a brand new one


The most probable problem is a clog in the hose.
First detach the hose from the vacuum and turn it on. If it runs without the hose, you're on the right track. Detach the hose from the wands and drop a coin in one end. Lift the end so the coin should drop through. If it doesn't, there's definitely a clog. Plug the hose into the exhaust port, place other end into front of vacuum, and turn it on. This usually clears it.
Also check the elbow at the power nozzle. Clogs here are usually visible, but you can hold the PN up to the light to check for a blockage.
If none of these take care of the problem, the entire vacuum needs to be taken to an authorized Aerus Electrolux shop for diagnosis and repair.

http://www.aerushome.com/storelocator/

Feb 17, 2011 | Electrolux C101 Bagged Canister Vacuum

1 Answer

How do you unclog a hose on a Bissell proheat powerlifter


Detach the hose completely.
Plug wrong end of hose into in port of vacuum.
Turn on. This should remove the clog.
If not, try using a vacuum with an exhaust blower to blow out the clog. Most canisters have these. An air pressure hose may work as well.

Nov 23, 2010 | Vacuums

1 Answer

My Dirt Devil Vibe bagless vacuum started giving off a burning smell. The brush roller was jammed with hair. I immediately shut it off and cut the hair out of the rollers with scissors until it turned...


It's more likely there's a clog in the hose somewhere, possibly where it connects to the power nozzle. Detach hose and check the PN.
If there's no clog in the PN, detach hose completely from machine and try to drop a marble or coin through the hose. If it doesn't fall through, there's a clog that needs removed/cleared. Hold PN end of hose tightly to tank of vacuum and turn on. That may be enough to **** the clog through. If not, use a canister or shop vacuum to blow the clog out.

Nov 13, 2010 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Central Vacuum works when power switch on canister is turned on, but will not turn on when connecting the hose.


DOes it not work on any of your wall inlet valves? If all wall inlets appear dead take a coin making a connection with both of the contacts inside the throat of the valve. If the vacuum turns on the problem is in your hose or the powerhead. If nothing happens plug in your hose and try wiggling the low voltage wires at the vacuum as you leave the hose plugged in with the swich on your in the "on" position ( if you have a switch) If still nothing unscrew all valve plates from wall leaving wires attatched. Inspect all connections for loose wires or wires that have come off terminals. .

Nov 09, 2009 | Kenmore Vacuums

1 Answer

Motor goes on and off briefly at regular intervals


Sounds like you may have a bad or loose connection, could be one of wires in the hose to the handle harness or the harness itself may be causing the problem. Also be the motor or relay causing a problem.

Jan 08, 2009 | Kenmore 23313 Whispertone Bagged Canister...

1 Answer

Help


hello jane just a brief message if you look on tis board at a similar problem i have just replied to about canister cover lifting off ? this may also be the same problem as the fixit solve i have suggested ? about blockage of filter please read it and will explain fault /remedy best wishes from uk

Oct 20, 2008 | Electrolux UltraLux 2000 Bagged Canister...

1 Answer

Suddenly the vacuum won't turn on


Could be a number of reasons, may have a bad cord, If the switch is on the hose, it may have gone bad. Could even be a motor problem. Needs to checked to find the problem.

Mar 13, 2008 | Kenmore 23812 Progressive PowerMate Bagged...

Not finding what you are looking for?
Panasonic MC-V9638 Bagged Canister Vacuum Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Panasonic Vacuums Experts

jasbo
jasbo

Level 3 Expert

2237 Answers

Joseph Hoffmann

Level 3 Expert

1702 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

Are you a Panasonic Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...