Question about Car Audio & Video

1 Answer

If my zapco amps break down will the company repair them for free

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 27 Answers

Only if its under warranty. If you are the original owner with a reciept from an authorized dealer then they will warranty it for free. You can find information here---> www.zapco.com/support.html

Posted on Feb 11, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I installed a 400 watt zapco competition amp\ front speakers play ...back woofers don't?


are you sure you didnt wire the amplifier the front and rear to
left/ right?

check your deck settings to see that the rear speaker rca are connected.
check all wires are connected.
push the mono or bridge buttons are off.

provide more info.

Nov 03, 2013 | Zapco I-450 IFORCE SERIES 4 CHANNEL CAR...

1 Answer

Install my amp


Go to this link and see page 47

http://www.zapco.com/files/Download/DCRef.pdf

Jan 18, 2013 | Zapco Reference 650 Car Audio Amplifier

1 Answer

How many rms does my amp have.....??????


4-channel, 4 ohms: 4 x 50 Watts
4-channel, 2 ohms: 4 x 90Watts
Stereo, 4 ohms: 2 x 180 Watts
T.H.D. : Frequency Response: 10 - 25KHz
S/N Ratio: >90dB
Channel Separation: >50dB
Dimensions: 13"L x 9.9"W x 2.25"H

Zapco I450 Zapco I 450 iForce Series 4 Ch. 360 Watt Amplifier

May 22, 2011 | Zapco I-450 IFORCE SERIES 4 CHANNEL CAR...

1 Answer

I need a manual for a zapco PEQ 9 band (old school) equalizer. can you help me?


i got a wiring paper that comes with the peq plug,its not a manual but it shows how to wire up a zapco peq

Nov 07, 2010 | Zapco Car Audio & Video

1 Answer

I have a zapco refrence 750.2 has no sound output when bridged but works fine when i run a speaker to each channel. any ideas on whats wrong?


check your settings on your stereo and the amp make sure you have changed to 1 ohm on the amlifier for a briged connection to a subwoofer and change from lpf to hpf on the amp there should be a switch.

Jun 07, 2010 | Zapco Reference 750 Car Audio Amplifier

1 Answer

...storing noise detected from my


Storing as in Distortion? If that's the case lower the output gain from your amp until it is suitable to you ears. It might be all the way open, besides this should be adjusted system to system.

May 31, 2010 | Zapco Reference 650 Car Audio Amplifier

1 Answer

Zapco DC Reference 750.2 problem


If the amp uses TIP35Cs and TIP36Cs, those will be the output transistors. Measure the resistance between legs 2 and 3 for each of the output transistors. Do any read near 0 ohms?

If you're new to repairing amps. The following page should help.
http://www.bcae1.com/repairbasicsforbcae1/repairbasics.htm

Nov 16, 2009 | Zapco Reference 750 Car Audio Amplifier

1 Answer

Repair service for AG1000 Zapco Amp.


Is it blowing the three 30 amp on-board fuses?

To have 3 speakers bridged, each speaker must have at least a 12 ohm impedance (assuming that all speakers are connected in parallel). If you're running a load lower than 4 ohms (mono), the amp will likely fail.

The fuses don't blow right away because they are cold at first. As they heat up, they can blow more easily (even though the current draw hasn't increased).

Aug 10, 2008 | Car Audio & Video

1 Answer

Zapco ag 350


Check your ground and make sure it is properly grounded ....it needs to be a very clean paint/gum free area tightly bolted.  Next Check and make sure you are recieving your 12 volts (not running)  13 (running)    by placing your test leads from positive to ground...... then make sure your power remote from your head unit is putting out voltage. 

Aug 23, 2007 | Zapco Reference 200 Car Audio Amplifier

1 Answer

ZAPCO 9.0


Go here first http://www.zapco.com/ Good Luck

Aug 06, 2006 | Zapco C2K-9.0XD Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

29 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

yadayada
yadayada

Level 3 Expert

75077 Answers

The Knight
The Knight

Level 3 Expert

73665 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...