Question about Winter Sports

1 Answer

Polaris 600 cuts out at hi rpm

My Polaris 600 cleanfire sdi starts and runs fine until it gets up to about 60 mph. At that point the engine cuts out. If I back off the throttle it runs fine if I keep its below 55 mph (approx. 7000 rpm. any ideas ?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Filmmaker:

    Uploaded 5 video answers.

  • Expert
  • 161 Answers

Check your Air Filter, clean it out, check for obvious blockages. Change the filter if it looks well used (look for excessive dust or color change on the inner part of the filter) or obvious wear.
Check for other blockages around the air filter inlet.

Check the spark plug, just change it for a new one so that eliminates that possibly.

Check your fuel filter and replace if needed.
Check the fuel tank for corrosion or dirt in the fuel. Empty it out, Clean it and add new fuel, be sure you have the correct fuel.
Check your Air / Fuel mix adjustment screws on the carburetor.

Hope that helps a bit
Good Luck

Posted on Feb 10, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Start up idle is slow below 1050 rpms and sounds like going to stall while idling. Runs fine otherwise.


How to adjust your Polaris Snowmobiles TPS. - YouTube

? 6:05
https://www.youtube.com/watch?v=aEPx7OsywNk
Dec 11, 2009 - Uploaded by PolarisRich
A quick video on how to adjust your Polaris Snowmobiles Throttle ... TPS cause this? it seems like it hits top rpm, it runs flawlessup to the ... Would this work on a 2011 Polaris pro rmk 800?? ... I have a 2006 Polaris Fusion 600 h.o. It seems to bog out when u first start ... Sounds like its a carb or clutch issue!

2011 Pro RMK 800 Top End Bogging [Archive] - SnoWest Snowmobile Forum

www.snowest.com/forum/archive/index.php/t-298871.html

Jan 30, 2012 - 52 posts - ‎33 authors
[Archive] 2011 Pro RMK 800 Top End Bogging Polaris: Pro-Ride. ... Sled is a 2011 ProRMK 800 155, 1700 kms, MBRP can. ... problems with bogging at every rpm and roughidle, I am running 91 from .... fuel filter yet?...almost sounds like your fuel pump can't keep up with ..... I am running a 2010 660 CFI-4. 2010 dragon 155 RMK electrical problems
13 posts
Feb 3, 2013
Polaris update
100+ posts
Nov 15, 2009
~~The Official Phazer Thread~~
100+ posts
Sep 12, 2009
M1000 Hiccups on the Bottom
100+ posts
Jan 28, 2008
More results from www.snowest.com

Jan 12, 2016 | Polaris 2010 RMK 800 Dragon 163-Inch

1 Answer

I have a 2004 polaris sportsman 500 when it gets hot it cuts off and back fires


Does the cooling fan ever run when the engine is hot? If not, you may have a problem with the fan thermostat.

For the record, spray carburetor cleaner does no good if it's sprayed on the outside of the carburetor with the engine running. That's not what it's for.

Jul 29, 2014 | Polaris 2004 Sportsman 500 H.O

1 Answer

Slow ground speed


or low geared all the way around..

Mar 08, 2014 | Polaris ATV

1 Answer

Can anyone tell me about Polaris Rush Pro?


Hello Rajendra, Rush Pro is an appreciable product by Polaris India. It is coming with lots of exciting features like-

Pro-Ride progressive-rate rear suspension
Pro-Ride chassis
600 Cleanfire engine
Race-Proven front suspension etc.

For more details, visit:
Rush Pro Snowmobile Features Buy snowmobile in India Snowmobile dealer...

Feb 28, 2014 | Polaris ATV

1 Answer

Looses power


You are either Losing Power (Engine) or Primary is Failing.

If you are losing it after it warms up, look at the RPM. If the Engine RPM is staying HIGH, then you have a Primary Clutch Issue.
If you are Losing RPM, then you are losing Compression. Best thing to do is look at the Compression of the Engine and if the Compression is LOWER on one Cylinder (Normally the PTO SIDE) then you are going to be doing a top end rebuild.
There is a slight 3rd scenerio (CDI is going bad).

Jan 28, 2014 | Polaris 2009 Trail Touring DLX

1 Answer

Runs fast 100 mph for 5 minutes. heats up and goes down to 60 mph. cool off 5 minutes back to normal


Check your Compression, once the engine gets to temperature, you are EXPANDING the Metal and losing compression.

It could also be the PRIMARY CLUTCH, If you are experiencing a Primary Clutch Failure, the Springs inside will be effected by the HEAT.

QUESTION:-
What is the Engine RPM when you are doing 100 and when doing 60?
Is the Engine RPM IDENTICAL? If RPM is the Same, you have a Primary Issue, if the Engine can't get out of its own way, then you have a Compression Issue

Jan 28, 2014 | Polaris 2009 Trail Touring DLX

2 Answers

My 2004 700 sportsman runs great and then cuts out at 20 mph. If I take my thumb off the throttle, it'll recover and run great until 20 mph. what gives???


Your carb. isn't getting enough fuel when the demand increases as you go faster. Begin by getting a can of a carb. cleaner, like seafoam which you add to the fuel, one ounce per gallon. That will clean your carb while u operate your sportsman and hopefully solve your problem. If that doesn't clear it up then the carbeurator will have to be rfebuilt.

Jul 05, 2009 | Polaris ATV

2 Answers

Polaris rmk 500 backfires when it gets hot then won't start


Ok this sounds like a similar problem that I have had with a 500xc engine...This engine has been running fine for the last 5 yrs until a few weeks ago when it became a pig to start and when it did only run on one cylinder eventually running on both and when it gets to a certain temp would cut out and then not start again for 5mins, changed everything we could think of, checked compression, barrels fine, carbs clean new cdi, coil, plugs, leads, fuel pump and pipes, then someone came accross with checking the resistance on the temp sensor on the top of the head which were different values to the the book and on another identical engine, I borrowed a spare sensor and although still a pig to start it was an improvement when running, need to buy a new sensor to rule it out
, can anyone else shine some light on this?

Feb 20, 2009 | Polaris New Genuine Polaris Snowmobile...

Not finding what you are looking for?
Winter Sports Logo

Related Topics:

384 people viewed this question

Ask a Question

Usually answered in minutes!

Top Winter Sports Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Todd Arndt
Todd Arndt

Level 3 Expert

2044 Answers

Are you a Winter Sport Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...