Question about MTX X702 Car Amp

Open Question

Thunder x 702 the light comes on then turns red then shuts down, checked all wires and good ground and fuses inline and amp ???

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 6 Answers

SOURCE: feedback issues.

Did you run your power and remote wires the same route as your RCA cables? If you dont run the RCA cables on the opposite side of the power and remote you will get feedback through your speakers. I run my power on the side closest to the battery along with the remote ( passenger in my case) and the RCA cables should be on the opposite side( driver side). They say the power current will create a disturbance in the RCA cables that you would hear as feedback. Hopefully this will help you.

Posted on May 29, 2009

MPetro302
  • 298 Answers

SOURCE: my MTX thunder 502x was working fine and know the

Could be a blown speaker/sub or a wire is crossed in the sub enclosure.

Posted on Jun 04, 2009

  • 149 Answers

SOURCE: MTX Thunder problem

Make sure that your connection at the battery is still good-sometimes the wire corrodes up front when your system is installed for a long time-so check that out and of course the fuse that you installed a foot away from the battery so that you dont burn your vehicle down if a short occurs somewhere down the line

Posted on Jun 04, 2009

nate6556
  • 103 Answers

SOURCE: MTX Terminator Amp...Red light comes on when it should be green.

its just a power light to let you know its on

Posted on Jul 25, 2009

lscf150
  • 443 Answers

SOURCE: i have a mtx thunder 421d. I've had it about 5

If you have proof of purchase(invoice or receipt) showing the purchase date and you are still within the warranty period then yes it would be repaired by MTX under the warranty guidlines, and by the way MTX is great at customer service and they are great to work with(very fair)!!!!
Keep in mind that the seal on the bottom of the amp cannot be broken or that will void warranty coverage.
Give them a call, you will be glad you did!
800 225 5689 - MTX Customer Service & Amplifier Service Center
Good luck !

Posted on Jan 31, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwood kac 628 red light comes on and no audio output


The red light you describe on your amp, is the protection mode warning light. An amp goes into protect for many reasons. Here's a checklist.

1st check the fuse (s) on your amp and make sure they are not blown.

2nd check the inline fuse next to your car battery (if you have an inline fuse)

3rd, disconnect the speaker wires with amp on, does the light go off?

4th check your ground, this may be ok if you have tried another amp with the same wires.

5th.if none of these turns the protect mode off, it may be an internal fault.

you may have blown transistors and it is a tricky job to repair and costly.

Jan 28, 2013 | Kenwood KAC-628 Car Audio Amplifier

1 Answer

Where is the fuse


is it the stock radio? if not, it may have a inline fuse. check the wires behind the radio, the red wire may have the inline fuse on it. also, make sure the black wire is grounded to the car.

Nov 03, 2012 | 2001 Mercury Grand Marquis

1 Answer

Need to know what order to hook up red,yellow,and black wire which to positive which to neg and what size inline fuse is needed for my mcd 5080


Red- power Yellow-Memory Black-Ground

Unless the yellow wire has a fuse built into it then....
Yellow- Power Red-Acc/Ign Black- Ground

If the fuse you are asking about is on the radio t s usually a 10 or 15 amp fuse but if you mean for the power wire for a amp then it depends on the power amount of the amp....look on the amp and find the sum of the fuses on the amp and use a inline fuse that is the next fuse size sum...
Ex. 2 40 watt fuses on the amp then 40+40=80 watts so you would want to get a 100 watt fuse. Also remember you can never go to big for your inline fuse with a amp

Aug 22, 2011 | Jensen Car Audio & Video

1 Answer

It has stopped workin and the red light is flashing.Is this a code and if so how do you read it


The red light is a power protection circuit designed to shut the amplifier down due to an overload or wiring problem. If the amp was playing then shut off, my guess is a problem with the speakers or the speaker wiring. Some amplifiers are only stable to a certain load. For example, most car audio speakers are 4 ohms which is the resistance placed upon your amplifier to produce a certain volume of sound. If you bridge two 4 ohm speakers together in parallel, you cut the resistance in half, thus increasing the amount of power (and volume) to your speakers. This also creates more heat and could, in effect, shut your amplifier down. I would find out how the speakers are wired to determine the resistance of the load your amplifier is pushing. Also check the grounding.

May 26, 2011 | MTX X Thunder 300XD Car Amp

1 Answer

MTX thunder 304 4ch red amp light comes on but no audio have triple checked all connections and they seem alright


if the lights on and there is no sound it's either a cd player issue or your rca issue or the inputs for rca's on the amp are no good. or you have your subs wired at a wrong load to your amp and it is in a constant protection to avoid burning up.

Jun 09, 2009 | Car Audio & Video

1 Answer

No boom in my box


Whats up!!! well check this out. The sub isnt working at all? don't hear anything from it? more then likely it can be one of the following problems.

before you do these steps make sure that the amp levels are all the way low so you dont have a chance in poping the sub for unnecessary jolts of power

you can check to see if the sub itself is good by getting a AA and touching each of the speaker +- on the sub see if you hear anything. More then likely the sub itself is good.
Moving on to the amp. Do you see any lights? red/green? or none

if no lights check the pos/neg terms and make sure there properly installed. have to check underneath the hood for that while your there check the fuse if its a inline one if not then there should be a fuse located on the amp itself.
if you see green then the amp is getting power and the amp is properly grounded
if nothing check the grounding and make sure thats its connected to the frame of the vehicle either by sanding down a small piece of the metal exposing the silver and using a self-tapping screw.

feel free to contact me via yahoo messenger if you have any questions
always forward-jcbproducts

ym-jcbproducts

Nov 16, 2008 | MTX Thunder 1501D Car Audio Amplifier

1 Answer

Radio fuse


did it work when they or you hooked it up ? if it did work when did it stop working there will be a red wire comming out of the new radio there will be a plastic inline fuse holder in line usually you push white plastic holder towards each other and turn one way or the other and it shoul open and reveal the fuse check the fuse with a multi meter or visually inspect the fuse replace with the same amperage and try stereo. if it doesnt work check the black wire under the dash it will be a ground it needs to be attached to the steel frame with a screw holding solidly if there is a ground and the fuse is good inline then see where the red wire from the radio goes trace it to the source if the source is fusebox check the fuse that its attached to or if its attached to another wire to get the power 12 volts dc . take a close peek if power and ground is good to the radio return it or thake it back in the car to let them see that it doesnt work ok good luck and im sorry to hear that your new music box stopped working im shure you will get it working again talk soon

Jul 14, 2008 | 1994 Chrysler LeBaron

2 Answers

Amplifier stays in protect mode


If the positive power cable touched the ground, the fuse inline should have blown. Did it?

Sep 18, 2006 | Kenwood Excelon KAC-X541 88W x 4 Car...

Not finding what you are looking for?
MTX X702 Car Amp Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...