Question about 2003-2007 Kawasaki Kaf620 Mule 3010 4x4 Atv Deep Cycle Trugel Battery

1 Answer

After running for a few minutes temp light will start flashing when u give it gas efi light comes on and will only idle

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 46 Answers

There are a few things that can cause this problem, though with it giving temp indicators and fuel problems I would look at things in the following order:

Fuel filters-Check the pickup screen on the pump first, then any in-line filters along the fuel line.

Oil levels-make sure your motor is properly filled with CLEAN oil. If you are running low, you will get friction which will cause heat buildup and can wear the motor out.

Injectors-Run some SeaFoam through the engine if the fuel filters are clean. With any vehicle that sits without regular usage, debris can foul the injectors.

Spark plugs-If your plugs are fouled our burnt out, you'll get improper ignition and pre-detonation or post-detonation. This is VERY bad for your motor.

Ignition timing-if the motor uses a rotary distributor for ignition, ensure the timing is proper.

Posted on May 01, 2014

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Subaru ecu


try the crank speed/position sensor as this controls the engine revs as well as other things

May 01, 2014 | 2003 Subaru Baja

2 Answers

Stalls after start up, Stalls when braking, then runs fine after a few minutes


Check the ECU engine temperature sensor. If it thinks the engine is hot, it will struggle to run when cold.

Mar 06, 2014 | Volkswagen Beetle Cars & Trucks

1 Answer

Kawasaki mule 2012 4010 aftr running few minutes temp light will start flashing and efi light comes on then rpms just at idle


the thermastat is probly stuck shut replace it with a new one if problem still persist you may have engine damage aka cracked head ect

Feb 08, 2014 | Vehicle Parts & Accessories

1 Answer

Kawasaki mule problems


sounds like its going into limp mode. have codes read as it could be one or more of many possible problems

Feb 08, 2014 | Vehicle Parts & Accessories

2 Answers

Idles roughly, then low when stopped or in park, then dies. Decreasing gas mileage. Slow to accelerate


Sometimes that's caused by a vacuum leak near the manifold area.

Sometimes air in the coolant will cause an idle problem. Air will keep the air temp sensor from sending proper info.
Hope this helps.

Jan 03, 2014 | 2004 Ford Taurus

1 Answer

My car starts fine when engine is warm. I turn it off then try starting it again. then starts up and shuts back off. does it like 3 times in a row. then I wait a few minutes then it starts up when I push...


stalls, are complex
if the engine is good (compression at spec)
it this list.
1: lost electric power to EFI system or spark.
2: bad fuel.
3: bad spark.
4: bad fueling. (too much or too little.
5: EGR stuck open
6: ISC dead. or IAC dead. (idle air valves failing cold)

there are tests for each.
cold start failure only ! all else good, engine tuneup done?
1: ECT fibbing like oh'bummer. (signals water temps of alaska in Panama? "floods, and your right foot helps./..........
2: IAC (cold start fast idle air valve bad) same for right foot....
3: check engine light on running? is it?

ECT can cause gross over fueling.
the IAC dead will cause gross under AIR which in fact causes flooding (less air plus same fuel = flood)
bad fuel.


Oct 12, 2013 | 1999 Honda Accord

1 Answer

Hd 96 roadking efi. Idles ruff and when given gas in gear wants to die unless i give it full throttle. Put in new wires and plugs and after a few minutes of running plugs were black. Also back fires when...


Check the air filter is clean, and the ignition for correct operation. The plug indications are that the engine is running rich (too much fuel) or that the ignition spark is weak.

Mar 17, 2012 | 2000 Harley Davidson FLHR-FLHRI Road king

1 Answer

Vehicle takes 5 minutes to idle by itself. Why?


An inadequate functioning egr system.The exhaust gas recirculation valve uses spent exhaust gases to line the cylinder walls with burnt gases.The purpose of this is to keep the cylinder temperature lower to reduce emissions of oxides of nitrogen.

Jun 01, 2010 | 1990 Pontiac Trans Sport

1 Answer

Electrical Questions Caponord Rally Raid


which gave me the following faul codes P0353 Ign coil 3 malfunction and P1357 Ign coil 3 Short circuit to vbatt/over temp I then started up the bike and the EFI light was flashing again. On checking the sensors page of Tuneboy it showed coils 12 & 4 with a dwell reading of 2.1-- whilst idleing but coil three would sit around 2.1 but would then drop right down to 0.4 for a few seconds before coming back up to 2.1ish. So the questions are, what does short circuit to vbatt/over temp mean? I assume that the fault codes and EFI light flashing are connected with the fluctuation of the dwell reading on coil three? Does this mean that coil three is on its way out and that I should order a new one? I should add that the bike is running fine. My main concern is that in two weeks time I'm taking the bike to France for 2 weeks / 2000+ miles and don't want to have coil problems whilst away. On a different subject (although still electrical) can anyone tell me the colours of the tacho feed wire, I have studied the diagram from the Caporider site and in my handbook but still can't find them,I had two coil failures. Both of them exhibited extreme dwell variance.,,,

Nov 10, 2008 | 2004 Aprilia Caponord Rally Raid

Not finding what you are looking for?
2003-2007 Kawasaki Kaf620 Mule 3010 4x4 Atv Deep Cycle Trugel Battery Logo

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bikemaster Vehicle Parts & Accessories Experts

 Russ Hill
Russ Hill

Level 3 Expert

3187 Answers

R.Karthikeyan
R.Karthikeyan

Level 2 Expert

122 Answers

Willie Keisser

Level 3 Expert

457 Answers

Are you a Bikemaster Vehicle Part and Accessory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...