Question about Vehicle Parts & Accessories

1 Answer

Kawasaki mule problems

Temp light will start flashing then efi light will not run except at idle

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 120 Answers

Sounds like its going into limp mode. have codes read as it could be one or more of many possible problems

Posted on Feb 21, 2014

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 57 Answers

SOURCE: #1cylinder not firing on 2003 3010 Kawasaki mule

if its firing ok on other cylinders, unlikely to be pump or fuel filter, focus on electrics, plug, ht lead etc

Posted on Dec 08, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2003 kawasaki mule model 3000 it wont say running at idle what to do


Full tune up and carb clean .get new plug,air filter.oil Chang ,carb clean and adjustment.that should do it.,., try fuel filters and test fuel pump see if it's functioning properly.,.

Dec 10, 2016 | kawasaki 2005 Mule 3010 4x4

1 Answer

My 2003 Kawasaki prairie 360 when u install the hose from the air box it will only idle u can not rev it up take the hose off and it runs fine


2003 360 Prairie 4x4 cutting out... I'm stumped! - Kawasaki ...

www.kawasakimotorcycle.org > ... > Kawasaki ATV and Mule
Dec 14, 2011 - This 360 4x4 has me stumped. ... 2003 360 Prairie 4x4 cutting out. ....It idles just fine, it has perfect throttle response, it just won't rev without ... 2006 Prairie 4x4 governor prob?
Oct 1, 2009
04 Prairie 360 Knocking when Idling and Belt Light on.
Jan 26, 2009
Older Prairie Tune Up Questions
Sep 19, 2008
Prairie 360 (Limp Mode)
Jan 4, 2005
More results from www.kawasakimotorcycle.org

Nov 19, 2015 | kawasaki Motorcycles

1 Answer

Kawasaki mule 2500 keeps running temp


go to TRACTORBYNET.COM enter OVERHEATING MULE in the question block. there is a forum on this problem, and may as well register.

Oct 05, 2015 | kawasaki Motorcycles

2 Answers

Kawasaki mule problems


It sounds like it is starving for fuel

May 05, 2014 | kawasaki Motorcycles

1 Answer

Kawasaki mule 2012 4010 aftr running few minutes temp light will start flashing and efi light comes on then rpms just at idle


the thermastat is probly stuck shut replace it with a new one if problem still persist you may have engine damage aka cracked head ect

Feb 08, 2014 | Vehicle Parts & Accessories

1 Answer

After running for a few minutes temp light will start flashing when u give it gas efi light comes on and will only idle


There are a few things that can cause this problem, though with it giving temp indicators and fuel problems I would look at things in the following order:

Fuel filters-Check the pickup screen on the pump first, then any in-line filters along the fuel line.

Oil levels-make sure your motor is properly filled with CLEAN oil. If you are running low, you will get friction which will cause heat buildup and can wear the motor out.

Injectors-Run some SeaFoam through the engine if the fuel filters are clean. With any vehicle that sits without regular usage, debris can foul the injectors.

Spark plugs-If your plugs are fouled our burnt out, you'll get improper ignition and pre-detonation or post-detonation. This is VERY bad for your motor.

Ignition timing-if the motor uses a rotary distributor for ignition, ensure the timing is proper.

Feb 08, 2014 | 2003-2007 Kawasaki Kaf620 Mule 3010 4x4...

1 Answer

22re starts good but after a minute starts to lopes


surge, lopes, hunts, all same. but does it do this hot/cold or both engine temps.?????????
Im and expert on this.... done many and is related to EFI fuel controls
big time..... (ive even programmed Megasquirts to do this)
first the rules then causes.
Rule 1, The EFI controls idle at all times. so that proves.
Macro reasons.
1: EFI lost control. (stuck ISC?)
2: Engine is missiing (too rich, too lean or never tuned up)
3: or both, usually #2 causes 1 ,

there are ways to solve this riddle
my ways are simple
i test the ISC, see if it works, (unplug it or power it with 12v power supply, ) Id clean the ISC first.

this old car 1992 , scan tools are hard to find for OBD1 cars.
so cant look to see if CLosed loop is working, I can with a scope
but you dont have a scope.
you could put in the diagnostic check jumper and hope for an error code to flash out.
you can look as spark plugs (newones work wonder) and see
if its burning fuel correctly (like old school carb days)
black?> white tips>
all engine carbs and EFI all will surge when lean,.
all, and on EFI it will in fact try to stop the surge,
if lean enough the EFI can actually make the surge worse
is it tries desperately to correct the impossible.@!

that be surge.
i learnd that loping my mule one day.. LOL

Jan 21, 2014 | 1992 Toyota Pickup

1 Answer

Kawasaki mule misfires only in reverse


I have an 88 Mule with the same problem. I thought maybe the float level was wrong but I cleaned and checked the carbs and it made no difference. I question fuses because it runs fine forward. There is a wire from the neutral/reverse switch going to the icigniter so I'm wondering if it is related to that. I'm sure someone has fought this problem. Thanks for the help.

Mar 03, 2013 | kawasaki Motorcycles

1 Answer

I have a Kawasaki Mule 3000. It is hard to keep


take the spring off the screw and use teflon tape so you can adjust the screw further

Sep 11, 2009 | kawasaki Sport & Outdoor - Others

Not finding what you are looking for?
Vehicle Parts & Accessories Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vehicle Parts & Accessories Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Thomas Perkins
Thomas Perkins

Level 3 Expert

14378 Answers

Brad Brown

Level 3 Expert

15950 Answers

Are you a Vehicle Part and Accessory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...